The officially official Devuan Forum!

You are not logged in.

#1 2020-05-25 18:32:20

toru
Member
Registered: 2020-04-12
Posts: 21  

[Solved] CPU frequency scaling on Devuan Beowulf RC

I use MATE, with the "CPU Frequency Scaling Monitor" in my panel in order to adjust my CPU frequency.  For me adjusting the frequency is a feature I must have because if I don't set the frequency, my computer overheats.  But this feature worked for this CPU in Ascii, yet not in Beowulf.  So I have 2 questions:

1.  Does anyone know why that might be or what I might be able to do to fix it?
2.  Does anyone know of alternative methods of adjusting the CPU frequency?  (The only method I know of for it is the MATE feature I described)

Thanks!

Last edited by toru (2020-06-01 01:49:59)

Offline

#2 2020-05-25 20:14:01

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

What is the CPU? How does the utility fail? What actually happens when you try to use it? Are you sure you need it with beowulf's newer kernel? The overheating problem might be fixed for that.

Have you seen thermald? It only offers a systemd unit file for autostarting but I'm sure we could hack something together for sysvinit if you want.

Alpine Linux have an OpenRC init script but you would have to switch to /sbin/openrc-init as PID1: https://git.alpinelinux.org/aports/tree … mald.initd

There is also linux-cpupower but that's command line only, the cpupower-gui package is only available in chimera/ceres.


Black Lives Matter

Offline

#3 2020-05-25 20:43:38

toru
Member
Registered: 2020-04-12
Posts: 21  

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

1.  "AMD dual core processor a9-9420 with turbo core technology up to 3.6 GHz"
2.  The utility only gives me 3 options when I try to use it in Beowulf.  Ondemand, Performance, and Schedutil, if I remember right.
3.  I'm actually using the backported kernel with ascii, so I think it is the same kernel on both installs, so I doubt the kernel fixes the problem, as it is present on ascii.
4.  I haven't heard of thermald or linux-cpupower before I think, thank you for making me aware of these.  I currently use sysvinit on Beowulf because I saw the warning that openrc is still experimental.  Do you think it would be fine to use openrc instead, and what do you base that on?

I did some searching on my own too and saw a cpufreqd in the repos, and also heard of a "userspace frequency governor" from a friend.

EDIT:  Oh and I don't mind using a command line program.

Last edited by toru (2020-05-25 21:02:07)

Offline

#4 2020-05-25 21:05:36

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

toru wrote:

Do you think it would be fine to use openrc instead, and what do you base that on?

Probably. I've used it myself and it is actively developed by Gentoo & Alpine Linux. But to use the Alpine init script you would have to use /sbin/openrc-init rather than just the service manager, which might not be the best idea for a production machine.

I've just run the systemd unit file through sysd2v and it generated this sysvinit script:

#!/bin/sh
# Generated by sysd2v v0.3  --  http://www.trek.eu.org/devel/sysd2v
# kFreeBSD do not accept scripts as interpreters, using #!/bin/sh and sourcing.
if [ true != "$INIT_D_SCRIPT_SOURCED" ] ; then
    set "$0" "$@"; INIT_D_SCRIPT_SOURCED=true . /lib/init/init-d-script
fi
### BEGIN INIT INFO
# Provides:       thermald dbus-org.freedesktop.thermald
# Required-Start: $remote_fs
# Required-Stop:  $remote_fs
# Default-Start:  2 3 4 5
# Default-Stop:   0 1 6
# Description:    Thermal Daemon Service
### END INIT INFO
DAEMON=/usr/sbin/thermald
DAEMON_ARGS="--no-daemon --dbus-enable"
PIDFILE=/var/run/thermald-sysd2v.pid
START_ARGS="--background --make-pidfile"

^ Place that in /etc/init.d/thermald and enable the service to autostart thermald at boot.


Black Lives Matter

Offline

#5 2020-05-25 21:44:57

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,571  

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

There' s cpufrequtils which will allow you to set the governor and/or frequency. Apparently, the kernel does some frequency scaling on its own these days, but there may be times you want to override that.

There's also cpulimit which will let you limit the amount of cpu(s) that a particular process or program can use. I use that to keep from overheating a laptop when mksquashfs is running.

Both are command-line tools and are easy to use.

Offline

#6 2020-05-26 06:37:09

Geoff 42
Member
Registered: 2016-12-15
Posts: 336  

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

Head_on_a_Stick wrote:

Alpine Linux have an OpenRC init script but you would have to switch to /sbin/openrc-init as PID1: https://git.alpinelinux.org/aports/tree … mald.initd

I think that you could use OpenRC as installed, which uses SysVinit as PID 1. I feel that using openrc-init as PID 1 is not quite there yet, as there are problems shutting down.

https://dev1galaxy.org/viewtopic.php?pid=21756#p21756

Geoff

Last edited by Geoff 42 (2020-05-26 06:39:20)

Offline

#7 2020-05-26 19:54:45

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

^ Thanks Geoff, sterling work you're doing.


Black Lives Matter

Offline

#8 2020-05-26 21:51:13

toru
Member
Registered: 2020-04-12
Posts: 21  

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

Head_on_a_Stick:  Thank you!  And thanks for alerting me to the existence of that web site, it seems like it may be useful at some point too.  I'll be seeing what software works for me and that I like the most out of the ones I know of for frequency settings, and if that's thermald I'll probably use the script.

fsmithred:  Thanks!  I've noted these down, maybe cpufrequtils is what I'll end up using, we'll see.

Geoff 42:  Oh, thank you for the information.

It is always wonderful when asking a question leads to me learning about a bunch of new things.  Thank you all!

Offline

#9 2020-05-27 17:18:51

chris2be8
Member
Registered: 2018-08-11
Posts: 91  

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

Do you have a desktop or a laptop? In either case my first thought would be to clean dust etc out of it to stop it overheating. If that fails on a desktop I would think of improving case ventilation or fitting a better cooler.

I've had systems where clearing dust and fluff out reduced CPU temperature several degrees.

Chris

Offline

#10 2020-06-01 01:46:32

toru
Member
Registered: 2020-04-12
Posts: 21  

Re: [Solved] CPU frequency scaling on Devuan Beowulf RC

chris2be8:  Thanks, it is a laptop that is over a year old I believe.  I have not tried cleaning dust out, but that may help.

**Update:**  linux-cpupower and cpufrequtils both seem to fix the problem.  They only work once per boot of the OS for an unknown reason, but that's enough to set it for the rest of the operation time.  Also, for an unknown reason, after that I can then set the frequency the old way, using MATE's CPU Frequency Scaling Monitor.  Thermald did not appear to actually be managing the temperature remotely adequately for the short time that I tried it.  I'm currently using linux-cpupower.  Thanks very much!  This can be marked as solved.

Last edited by toru (2020-06-01 01:48:07)

Offline

Board footer