The officially official Devuan Forum!

You are not logged in.

#1 2020-05-10 22:54:29

Kiwi Rider
Member
Registered: 2020-02-01
Posts: 8  

Updating X

Good morning, hope you and yours are well.

Attempting to install the appropriate AMD driver for my video card, I get the following error :

error: Detected X Server version 'XServer 1.19.2_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer 1.19.2_64a:none:4.9.0-12-amd64:)
Installation will not proceed.

While better than many systems, I find the graphics performance lacking at times and would love to see an improvement.

As per the thread at https://dev1galaxy.org/viewtopic.php?id=3296 I have installed the firmware and standard radeon driver. The card is a Radeon HD 6950  - sure it's older by today's standards but it's the best I can afford by my budget standards smile

Thanks in advance for any suggestions on how to improve performance.

Offline

#2 2020-05-11 07:35:11

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 207  

Re: Updating X

The only appropriate driver for your videocard is xserver-xorg-video-radeon from Devuan repository.

Offline

#3 2020-05-12 16:10:38

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 972  
Website

Re: Updating X

Kiwi Rider wrote:

I get the following error

Catalyst ("fglrx") doesn't work any more.


Black Lives Matter

Offline

#4 2020-05-13 09:23:37

Magnus
Member
Registered: 2020-03-14
Posts: 15  

Re: Updating X

Head_on_a_Stick wrote:
Kiwi Rider wrote:

I get the following error

Catalyst ("fglrx") doesn't work any more.

That forced me to buy a new graphic card.  - Then it affected Ceres. - A NVIDIA card...

Offline

#5 2020-05-13 16:33:10

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 972  
Website

Re: Updating X

Well the situation is markedly better for new AMD cards because AMD themselves are effectively writing the open source drivers and they now out-perform the proprietary version for most tasks.


Black Lives Matter

Offline

#6 2020-05-13 22:30:08

Magnus
Member
Registered: 2020-03-14
Posts: 15  

Re: Updating X

Head_on_a_Stick wrote:

Well the situation is markedly better for new AMD cards because AMD themselves are effectively writing the open source drivers and they now out-perform the proprietary version for most tasks.

As long as the AMD card is new... But my experience say that NVIDIA upgrade theire drivers to support new X versions for a longer lasting period than AMD does.

Offline

#7 2020-05-15 08:42:16

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 207  

Re: Updating X

Magnus wrote:
Head_on_a_Stick wrote:

Well the situation is markedly better for new AMD cards because AMD themselves are effectively writing the open source drivers and they now out-perform the proprietary version for most tasks.

As long as the AMD card is new... But my experience say that NVIDIA upgrade theire drivers to support new X versions for a longer lasting period than AMD does.

Instead of supporting proprietary fglrx driver AMD preferred to support fully featured free driver. It's xserver-xorg-video-radeon and Mesa in Devuan repository. It works even with very old AMD GPUs.

Nvidia don't support GNU/Linux. Proprietary blob is total garbage. It doesn't even support OpenGL (there is NvGL, which is NOT OpenGL). So downgrading to nvidia is very big mistake. Nvidia hate everything related to freedom and choice.

Offline

#8 2020-05-15 10:41:22

Magnus
Member
Registered: 2020-03-14
Posts: 15  

Re: Updating X

ToxicExMachina wrote:
Magnus wrote:
Head_on_a_Stick wrote:

Well the situation is markedly better for new AMD cards because AMD themselves are effectively writing the open source drivers and they now out-perform the proprietary version for most tasks.

As long as the AMD card is new... But my experience say that NVIDIA upgrade theire drivers to support new X versions for a longer lasting period than AMD does.

Instead of supporting proprietary fglrx driver AMD preferred to support fully featured free driver. It's xserver-xorg-video-radeon and Mesa in Devuan repository. It works even with very old AMD GPUs.

Nvidia don't support GNU/Linux. Proprietary blob is total garbage. It doesn't even support OpenGL (there is NvGL, which is NOT OpenGL). So downgrading to nvidia is very big mistake. Nvidia hate everything related to freedom and choice.

In any case, there was no driver with OpenGL support - I need OpenGL for Dark Table - for my AMD HD7970 a year ago, because AMD did not upgrade its drivers to the version of X that Ceres used. However, NVIDIA's drivers work well. OpenGL also works well with NVIDIA's drivers and NVIDA usually has the habit of upgrading its drivers considerably longer than AMD does.
And about freedom and choise. The only wish I have is a working graphic card that last more than a few years.

Must tell: My mom has my old computer from 2003 with ASCII installed. The graphic card is a NVIDIA GEFORCE 4 TI 4200 and there are still working proprietary drivers for it.

Last edited by Magnus (2020-05-15 11:26:35)

Offline

#9 2020-05-15 20:55:33

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 207  

Re: Updating X

Magnus wrote:

In any case, there was no driver with OpenGL support - I need OpenGL for Dark Table - for my AMD HD7970 a year ago, because AMD did not upgrade its drivers to the version of X that Ceres used. However, NVIDIA's drivers work well. OpenGL also works well with NVIDIA's drivers and NVIDA usually has the habit of upgrading its drivers considerably longer than AMD does.
And about freedom and choise. The only wish I have is a working graphic card that last more than a few years.

Must tell: My mom has my old computer from 2003 with ASCII installed. The graphic card is a NVIDIA GEFORCE 4 TI 4200 and there are still working proprietary drivers for it.

I think you're spreading misinformation. Ceres has one of newest drivers for AMD videocards including Radeon HD 7970. It has the best OpenGL support ever.

Offline

#10 2020-05-18 07:38:45

Magnus
Member
Registered: 2020-03-14
Posts: 15  

Re: Updating X

ToxicExMachina wrote:

I think you're spreading misinformation. Ceres has one of newest drivers for AMD videocards including Radeon HD 7970. It has the best OpenGL support ever.

And the name of the driver is?

Offline

Board footer