The officially official Devuan Forum!

You are not logged in.

#1 2020-04-16 10:47:27

Geoff 42
Member
Registered: 2016-12-15
Posts: 328  

/var & /home not unmounting correctly under OpenRC

I am runnning OpenRC in Beowulf.

When I look in the log file /var/log/rc.log I can see that /home and /var are failing to unmount properly on shutdown and that on the following boot, they are both recovered from their journals.

I would assume that things are not being shutdown in the correct order and/or the dependencies are incorrect. I see that umountfs is in /etc/runlevel/off I also see that /etc/runlevel/shutdown is empty.

With some pruning, the log file looks like this :-

[....] Unmounting temporary filesystems...umount: /tmp: target is busy.
[FAILfailed.
[....] Deactivating swap...[ ok done.
[....] Unmounting local filesystems...umount: /var: target is busy.
umount: /home: target is busy.
[FAILfailed.
[....] Stopping hot-plug events dispatcher: udevd[ ok .

rc shutdown logging stopped at Wed Apr 15 20:49:49 2020

followed by :-

rc sysinit logging started at Thu Apr 16 07:34:11 2020

   OpenRC 0.42.1 is starting up Linux 4.19.0-8-amd64 (x86_64) [XENU]

* /proc is already mounted

etc, etc...

[....] Activating swap...[ ok done.
[....] Setting up LVM Volume Groups...[ ok done.
[....] Checking file systems...fsck from util-linux 2.33.1
/dev/mapper/SSD0-home: recovering journal
/dev/mapper/SSD0-home: clean, 169879/2531328 files, 7506728/10125312 blocks
var: recovering journal
var: clean, 18460/610800 files, 1319940/2441216 blocks
/dev/mapper/HDD0-Flightgear: clean, 48736/155648 files, 290643/600064 blocks
boot: clean, 358/64000 files, 206879/256000 blocks
/dev/mapper/HDD0-archive: clean, 270513/21626880 files, 32926707/86507520 blocks
fsck.fat 4.1 (2017-01-24)
/dev/mapper/HDD0-xen--boot: 3 files, 9637/261629 clusters
[ ok done.
[....] Cleaning up temporary files... /tmp[ ok .
[....] Mounting local filesystems...[ ok done.

etc...

This is not the standard set-up as I have replaced SysV init with openrc-init.

Geoff

Offline

#2 2020-04-18 13:32:30

Geoff 42
Member
Registered: 2016-12-15
Posts: 328  

Re: /var & /home not unmounting correctly under OpenRC

I have been looking into this and scratching my head!

As my set-up is a bit experimental, I will take this over to my earlier thread under DIY, where I discussed using newer versions of OpenRC :-

https://dev1galaxy.org/viewtopic.php?id=3371

Geoff

Offline

Board footer