The officially official Devuan Forum!

You are not logged in.

#1 2019-11-19 13:21:21

GNUser
Member
Registered: 2017-03-16
Posts: 496  

disable touchpad without disabling trackpoint [SOLVED]

I run Devuan ASCII on my T400 laptop. I only use the trackpoint ("nipple mouse"). To me, the touchpad is just a nuisance.

I've discovered (by monitoring output of sudo cat /dev/input/event5) that the touchpad generates random input while the lid is closed. This causes applications that should run while the system to be idle (e.g., xscreensaver) to never run while the lid is closed.

I've tried to disable the touchpad via xinput, synaptics and evtest (evtest --grab /dev/input/event5 >/dev/null 2>&1), but none of these remedy the issue. The only remedy I've found is to unbind the touchpad's driver with this command:

# echo serio1 >/sys/bus/serio/drivers/psmouse/unbind

Unfortunately, the above command has the unacceptable side effect of simultaneously unbinding serio2, which renders my trackpoint ("nipple mouse") inoperable.

Please, do you know how to *completely* disable the touchpad (e.g., via unbinding its driver) without disabling the trackpoint?

P.S. This may be useful:

bruno@thinkpad:~$ cat /proc/bus/input/devices
---snip---
I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=1
B: EV=b
B: KEY=420 30000 0 0 0 0
B: ABS=11000003

I: Bus=0011 Vendor=0002 Product=000a Version=0000
N: Name="TPPS/2 IBM TrackPoint"
P: Phys=synaptics-pt/serio0/input0
S: Sysfs=/devices/platform/i8042/serio1/serio2/input/input7
U: Uniq=
H: Handlers=mouse1 event6
B: PROP=21
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

P.S. Solution is in post #3. It's a hardware solution, not the software solution I was hoping to find.

Last edited by GNUser (2019-11-19 21:07:50)

Online

#2 2019-11-19 17:58:48

yeti
Member
Registered: 2017-02-23
Posts: 157  

Re: disable touchpad without disabling trackpoint [SOLVED]

On T510 I use Fn-F8 to dispable (or re-enable) the touchpad and the trackpin stays active.


"I toggle, therefor I am." — Clock Bit.
"There is no PLANET-B!" — ???
"Vrijdag voor VT100!" — Yeti.
"Stop slavery! Free all mitochondria!" — Yeti.

Offline

#3 2019-11-19 18:07:14

GNUser
Member
Registered: 2017-03-16
Posts: 496  

Re: disable touchpad without disabling trackpoint [SOLVED]

Thanks, yeti. Fn-F8 supposedly turns off the touchpad on the T400 as well (based on the little blue drawing on the F8 key), but it actually has no effect when I press it.

I decided to go with a hardware solution: Unplugging the touchpad's ribbon (the ribbon is just under the palmrest--it was trivial to find and disconnect) smile

Now the touchpad is completely disabled, but the trackpoint and its three buttons (just under the spacebar) are fully operational.

(I find it strange that on software level the trackpoint seems to be considered a child device of the touchpad, even though the hardware-level reality is that the two devices are independent.)

Last edited by GNUser (2019-11-19 21:07:00)

Online

#4 2019-11-19 20:35:13

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 383  

Re: disable touchpad without disabling trackpoint [SOLVED]

I think synclient has an option to disable the "TouchPad" - see man synaptics. Though that might be co-joined with the nipple as well.

Offline

#5 2019-11-19 20:53:47

GNUser
Member
Registered: 2017-03-16
Posts: 496  

Re: disable touchpad without disabling trackpoint [SOLVED]

Thanks, ralph.ronnquist. Indeed it does (synclient TouchpadOff=1). This does not interfere with the trackpoint.

However, I've found that synclient, xinput, et al. are only effective in preventing the touchpad from controlling the pointer. That's it. On a low level, they leave the touchpad very much alive--run sudo cat /dev/input/eventX and watch all the chatter from the "disabled" touchpad when anything comes near it. This noise prevents the system from becoming idle when laptop's lid is shut.

Last edited by GNUser (2019-11-19 20:55:49)

Online

#6 2019-11-20 05:11:59

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 156  

Re: disable touchpad without disabling trackpoint [SOLVED]

I know simple solution: reboot, enter the CMOS Setup, disable touchpad, save changes, boot Devuan.

For coreboot/libreboot the following thing will probably work:

https://wej.k.vu/coreboot/coreboot_on_t … kpad_x220/

One thing that was especially of interest to me is the ability to disable the touchpad, since I don't like using it and very much prefer the Thinkpad's track point. Fortunately it is possible to disable it with Coreboot and nvramcui makes it pretty easy to change.

Offline

#7 2019-11-20 15:16:16

GNUser
Member
Registered: 2017-03-16
Posts: 496  

Re: disable touchpad without disabling trackpoint [SOLVED]

Thank you very much for that, ToxicExMachina. Great find!!! My laptop does happen to run Libreboot. I had not heard of nvramcui (or its cousin, nvramtool) before. Very interesting.

According to this, Libreboot locks the CMOS table, so the only way to modify BIOS settings is to download the Libreboot rom, modify it with nvramtool, then flash the modified rom.

Alas, touchpad does not seem to be an option in my CMOS table:

$ sudo nvramtool -a
boot_option = Fallback
baud_rate = 115200
debug_level = Spew
sata_mode = AHCI
power_on_after_fail = Disable
first_battery = Primary
bluetooth = Enable
wwan = Enable
wlan = Enable
trackpoint = Enable
fn_ctrl_swap = Disable
sticky_fn = Disable
boot_devices = 
boot_default = 0x0
power_management_beeps = Enable
low_battery_beep = Enable
uwb = Disable
hybrid_graphics_mode = Integrated Only
gfx_uma_size = 256M
volume = 0x3

This is the closest I've come to a software solution.

Online

Board footer