The officially official Devuan Forum!

You are not logged in.

#1 2019-09-24 06:28:40

devuanuser
Member
Registered: 2019-03-14
Posts: 21  

Devuan / Video issue

I have a problem with firefox on Devuan which seems to be devuan only at this stage.

I tested this on a machine where I can dual boot Devuan and MX18 on the same hardware.

I have the same version of firefox installed on both. 69.0

When I play an mp4 video in firefox originating from an email, both plays it natively in firefox and not with an external app like VLC.

On MX18, the video plays smoothly.
On Devuan it stutters and freezes, seemingly dropping massive amounts of frames.

Any idea where I can start troubleshooting this to get
Devuan/firefox to p[lay videos properly.?

Offline

#2 2019-09-24 12:38:20

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 329  
Website

Re: Devuan / Video issue

Try

# apt install libavcodec-extra

Unless you already have it in your Devuan system, ofc.

EDIT: does the stock firefox-esr package in Devuan work for you?

Last edited by Head_on_a_Stick (2019-09-24 12:38:55)


Fabricando fit faber

Offline

#3 2019-09-27 03:42:15

devuanuser
Member
Registered: 2019-03-14
Posts: 21  

Re: Devuan / Video issue

Thanks for the response.

apt install libavcodec-extra
did not help.

No stock esr is a bit of a mess generally for me and I try not to use it. I usually just install a latest standard Firefox. That said, I did try it initially with
ESR, the same problem is encountered with newest firefox and ESR.


I also tried playing the video with VLC and got an error as follows
*"5 minutes of delayed video (Slow computer?) "*

Lol !! Slow computer? This is a 24 core 2.4GHz per core rackserver with 32GB memory and an AMD gaming video card that plays Heaven Benchmark smoothly at the maximum of my monitor resolutions.... sheez!
I need the fast video card for Video editing with Blackmagic Davinci etc and Lightworks and it works fantastic on this machine.

The error must in this case seemingly Devuan related, because if I dual boot into MX18, then it plays perfect on the SAME machine both running XFCE
Only difference is the OS.

Last edited by devuanuser (2019-09-27 03:50:54)

Offline

#4 2019-09-27 16:58:47

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 329  
Website

Re: Devuan / Video issue

Must be firmware then.

# apt install firmware-misc-nonfree

You may need to add the contrib & non-free components to your sources first though.


Fabricando fit faber

Offline

#5 2019-09-28 05:06:18

devuanuser
Member
Registered: 2019-03-14
Posts: 21  

Re: Devuan / Video issue

That wasnt installed, I addedrepos and installed it, but error remains the same.

In adition I noticed terminal output in vlc says avcoded decode error and in VLC just plays a blank black screen. In firefox it plays audio and shows video, but it drops frames probably due to the avcodec decode error.


Maybe this ? A bug is mentioned. Althouigh it is for windows, the bug would be the same.
https://forum.videolan.org/viewtopic.php?t=144998

If this is in fact the problem, then Devuan must be using oooooold package versions.

Last edited by devuanuser (2019-09-28 05:11:55)

Offline

#6 2019-09-28 14:09:17

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 329  
Website

Re: Devuan / Video issue

Both Devuan ASCII and MX-18 are based on Debian oldstable (stretch) but MX includes many backported packages.

Try comparing the configuration of the desktops, for example:

lspci -k | grep -iA2 'vga\|3d\|display'
xrandr --listproviders
glxinfo | grep 'OpenGL r'

EDIT: the X.org log would probably be useful also.

Last edited by Head_on_a_Stick (2019-09-28 14:10:04)


Fabricando fit faber

Offline

Board footer