The officially official Devuan Forum!

You are not logged in.

#1 2019-03-24 19:58:02

Geoff 42
Member
Registered: 2016-12-15
Posts: 265  

Upgrading laptop from ASCII to Beowulf

After trying Beowulf on a VM under Xen, I tried upgrading my Asus ZenBook UX305.
I started this with Debian Jessie and had upgraded over time to Deuan Jessie and then to ASCII.
Having replaced ascii with beowulf in /etc/apt/sources.list, then using apt-get update and apt-get dist-upgrade would not have upgraded the 3 elogind packages, so I tried aptitude full-upgrade and let it do its thing, which seems to have largely worked. I use LXQt with OpenBox and it needs a little bit of tweeking to get everything as I like it, but it seems to basically work.

However va-driver-all is marked as a broken package as it depends on mesa-va-drivers.

E: /var/cache/apt/archives/mesa-va-drivers_18.3.4-2_amd64.deb: trying to overwrite '/usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so', which is also in package vdpau-va-driver:amd64 0.7.4-dmo6

Using the aptitude command which fsmithred supplied I looked for packages not in testing :-

aptitude search ~i -F"%p# %v# %t#"|grep -v testing
returns a lot of packages, (about 100 according to wc).

I then used Synaptic to carry out the tidying up.

I forced the version of upower to 0.99.10-1 which counts as a downgrade!
It also removes va-driver-all and moves to libupower-glib3, which gets rid of the broken package problem.
I downgraded vdpau-va-driver to the Beowulf version.

As I am using LXQt instead of LXDE, I removed the LXDE components.

I had consolekit installed as well as elogind, so remove consolekit,
which does some other sorting out of libpolkit stuff.
Initially the shutdown icon only logged me out, but with libpolkit sorted out, shutdown now works.

The old gksu from ASCII is still installed and works!

apt-get autoremove does some minor tidying up.

Where possible I forced versions of packages to the Beowulf ones.
Both Firefox-esr and Chromium have a version in Beowulf which appears to be older, so I forced the versions.
Also devuan-baseconf. Trying to force the version of that crashed Synaptic.
So I had to sort sources.list and removed the backports which don't seem ready yet!

I removed lots of packages which were not in Beowulf. The Beowulf stuff gets reported as "testing".
The others are reported as "now", which I guess means that it is not in the selected repositories.
Packages which I removed include :-
php7.0
ruby 2.1 & 2.2
leafpad
an older WordPress theme from ASCII
webkit-image-qt possibly used by the old version of Claws-mail and is now replaced by Dillo.
as well as numerous libraries and old versions of things, which had no dependencies.

After the version forcing and the removals I was left with gksu and some libraries on which it is dependent,
as well as keeping one old kernel, just in case it was needed.

$ aptitude search ~i -F"%p# %v# %t#"|grep -v testing | awk -e '{print $1,"   \t\t" $2,"\t" $3}' -
gksu    		2.0.2-9+b1 	now
libgksu2-0    		2.0.13~pre1-9+b1 	now
libgnome-keyring-common    		3.12.0-1 	now
libgnome-keyring0    		3.12.0-1+b2 	now
libgtop-2.0-10    		2.34.2-1 	now
libssl1.0.0    		1.0.2d-1 	now
linux-image-4.18.0-0.bpo.1-amd64    		4.18.6-1~bpo9+1 	now

Things are now largely running normally.

Geoff

Offline

#2 2019-03-24 20:37:04

dxrobertson
Member
Registered: 2017-05-04
Posts: 231  

Re: Upgrading laptop from ASCII to Beowulf

Another LXQT user here.  Just wanted to let you know that lxqt-sudo seems to be stable and can be used in lieu of gksu.  I have been using it for a while without issue.  Using elogind here too, with LightDM login manager, as well as Openbox.  I have been very happy with LXQT as well as Beowulf.  Running this combo on 3 machine, no problems.

Last edited by dxrobertson (2019-03-24 20:38:18)

Offline

#3 2019-03-25 14:16:56

Geoff 42
Member
Registered: 2016-12-15
Posts: 265  

Re: Upgrading laptop from ASCII to Beowulf

I forgot to mention that I use LXDM as the login manager. I have tried some of the others but prefer this one. It has the advantage over at least one of the alternatives that you can shutdown or reboot from LXDM, which came in useful when I was having some difficulty shutting down when logged in (now sorted).
It is also clear how you select alternative desktops as it has a box at the bottom to choose from.

Geoff

Offline

Board footer