The officially official Devuan Forum!

You are not logged in.

#1 2018-12-17 15:37:31

Geoff 42
Member
Registered: 2016-12-15
Posts: 250  

Upgrade - grave bugs - Apache, Chromium & Firefox

When I update an ASCII machine with the usual

apt-get update
apt-get dist-upgrade

It reports :-

Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of apache2 (2.4.25-3+deb9u5 → 2.4.25-3+deb9u6) <Outstanding>
 b1 - #916375 - apache2: Segmentation fault when mod_perl.so is enabled
grave bugs of chromium (69.0.3497.92-1~deb9u1 → 71.0.3578.80-1~deb9u1) <Outstanding>
 b2 - #913116 - Fails to start without chromium-sandbox installed
serious bugs of firefox-esr (60.2.2esr-1~deb9u1 → 60.4.0esr-1~deb9u1) <Forwarded>
 b3 - #913604 - [firefox-esr] Lack of login storage API on recent firefox
Summary:
 apache2(1 bug), chromium(1 bug), firefox-esr(1 bug)

Are you sure you want to install/upgrade the above packages? [Y/n/?/...] n
**********************************************************************
****** Exiting with an error in order to stop the installation. ******
**********************************************************************

I was able to upgrade the remaining packages with the same proceedure as last time :-

https://dev1galaxy.org/viewtopic.php?pid=4510#p4510

As for the bugs,
Apache is reported to crash if you use mod_perl.
Chromium is reported to not start without chromium-sandbox. I was unable to locate this sandbox.
Firefox is reported to have a security problem which I don't really understand.

Geoff

Offline

Board footer