The officially official Devuan Forum!

You are not logged in.

#1 2018-10-25 13:10:05

thierrybo
Member
Registered: 2017-11-11
Posts: 16  

no /usr/bin/X after 'apt full-upgrade'

Hi,

I said to myself :I will not be the only one, but alas I do not see any message about this, so this should be my fault... hmm

I use Devuan since 01/01/2018 (after 12 years using Ubuntu=setup), stable ascii, with backports activated. Here is the full list of programs I installed from backports :

- virtualbox
- virtualbox-qt
- libcuda1
- libnvidia-encode1
- wine
- wine32
- nvidia-driver
- nvidia-detect
- mesa-vulkan-drivers
- mesa-vulkan-drivers:i386
- vulkan-utils

I also use chrome repository:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

and ceres repository, but this is ONLY to show what is available with

apt list -a

, I never installed any program from sid,and the repository is pinned like this :

Package: *
Pin: release a=unstable
Pin-Priority: -1

Package: *:i386
Pin: release a=unstable:
Pin-Priority: -1


My setup use Openbox Window Manager but no Display Manager, I use startx to run Openbox.

I use

 apt full-upgrade

as I do usually. Yesterday I ran it, and now when I type startx i get :

/etc/X11/xinit/xserverrc: 3: exec: /usr/bin/X: not found

Reading the apt log below, it turns out that XORG has been replaced by wayland automatically, how can this occurs?

By the way some important packages for me have been removed :

- default-jre and openjdk-8-jre sad
- alsamixergui sad
- xserver-xorg-core xserver-xorg-video-nouveau ....
- ffmpeg !!!
- simplescreenrecorder mad
- nvidia-driver mad
- yelp sad
- python-wxgtk3.0 python3-pyqt5 python3-poppler-qt5
- remarkable sad
- paprass
- breeze
- mesa-utils
- abiword mad
- kdenlive mad
- compton mad
- steam mad
- qt5ct
- rapidsvn  mad
- zenity mad
- vlc mad
- xfe
- lightning thunderbird mad
- sqlitebrowser
- htmldoc
- vitualbox-qt mad
- openshot
- htmldoc
- keepassxc
- filezilla


So I know this will be painful, but what I did wrong and how to avoid this occurs again?  From what I see in upgraded packages, I have SERIOUS suspicions on

google-chrome-stable

triggering all that mess.

Start-Date: 2018-10-25  00:35:48
Commandline: apt full-upgrade
Requested-By: thierrybo (1000)
Upgrade: libimage-magick-perl:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), libwayland-egl1:amd64 (1.15.0-2~bpo9+1, 1.16.0-1~bpo9+1), libdrm-nouveau2:amd64 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libdrm-nouveau2:i386 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libimage-magick-q16-perl:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), imagemagick:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), google-chrome-stable:amd64 (69.0.3497.100-1, 70.0.3538.77-1), libwayland-client0:amd64 (1.15.0-2~bpo9+1, 1.16.0-1~bpo9+1), libwayland-client0:i386 (1.15.0-2~bpo9+1, 1.16.0-1~bpo9+1), libdrm-amdgpu1:amd64 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libdrm-amdgpu1:i386 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), imagemagick-6.q16:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), libdrm2:amd64 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libdrm2:i386 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libssh-gcrypt-4:amd64 (0.7.3-2, 0.7.3-2+deb9u1), libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), libdrm-intel1:amd64 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libdrm-intel1:i386 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libdrm-radeon1:amd64 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), libdrm-radeon1:i386 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1), perlmagick:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), libwayland-server0:amd64 (1.15.0-2~bpo9+1, 1.16.0-1~bpo9+1), libwayland-server0:i386 (1.15.0-2~bpo9+1, 1.16.0-1~bpo9+1), imagemagick-6-common:amd64 (8:6.9.7.4+dfsg-11+deb9u5, 8:6.9.7.4+dfsg-11+deb9u6), tzdata:amd64 (2018e-0+deb9u1, 2018f-0+deb9u1), libdrm-common:amd64 (2.4.91-2~bpo9+1, 2.4.95-1~bpo9+1)
Remove: libchamplain-gtk-0.12-0:amd64 (0.12.15-1), libfltk1.1:amd64 (1.1.10-23), libkf5kiowidgets5:amd64 (5.28.0-2), xserver-xorg-video-dummy:amd64 (1:0.3.8-1), vlc-plugin-video-output:amd64 (3.0.3-1-0+deb9u1), qt5-style-plugins:amd64 (5.0.0+git16.g7aa4764-1), default-jre:amd64 (2:1.8-58), libcogl20:amd64 (1.22.2-2), libgles2-mesa:amd64 (18.1.6-1~bpo9+1), python3-poppler-qt5:amd64 (0.24.2-3), libqt5svg5:amd64 (5.7.1~20161021-2+b2), libclutter-1.0-0:amd64 (1.26.0+dfsg-3), wkhtmltopdf:amd64 (0.12.3.2-3), kinit:amd64 (5.28.0-1), qml-module-qtquick-window2:amd64 (5.7.1-2+b2), alsamixergui:amd64 (0.9.0rc2-1-10), xserver-xorg-video-nouveau:amd64 (1:1.0.13-3), ffmpeg:amd64 (7:3.2.12-1~deb9u1), libgles-nvidia2:amd64 (390.87-2~bpo9+1), libgles-nvidia2:i386 (390.87-2~bpo9+1), libkf5itemviews5:amd64 (5.28.0-1), libkwalletbackend5-5:amd64 (5.28.0-3), libnvidia-ml1:amd64 (390.87-2~bpo9+1), nvidia-vulkan-icd:amd64 (390.87-2~bpo9+1), nvidia-vulkan-icd:i386 (390.87-2~bpo9+1), libegl1:amd64 (1.0.0+git20180308-2~bpo9+1), libegl1:i386 (1.0.0+git20180308-2~bpo9+1), openjdk-8-jre:amd64 (8u181-b13-1~deb9u1), nvidia-driver-libs-i386:i386 (390.87-2~bpo9+1), qt5-gtk-platformtheme:amd64 (5.7.1+dfsg-3+b1), xserver-xorg-core:amd64 (2:1.19.2-1+deb9u2), nvidia-egl-icd:amd64 (390.87-2~bpo9+1), nvidia-egl-icd:i386 (390.87-2~bpo9+1), qml-module-qtquick2:amd64 (5.7.1-2+b2), libcogl-path20:amd64 (1.22.2-2), libqt5help5:amd64 (5.7.1-1), libatk-wrapper-java:amd64 (0.33.3-13+deb9u1), libkf5kiofilewidgets5:amd64 (5.28.0-2), libkf5globalaccel5:amd64 (5.28.0-1), vlc-plugin-qt:amd64 (3.0.3-1-0+deb9u1), libkf5dbusaddons5:amd64 (5.28.0-1), libabiword-3.0:amd64 (3.0.2-2+deb9u2), simplescreenrecorder:amd64 (0.3.8-2), libgl1:i386 (1.0.0+git20180308-2~bpo9+1), nvidia-driver:amd64 (390.87-2~bpo9+1), yelp:amd64 (3.22.0-1), libyelp0:amd64 (3.22.0-1), kwin-style-breeze:amd64 (4:5.8.5-2), xserver-xorg-input-void:amd64 (1:1.4.1-1+b2), qml-module-qtquick-controls:amd64 (5.7.1~20161021-2), libkf5service-bin:amd64 (5.28.0-1), libkf5declarative5:amd64 (5.28.0-1), phonon4qt5:amd64 (4:4.9.0-4), libpoppler-qt5-1:amd64 (0.48.0-2+deb9u2), kde-style-breeze:amd64 (4:5.8.5-2), python-wxgtk3.0:amd64 (3.0.2.0+dfsg-4), libopengl0:i386 (1.0.0+git20180308-2~bpo9+1), python3-pyqt5:amd64 (5.7+dfsg-5), remarkable:amd64 (1.87), libkf5jobwidgets5:amd64 (5.28.0-2), libkf5wallet-bin:amd64 (5.28.0-3), qml-module-qtquick-layouts:amd64 (5.7.1-2+b2), libnvidia-encode1:amd64 (390.87-2~bpo9+1), paprass:amd64 (2.06-2), libqt5widgets5:amd64 (5.7.1+dfsg-3+b1), kded5:amd64 (5.28.0-1), breeze:amd64 (4:5.8.5-2), libcogl-pango20:amd64 (1.22.2-2), libpolkit-qt5-1-1:amd64 (0.112.0-5), mesa-utils:amd64 (8.3.0-3), gstreamer1.0-plugins-bad:amd64 (1.10.4-1), nvidia-vdpau-driver:amd64 (390.87-2~bpo9+1), libgl1-nvidia-glvnd-glx:amd64 (390.87-2~bpo9+1), libgl1-nvidia-glvnd-glx:i386 (390.87-2~bpo9+1), libegl1-mesa:amd64 (18.1.6-1~bpo9+1), libkf5quickaddons5:amd64 (5.28.0-1), libgles2:amd64 (1.0.0+git20180308-2~bpo9+1), libglx-nvidia0:amd64 (390.87-2~bpo9+1), libglx-nvidia0:i386 (390.87-2~bpo9+1), abiword:amd64 (3.0.2-2+deb9u2), libkdecorations2-5v5:amd64 (4:5.8.4-1), libnvidia-egl-wayland1:amd64 (390.87-2~bpo9+1), libnvidia-egl-wayland1:i386 (390.87-2~bpo9+1), libkf5bookmarks5:amd64 (5.28.0-1), kio:amd64 (5.28.0-2), libwxgtk3.0-0v5:amd64 (3.0.2+dfsg-4), libkf5notifyconfig5:amd64 (5.28.0-1), libwebkitgtk-3.0-0:amd64 (2.4.11-3), nvidia-kernel-dkms:amd64 (390.87-2~bpo9+1), libkf5configwidgets5:amd64 (5.28.0-2), libatk-wrapper-java-jni:amd64 (0.33.3-13+deb9u1), libqt5printsupport5:amd64 (5.7.1+dfsg-3+b1), libkf5configgui5:amd64 (5.28.0-2), libkf5service5:amd64 (5.28.0-1), libegl-nvidia0:amd64 (390.87-2~bpo9+1), libegl-nvidia0:i386 (390.87-2~bpo9+1), thunderbird-l10n-fr:amd64 (1:60.0-3~deb9u1), libkf5completion5:amd64 (5.28.0-1), libkf5kcmutils5:amd64 (5.28.0-2), kdenlive:amd64 (16.12.2-1), compton:amd64 (0.1~beta2+20150922-1), libkf5newstuff5:amd64 (5.28.0-1), libkf5wallet5:amd64 (5.28.0-3), libqt5gui5:amd64 (5.7.1+dfsg-3+b1), libqt5quickwidgets5:amd64 (5.7.1-2+b2), libnvidia-cfg1:amd64 (390.87-2~bpo9+1), libnvidia-cfg1:i386 (390.87-2~bpo9+1), libkf5xmlgui5:amd64 (5.28.0-1), nvidia-egl-wayland-icd:amd64 (390.87-2~bpo9+1), nvidia-egl-wayland-icd:i386 (390.87-2~bpo9+1), libchamplain-0.12-0:amd64 (0.12.15-1), libqt5x11extras5:amd64 (5.7.1~20161021-2), steam:i386 (1.0.0.54-2), libmlt++3:amd64 (6.4.1-4), libfox-1.6-0:amd64 (1.6.53-1), qt5ct:amd64 (0.33-1~ubuntu17.04.1), libkf5textwidgets5:amd64 (5.28.0-1), libdbusmenu-qt5-2:amd64 (0.9.3+16.04.20160218-1), rapidsvn:amd64 (0.12.1dfsg-3.1+b1), libkf5style5:amd64 (5.28.0-1), gir1.2-webkit-3.0:amd64 (2.4.11-3), libwayland-egl1-mesa:amd64 (18.1.6-1~bpo9+1), libkf5guiaddons5:amd64 (5.28.0-1), nvidia-kernel-support:amd64 (390.87-2~bpo9+1), libqt5webkit5:amd64 (5.7.1+dfsg-1), zenity:amd64 (3.22.0-1+b1), libglew2.0:amd64 (2.0.0-3+b1), libqt5scintilla2-12v5:amd64 (2.9.3+dfsg-4), vlc:amd64 (3.0.3-1-0+deb9u1), libglx0:i386 (1.0.0+git20180308-2~bpo9+1), libnvcuvid1:amd64 (390.87-2~bpo9+1), libqcustomplot1.3:amd64 (1.3.2+dfsg1-1), libwebkit2gtk-4.0-37:amd64 (2.18.6-1~deb9u1), melt:amd64 (6.4.1-4), libavdevice57:amd64 (7:3.2.12-1~deb9u1), nvidia-driver-libs:amd64 (390.87-2~bpo9+1), nvidia-driver-libs:i386 (390.87-2~bpo9+1), xserver-xorg-input-evdev:amd64 (1:2.10.5-1), xfe:amd64 (1.42-1+b1), libglu1-mesa:amd64 (9.0.0-2.1), libglu1-mesa:i386 (9.0.0-2.1), nvidia-driver-bin:amd64 (390.87-2~bpo9+1), lightning:amd64 (1:60.0-3~deb9u1), xfe-i18n:amd64 (1.42-1), libkf5windowsystem5:amd64 (5.28.0-2), sqlitebrowser:amd64 (3.9.1-2), thunderbird:amd64 (1:60.0-3~deb9u1), libphonon4qt5-4:amd64 (4:4.9.0-4), nvidia-persistenced:amd64 (384.111-1~deb9u1), libkf5widgetsaddons5:amd64 (5.28.0-3), libqt5opengl5:amd64 (5.7.1+dfsg-3+b1), lightning-l10n-fr:amd64 (1:60.0-3~deb9u1), libgl1-mesa-glx:i386 (18.1.6-1~bpo9+1), htmldoc:amd64 (1.8.27-8+b5), libkf5sonnetui5:amd64 (5.28.0-2), openshot:amd64 (1.4.3-1.2), xserver-xorg-video-nvidia:amd64 (390.87-2~bpo9+1), virtualbox-qt:amd64 (5.2.18-dfsg-2~bpo9+1), libcuda1:amd64 (390.87-2~bpo9+1), libkf5iconthemes5:amd64 (5.28.0-2), libkf5auth5:amd64 (5.28.0-2), phonon4qt5-backend-vlc:amd64 (0.9.0-2+deb9u1), x11-utils:amd64 (7.7+3+b1), libkf5solid5:amd64 (5.28.0-3), libqt5designer5:amd64 (5.7.1-1), python-mlt:amd64 (6.4.1-4), libkf5crash5:amd64 (5.28.0-1), keepassxc:amd64 (2.3.4+dfsg.1-1~bpo9+1), libkf5kiocore5:amd64 (5.28.0-2), libgstreamer-plugins-bad1.0-0:amd64 (1.10.4-1), libqt5quick5:amd64 (5.7.1-2+b2), filezilla:amd64 (3.24.0-1), libmlt6:amd64 (6.4.1-4), libkdecorations2private5v5:amd64 (4:5.8.4-1), libkf5notifications5:amd64 (5.28.0-1), qml-module-qtquick-controls-styles-breeze:amd64 (4:5.8.5-2), qml-module-qtgraphicaleffects:amd64 (5.7.1~20161021-3), playonlinux:amd64 (4.2.10-2), libclutter-gtk-1.0-0:amd64 (1.8.2-2), nvidia-settings:amd64 (390.48-2~bpo9+1), nvidia-alternative:amd64 (390.87-2~bpo9+1)
End-Date: 2018-10-25  00:38:20

Last edited by thierrybo (2018-10-25 13:13:10)

Offline

#2 2018-10-25 13:29:03

thierrybo
Member
Registered: 2017-11-11
Posts: 16  

Re: no /usr/bin/X after 'apt full-upgrade'

Well it seems chrome has not direct wayland dependency:

Pre-Depends: dpkg (>= 1.14.0)
Depends: ca-certificates, fonts-liberation, libappindicator3-1, libasound2 (>= 1.0.16), libatk-bridge2.0-0 (>= 2.5.3), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.16), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.1.4), libexpat1 (>= 2.0.1), libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk-3-0 (>= 3.9.10), libnspr4 (>= 2:4.9-2~), libnss3 (>= 2:3.22), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libstdc++6 (>= 4.6), libuuid1 (>= 2.16), libx11-6 (>= 2:1.4.99.1), libx11-xcb1, libxcb1 (>= 1.6), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6 (>= 2:1.2.99.4), libxrandr2 (>= 2:1.2.99.3), libxrender1, libxss1, libxtst6, lsb-release, wget, xdg-utils (>= 1.0.2)

Offline

#3 2018-10-25 16:50:39

thierrybo
Member
Registered: 2017-11-11
Posts: 16  

Re: no /usr/bin/X after 'apt full-upgrade'

OK, thanks to my install records, I am online again smile

I installed again all missing manually installed packages:

sudo apt install xserver-xorg-video-dummy
sudo apt install xserver-xorg-input-void
sudo apt install xserver-xorg-input-evdev
sudo apt install xserver-xorg-video-nouveau
sudo reboot
sudo apt install -t ascii-backports --install-recommends nvidia-driver
sudo reboot
sudo apt install compton
sudo apt install xfe
sudo apt install qt5-style-plugins
sudo apt install default-jre
sudo apt install python3-poppler-qt5
sudo apt install alsamixergui
sudo apt install ffmpeg
sudo apt install simplescreenrecorder
sudo apt install yelp
sudo apt install python-wxgtk3.0
sudo apt install -t ascii-backports libcuda1
sudo apt install -t ascii-backports libnvidia-encode1
sudo apt install paprass
sudo apt install breeze
sudo apt install gstreamer1.0-plugins-bad
sudo apt install abiword
sudo apt install thunderbird
sudo apt install thunderbird-l10n-fr
sudo apt install kdenlive
sudo apt install steam  -> The following packages have unmet dependencies: 
                        steam:i386 : Dépends: libgl1-mesa-glx:i386 but will NOT be installed
sudo apt install vlc
sudo apt install lightning
sudo apt install sqlitebrowser
sudo apt install lightning-l10n-fr
sudo apt install htmldoc
sudo apt install openshot
sudo apt install -t ascii-backports virtualbox-qt
sudo apt install keepassxc
sudo apt install filezilla
sudo apt install playonlinux

I just  can't install steam anymore, I have to investigate.

Still I do not understand what triggers all these removals.

But I noticed something weird. Some of the packages that were removed and that have been installed thereafter as dependencies are still "auto-removeable".

For example , "nvidia-settings" has been reinstalled when I installed "nvidia-driver". apt show nvidia-settings show the package as not manually installed :  APT-Manual-Installed: no

But it is still listed as a package that can be removed automatically.

Offline

Board footer