The officially official Devuan Forum!

You are not logged in.

#1 2018-09-22 13:44:56

sn
Member
Registered: 2018-08-17
Posts: 6  

usb's not mounting

Sorry to repost haven't been able to fix the problem
Noticed this when the policykit-1 package was updated I was unable to shutdown or suspend from XFCE desktop without logging out and logging back in as root. I fixed it with the following workaround: Downgrade libpolkit-agent-1-0, libpolkit-backend-1-0, and libpolkit-gobject-1-0 from 0.105-15~deb8u3 to 0.105-9+devuan1.

- Launch Synaptic Package Manager.

gksudo synaptic-pkexec

- Find each of the 3 packages and press CTRL+E, or from the menu: Package -> Force Version.

- Select 0.105-9+devuan1.

Since then I've reinstalled policykit-1 which allows me to shutdown and suspend from XFCE menu.
The following didn't work

fsmithred wrote:

The devuanized versions of 0.105-15 are in jessie-security.

apt-get -t jessie-security install policykit-1

Thanks for any help

Offline

#2 2018-09-22 21:43:09

fsmithred
Administrator
Registered: 2016-11-25
Posts: 873  

Re: usb's not mounting

How does it not work? Did you get an error message? Please post the contents of /etc/apt/sources.list

You should get something like this when you run that command:

# apt-get -t jessie-security install policykit-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0
The following packages will be upgraded:
  libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 policykit-1
4 upgraded, 0 newly installed, 0 to remove and 354 not upgraded.
Need to get 173 kB of archives.
After this operation, 298 kB disk space will be freed.
Do you want to continue? [Y/n]

This looks odd.

gksudo synaptic-pkexec

You can start synaptic with gksudo or pkexec. No need to use both.
gksudo synaptic
or
synaptic-pkexec

Offline

#3 2018-09-23 16:10:19

sn
Member
Registered: 2018-08-17
Posts: 6  

Re: usb's not mounting

Sorry for the late reply fsmithred. I meant "apt-get -t jessie-security install policykit-1" didn't make usb's automount  like they had before. Not that I know for sure that policykit-1 was even the cause

Offline

#4 2018-09-23 16:39:23

fsmithred
Administrator
Registered: 2016-11-25
Posts: 873  

Re: usb's not mounting

Check to make sure you have the right versions of all those libraries listed in my codebox above.
(should be version 0.105-15~deb8u3+devuanSEC1)

Check removable device settings in xfce.

When you plug in a usb stick, do you get an icon on the desktop? If so, can you mount/open it from there?

Offline

Board footer