The officially official Devuan Forum!

You are not logged in.

#1 2018-09-09 19:53:43

GNUser
Member
Registered: 2017-03-16
Posts: 397  

downloaded .debs have url escape code in name?! [SOLVED]

When I download packages that contain a colon in the version number (e.g., ffmpeg 7:3.2.10-1~deb9u1 or xserver-common 2:1.19.2-1+deb9u2), the downloaded package name contains %3a where I was expecting :.

bruno@thinkpad:~/Desktop$ apt download ffmpeg xserver-common
Get:1 http://gnuser.ddns.net/devuan/merged ascii/main amd64 ffmpeg amd64 7:3.2.10-1~deb9u1 [1,530 kB]
Get:2 http://gnuser.ddns.net/devuan/merged ascii/main amd64 xserver-common all 2:1.19.2-1+deb9u2 [2,059 kB]
Fetched 3,589 kB in 4s (784 kB/s)           
bruno@thinkpad:~/Desktop$ ls
ffmpeg_7%3a3.2.10-1~deb9u1_amd64.deb
xserver-common_2%3a1.19.2-1+deb9u2_all.deb

Using apt-get download instead of apt download makes no difference.

Is this expected behavior, an upstream bug, or symptom of some misconfiguration on my system? (Internet searches have come up dry.)

Last edited by GNUser (2018-09-10 02:38:44)

Offline

#2 2018-09-09 23:01:03

yeti
Member
Registered: 2017-02-23
Posts: 75  

Re: downloaded .debs have url escape code in name?! [SOLVED]

$ lsb_release -sir
Debian
9.5
$ apt download ffmpeg xserver-common
Get:1 http://ftp.de.debian.org/debian stretch/main amd64 xserver-common all 2:1.19.2-1+deb9u2 [2059 kB]
Get:2 http://security.debian.org/debian-security stretch/updates/main amd64 ffmpeg amd64 7:3.2.12-1~deb9u1 [1532 kB]
Fetched 3591 kB in 2s (1458 kB/s)                                        
$ ls -1
ffmpeg_7%3a3.2.12-1~deb9u1_amd64.deb
xserver-common_2%3a1.19.2-1+deb9u2_all.deb

It does not screw up Debian.
So probably its not a problem in Devuan too.


"Stay OmmmMMMmmmPtimistic!" — yeti
"Isch ahbe fertisch!" — Sisyphos
"Logic, my dear Zoe, merely enables one to be wrong with authority." — The 2nd Doctor
"No Source — No Go!" — yeti

Offline

#3 2018-09-09 23:14:42

fsmithred
Administrator
Registered: 2016-11-25
Posts: 857  

Re: downloaded .debs have url escape code in name?! [SOLVED]

They look like that in /var/cache/apt/archives, too. I always assumed it was normal.

Offline

#4 2018-09-10 02:19:15

GNUser
Member
Registered: 2017-03-16
Posts: 397  

Re: downloaded .debs have url escape code in name?! [SOLVED]

Thank you, yeti and fsmithred. Good to know this is just how it is. I thought something in my /etc/apt/apt.conf.d/ or /etc/apt/preferences.d/ was broken.

Then my guess then is that it is either this way by design (for some reason unknown to me) or else it's a minor bug that's only cosmetic.

At any rate, I booted an old Debian 8 partition, downloaded ffmpeg, installed it, and checked the installed version. There are no url escape codes in the version that apt reports being installed. (I guess this is not surprising since apt gets version number from package's /DEBIAN/control file and not from the name of the .deb file.) No harm, no foul.

bruno@thinkpad8:~/Desktop$ apt-get download ffmpeg
Get:1 http://ftp.us.debian.org/debian/ jessie-backports/main ffmpeg amd64 7:3.2.10-1~deb9u1~bpo8+1 [1,535 kB]
Fetched 1,535 kB in 0s (1,537 kB/s)

bruno@thinkpad8:~/Desktop$ ls
ffmpeg_7%3a3.2.10-1~deb9u1~bpo8+1_amd64.deb # note the '%3a'

bruno@thinkpad8:~/Desktop$ sudo gdebi ./ffmpeg_7%3a3.2.10-1~deb9u1~bpo8+1_amd64.deb 
# installation proceeds normally

bruno@thinkpad8:~/Desktop$ apt list --installed ffmpeg
Listing... Done
ffmpeg/jessie-backports,now 7:3.2.10-1~deb9u1~bpo8+1 amd64 [installed] # note the ':'

Sorry for the noise, but when I first noticed this it was completely unexpected.

Last edited by GNUser (2018-09-10 02:23:51)

Offline

Board footer