The officially official Devuan Forum!

You are not logged in.

#1 2018-07-15 07:33:00

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

ASCII: Can't start Xorg after system upgrade [SOLVED]

Xorg.0.log:

[    57.596] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[    57.597] X Protocol Version 11, Revision 0
[    57.597] Build Operating System: Linux 4.9.0-4-amd64 x86_64 Debian
[    57.597] Current Operating System: Linux hstnm 4.9.0-7-amd64 #1 SMP Debian 4.9.110-1 (2018-07-05) x86_64
[    57.597] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-7-amd64 root=UUID=cac-...-...-...3-....78 ro
[    57.597] Build Date: 16 October 2017  08:19:45AM
[    57.597] xorg-server 2:1.19.2-1+deb9u2 (https://www.debian.org/support) 
[    57.597] Current version of pixman: 0.34.0
[    57.602] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    57.602] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    57.612] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 14 21:11:57 2018
[    57.614] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    57.614] (==) No Layout section.  Using the first Screen section.
[    57.614] (==) No screen section available. Using defaults.
[    57.614] (**) |-->Screen "Default Screen Section" (0)
[    57.614] (**) |   |-->Monitor "<default monitor>"
[    57.615] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    57.615] (==) Automatically adding devices
[    57.615] (==) Automatically enabling devices
[    57.615] (==) Automatically adding GPU devices
[    57.615] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    57.615] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    57.615] 	Entry deleted from font path.
[    57.615] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[    57.615] (==) ModulePath set to "/usr/lib/xorg/modules"
[    57.615] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    57.615] (II) Loader magic: 0x559a46889e00
[    57.615] (II) Module ABI versions:
[    57.615] 	X.Org ANSI C Emulation: 0.4
[    57.615] 	X.Org Video Driver: 23.0
[    57.615] 	X.Org XInput driver : 24.1
[    57.615] 	X.Org Server Extension : 10.0
[    57.616] (--) using VT number 7

[    57.616] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    57.616] (II) xfree86: Adding drm device (/dev/dri/card0)
[    57.625] (--) PCI:*(0:0:2:0) 8086:0166:1462:10d8 rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[    57.625] (II) LoadModule: "glx"
[    57.625] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    57.627] (II) Module glx: vendor="X.Org Foundation"
[    57.627] 	compiled for 1.19.2, module version = 1.0.0
[    57.627] 	ABI class: X.Org Server Extension, version 10.0
[    57.627] (==) Matched modesetting as autoconfigured driver 0
[    57.627] (==) Matched fbdev as autoconfigured driver 1
[    57.627] (==) Matched vesa as autoconfigured driver 2
[    57.627] (==) Assigned the driver to the xf86ConfigLayout
[    57.627] (II) LoadModule: "modesetting"
[    57.627] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    57.627] (II) Module modesetting: vendor="X.Org Foundation"
[    57.627] 	compiled for 1.19.2, module version = 1.19.2
[    57.627] 	Module class: X.Org Video Driver
[    57.627] 	ABI class: X.Org Video Driver, version 23.0
[    57.627] (II) LoadModule: "fbdev"
[    57.627] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    57.627] (II) Module fbdev: vendor="X.Org Foundation"
[    57.627] 	compiled for 1.19.0, module version = 0.4.4
[    57.627] 	Module class: X.Org Video Driver
[    57.627] 	ABI class: X.Org Video Driver, version 23.0
[    57.627] (II) LoadModule: "vesa"
[    57.627] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    57.628] (II) Module vesa: vendor="X.Org Foundation"
[    57.628] 	compiled for 1.19.0, module version = 2.3.4
[    57.628] 	Module class: X.Org Video Driver
[    57.628] 	ABI class: X.Org Video Driver, version 23.0
[    57.628] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    57.628] (II) FBDEV: driver for framebuffer: fbdev
[    57.628] (II) VESA: driver for VESA chipsets: vesa
[    57.657] (II) modeset(0): using drv /dev/dri/card0
[    57.657] (WW) Falling back to old probe method for fbdev
[    57.657] (II) Loading sub module "fbdevhw"
[    57.657] (II) LoadModule: "fbdevhw"
[    57.657] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    57.657] (II) Module fbdevhw: vendor="X.Org Foundation"
[    57.657] 	compiled for 1.19.2, module version = 0.0.2
[    57.657] 	ABI class: X.Org Video Driver, version 23.0
[    57.657] (WW) Falling back to old probe method for vesa
[    57.657] (II) modeset(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    57.657] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    57.658] (==) modeset(0): RGB weight 888
[    57.658] (==) modeset(0): Default visual is TrueColor
[    57.658] (II) Loading sub module "glamoregl"
[    57.658] (II) LoadModule: "glamoregl"
[    57.658] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    57.663] (II) Module glamoregl: vendor="X.Org Foundation"
[    57.663] 	compiled for 1.19.2, module version = 1.0.0
[    57.663] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    57.663] (II) glamor: OpenGL accelerated X.org driver based.
[    57.678] (II) glamor: EGL version 1.4 (DRI2):
[    57.680] (II) modeset(0): glamor initialized
[    57.680] (II) modeset(0): Output LVDS-1 has no monitor section
[    57.682] (II) modeset(0): Output VGA-1 has no monitor section
[    57.683] (II) modeset(0): Output HDMI-1 has no monitor section
[    57.683] (II) modeset(0): Output DP-1 has no monitor section
[    57.683] (II) modeset(0): EDID for output LVDS-1
[    57.683] (II) modeset(0): Manufacturer: CMO  Model: 1720  Serial#: 0
[    57.683] (II) modeset(0): Year: 2011  Week: 2
[    57.683] (II) modeset(0): EDID Version: 1.3
[    57.683] (II) modeset(0): Digital Display Input
[    57.683] (II) modeset(0): Max Image Size [cm]: horiz.: 38  vert.: 21
[    57.683] (II) modeset(0): Gamma: 2.20
[    57.683] (II) modeset(0): No DPMS capabilities specified
[    57.683] (II) modeset(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[    57.683] (II) modeset(0): First detailed timing is preferred mode
[    57.683] (II) modeset(0): redX: 0.640 redY: 0.333   greenX: 0.303 greenY: 0.613
[    57.683] (II) modeset(0): blueX: 0.154 blueY: 0.060   whiteX: 0.313 whiteY: 0.329
[    57.683] (II) modeset(0): Manufacturer's mask: 0
[    57.683] (II) modeset(0): Supported detailed timing:
[    57.683] (II) modeset(0): clock: 138.7 MHz   Image Size:  382 x 215 mm
[    57.683] (II) modeset(0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
[    57.683] (II) modeset(0): v_active: 1080  v_sync: 1083  v_sync_end 1088 v_blanking: 1111 v_border: 0
[    57.683] (II) modeset(0):  N173HGE-L11
[    57.683] (II) modeset(0):  CMO
[    57.683] (II) modeset(0):  N173HGE-L11
[    57.683] (II) modeset(0): EDID (in hex):
[    57.683] (II) modeset(0): 	00ffffffffffff000daf201700000000
[    57.683] (II) modeset(0): 	02150103802615780ad895a3554d9d27
[    57.683] (II) modeset(0): 	0f505400000001010101010101010101
[    57.683] (II) modeset(0): 	0101010101012e3680a070381f403020
[    57.684] (II) modeset(0): 	35007ed710000018000000fe004e3137
[    57.684] (II) modeset(0): 	334847452d4c31310a20000000fe0043
[    57.684] (II) modeset(0): 	4d4f0a202020202020202020000000fe
[    57.684] (II) modeset(0): 	004e3137334847452d4c31310a20006e
[    57.684] (II) modeset(0): Printing probed modes for output LVDS-1
[    57.684] (II) modeset(0): Modeline "1920x1080"x60.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 -hsync -vsync (66.7 kHz eP)
[    57.684] (II) modeset(0): Modeline "1920x1080"x59.9  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz d)
[    57.684] (II) modeset(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz d)
[    57.684] (II) modeset(0): Modeline "1680x1050"x59.9  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync (64.7 kHz d)
[    57.684] (II) modeset(0): Modeline "1600x1024"x60.2  103.12  1600 1600 1656 1664  1024 1024 1029 1030 +hsync +vsync (62.0 kHz d)
[    57.684] (II) modeset(0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz d)
[    57.684] (II) modeset(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz d)
[    57.684] (II) modeset(0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz d)
[    57.684] (II) modeset(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz d)
[    57.684] (II) modeset(0): Modeline "1360x768"x59.8   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync (47.7 kHz d)
[    57.684] (II) modeset(0): Modeline "1360x768"x60.0   72.00  1360 1408 1440 1520  768 771 781 790 +hsync -vsync (47.4 kHz d)
[    57.684] (II) modeset(0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz d)
[    57.684] (II) modeset(0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[    57.684] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[    57.684] (II) modeset(0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[    57.684] (II) modeset(0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[    57.684] (II) modeset(0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[    57.684] (II) modeset(0): Modeline "960x600"x120.0   77.00  960 984 1000 1040  600 601 604 617 doublescan +hsync -vsync (74.0 kHz d)
[    57.684] (II) modeset(0): Modeline "960x540"x120.0   69.25  960 984 1000 1040  540 541 544 555 doublescan +hsync -vsync (66.6 kHz d)
[    57.684] (II) modeset(0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[    57.684] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[    57.684] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[    57.684] (II) modeset(0): Modeline "840x525"x120.0   73.12  840 892 980 1120  525 526 529 544 doublescan -hsync +vsync (65.3 kHz d)
[    57.684] (II) modeset(0): Modeline "840x525"x119.8   59.50  840 864 880 920  525 526 529 540 doublescan +hsync -vsync (64.7 kHz d)
[    57.684] (II) modeset(0): Modeline "800x512"x120.3   51.56  800 800 828 832  512 512 514 515 doublescan +hsync +vsync (62.0 kHz d)
[    57.684] (II) modeset(0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[    57.684] (II) modeset(0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[    57.684] (II) modeset(0): Modeline "720x450"x119.8   53.25  720 760 836 952  450 451 454 467 doublescan -hsync +vsync (55.9 kHz d)
[    57.684] (II) modeset(0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[    57.684] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[    57.684] (II) modeset(0): Modeline "680x384"x119.6   42.38  680 716 784 888  384 385 390 399 doublescan -hsync +vsync (47.7 kHz d)
[    57.684] (II) modeset(0): Modeline "680x384"x119.9   36.00  680 704 720 760  384 385 390 395 doublescan +hsync -vsync (47.4 kHz d)
[    57.684] (II) modeset(0): Modeline "576x432"x120.1   40.81  576 608 668 760  432 432 434 447 doublescan -hsync +vsync (53.7 kHz d)
[    57.684] (II) modeset(0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[    57.684] (II) modeset(0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[    57.684] (II) modeset(0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[    57.684] (II) modeset(0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[    57.686] (II) modeset(0): EDID for output VGA-1
[    57.687] (II) modeset(0): EDID for output HDMI-1
[    57.687] (II) modeset(0): EDID for output DP-1
[    57.687] (II) modeset(0): Output LVDS-1 connected
[    57.687] (II) modeset(0): Output VGA-1 disconnected
[    57.687] (II) modeset(0): Output HDMI-1 disconnected
[    57.687] (II) modeset(0): Output DP-1 disconnected
[    57.687] (II) modeset(0): Using exact sizes for initial modes
[    57.687] (II) modeset(0): Output LVDS-1 using initial mode 1920x1080 +0+0
[    57.687] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[    57.687] (==) modeset(0): DPI set to (96, 96)
[    57.687] (II) Loading sub module "fb"
[    57.687] (II) LoadModule: "fb"
[    57.687] (II) Loading /usr/lib/xorg/modules/libfb.so
[    57.687] (II) Module fb: vendor="X.Org Foundation"
[    57.687] 	compiled for 1.19.2, module version = 1.0.0
[    57.687] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    57.687] (II) UnloadModule: "fbdev"
[    57.687] (II) Unloading fbdev
[    57.687] (II) UnloadSubModule: "fbdevhw"
[    57.687] (II) Unloading fbdevhw
[    57.687] (II) UnloadModule: "vesa"
[    57.687] (II) Unloading vesa
[    57.687] (==) Depth 24 pixmap format is 32 bpp
[    57.688] (WW) glamor0: Failed to get GLSL version
[    57.688] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
[    57.688] (EE) 
Fatal server error:
[    57.688] (EE) AddScreen/ScreenInit failed for driver 0
[    57.688] (EE) 
[    57.688] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    57.688] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    57.688] (EE) 
[    57.698] (EE) Server terminated with error (1). Closing log file.

Any idea please ?

Last edited by boycottsystemd (2018-07-27 08:10:09)

Offline

#2 2018-07-15 09:56:06

Panopticon
Member
Registered: 2018-01-27
Posts: 147  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Looks you are using the modesetting driver would that be correct?

If you have lshw what is the output of below command?

sudo lshw -c video

Offline

#3 2018-07-15 12:16:54

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Panopticon wrote:

Looks you are using the modesetting driver would that be correct?

If you have lshw what is the output of below command?

sudo lshw -c video

I'm sorry I don't remember whether I made any changes in modesetting

# lshw -c video
  *-display                 
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:31 memory:f6400000-f67fffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff

Offline

#4 2018-07-16 10:27:09

Panopticon
Member
Registered: 2018-01-27
Posts: 147  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Maybe below code snippet has something to do with it. Its loading glamorgl module but its not working.

Sorry i cant be of anymore help as i am really not sure and dont want to help break your system. Maybe someone else has a better idea of a fix for this.

One last thing that might help is to check and see whats inside /etc/X11/xorg.conf.d/ if anything.

[    57.658] (II) Loading sub module "glamoregl"
[    57.658] (II) LoadModule: "glamoregl"
[    57.658] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    57.663] (II) Module glamoregl: vendor="X.Org Foundation"
[    57.663] 	compiled for 1.19.2, module version = 1.0.0
[    57.663] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    57.663] (II) glamor: OpenGL accelerated X.org driver based.
[    57.678] (II) glamor: EGL version 1.4 (DRI2):
[    57.680] (II) modeset(0): glamor initialized
[    57.688] (WW) glamor0: Failed to get GLSL version
[    57.688] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.

Last edited by Panopticon (2018-07-16 10:27:37)

Offline

#5 2018-07-16 12:12:07

UnclePa
Member
Registered: 2018-07-06
Posts: 24  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

As Panopticon said, what's in xorg.conf and/or xorg.conf.d?  Also, do you have xserver-xorg-video-intel installed?

Offline

#6 2018-07-17 10:20:33

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

UnclePa wrote:

As Panopticon said, what's in xorg.conf and/or xorg.conf.d?  Also, do you have xserver-xorg-video-intel installed?

Hello, thank you both for reply.

xorg.conf is not present, /etc/X11/xorg.conf.d/ is empty.


# apt --installed list  | grep xserver-xorg-video-intel

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

xserver-xorg-video-intel/stable,testing,now 2:2.99.917+git20161206-1 amd64 [installed,automatic]
# aptitude  install
The following NEW packages will be installed:
  nvidia-legacy-304xx-driver{b} nvidia-legacy-304xx-kernel-dkms{b} 
The following packages will be REMOVED:
  freeglut3{u} libaec0{u} libarmadillo7{u} libarpack2{u} libcoin80v5{u} libdap23{u} 
  libdapclient6v5{u} libdapserver7v5{u} libepsilon1{u} libfftw3-single3{u} libfreexl1{u} 
  libgdal20{u} libgeos-3.5.1{u} libgeos-c1v5{u} libgeotiff2{u} libgraphicsmagick-q16-3{u} 
  libhdf4-0-alt{u} libhdf5-100{u} libhtsengine1{u} libiso9660-8{u} libjs-bootstrap{u} 
  libjs-excanvas{u} libjs-jquery-flot{u} libjs-jquery-ui{u} 
  libjs-jquery-ui-theme-smoothness{u} libjs-leaflet{u} libjs-requirejs{u} 
  libjs-requirejs-text{u} libjson-c3{u} libkmlbase1{u} libkmlconvenience1{u} 
  libkmldom1{u} libkmlengine1{u} libkmlregionator1{u} libkmlxsd1{u} libmariadbclient18{u} 
  libminizip1{u} libnetcdf11{u} libogdi3.2{u} libopenthreads20{u} libplib1{u} 
  libproj12{u} libqhull7{u} libqt4-dbus{u} libqt4-opengl{u} libqt4-xml{u} libqtcore4{u} 
  libqtdbus4{u} libqtgui4{u} libspatialite7{u} libsuperlu5{u} libsz2{u} libudns0{u} 
  liburiparser1{u} libuv1{u} libvcdinfo0{u} libwebrtc-audio-processing-0{u} 
  libxcb-glx0:i386{u} libxcb-present0{u} libxdamage1:i386{u} libxerces-c3.1{u} 
  libxine2{u} libxine2-bin{u} libxine2-doc{u} libxine2-ffmpeg{u} libxine2-misc-plugins{u} 
  libxine2-plugins{u} mysql-common{u} node-sprintf-js{u} nodejs{u} odbcinst{u} 
  odbcinst1debian2{u} proj-bin{u} proj-data{u} qdbus{u} qt-at-spi{u} qtchooser{u} 
  qtcore4-l10n{u} rtkit{u} socat{u} 
The following packages are RECOMMENDED but will NOT be installed:
  nvidia-settings-legacy-304xx 
0 packages upgraded, 2 newly installed, 80 to remove and 0 not upgraded.
Need to get 4026 kB of archives. After unpacking 120 MB will be freed.
The following packages have unmet dependencies:
 alsa-utils : Depends: libfftw3-single3 (>= 3.3.5) but it is not going to be installed
 nvidia-legacy-304xx-driver : Depends: nvidia-legacy-304xx-driver-libs (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-legacy-304xx-driver-bin (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: xserver-xorg-video-nvidia-legacy-304xx (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-legacy-304xx-vdpau-driver (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-legacy-304xx-alternative (= 304.137-5~deb9u1) but it is not going to be installed
 flightgear-phi : Depends: libjs-bootstrap but it is not going to be installed
                  Depends: libjs-jquery-flot but it is not going to be installed
                  Depends: libjs-jquery-ui (>= 1.11) but it is not going to be installed
                  Depends: libjs-jquery-ui-theme-smoothness but it is not going to be installed
                  Depends: libjs-leaflet but it is not going to be installed
                  Depends: node-sprintf-js but it is not going to be installed
                  Depends: libjs-requirejs but it is not going to be installed
                  Depends: libjs-requirejs-text but it is not going to be installed
 nvidia-legacy-304xx-kernel-dkms : Depends: nvidia-legacy-304xx-kernel-support--v1 which is a virtual package, provided by:
                                            - nvidia-legacy-304xx-kernel-support:i386 (304.137-5~bpo9+1), but it is not going to be installed
                                            - nvidia-legacy-304xx-kernel-support (304.137-5~bpo9+1), but it is not going to be installed
                                            - nvidia-legacy-304xx-kernel-support:i386 (304.137-5~deb9u1), but it is not going to be installed
                                            - nvidia-legacy-304xx-kernel-support (304.137-5~deb9u1), but it is not going to be installed

The following actions will resolve these dependencies:

      Install the following packages:                                                  
1)      libgl1-nvidia-legacy-304xx-glx [304.137-5~deb9u1 (stable)]                     
2)      libnvidia-legacy-304xx-cfg1 [304.137-5~deb9u1 (stable)]                        
3)      libnvidia-legacy-304xx-glcore [304.137-5~deb9u1 (stable)]                      
4)      libnvidia-legacy-304xx-ml1 [304.137-5~deb9u1 (stable)]                         
5)      nvidia-legacy-304xx-alternative:i386 [304.137-5~deb9u1 (stable)]               
6)      nvidia-legacy-304xx-driver-bin [304.137-5~deb9u1 (stable)]                     
7)      nvidia-legacy-304xx-driver-libs [304.137-5~deb9u1 (stable)]                    
8)      nvidia-legacy-304xx-kernel-support [304.137-5~deb9u1 (stable)]                 
9)      nvidia-legacy-304xx-vdpau-driver [304.137-5~deb9u1 (stable)]                   
10)     nvidia-settings-legacy-304xx [304.134-1 (stable)]                              
11)     pkgconf:i386 [0.9.12-6 (stable, testing)]                                      
12)     xserver-xorg-video-nvidia-legacy-304xx [304.137-5~deb9u1 (stable)]             

      Keep the following packages at their current version:                            
13)     libfftw3-single3 [3.3.5-3 (now, stable, testing)]                              
14)     libjs-bootstrap [3.3.7+dfsg-2 (now, stable, testing)]                          
15)     libjs-jquery-flot [0.8.3+dfsg-1 (now, stable, testing)]                        
16)     libjs-jquery-ui [1.12.1+dfsg-4 (now, stable, testing)]                         
17)     libjs-jquery-ui-theme-smoothness [1.12.1+dfsg-1 (now, stable, testing)]        
18)     libjs-leaflet [0.7.7+20160312-1 (now, stable, testing)]                        
19)     libjs-requirejs [2.3.2-1 (now, stable, testing)]                               
20)     libjs-requirejs-text [2.0.12-1 (now, stable, testing)]                         
21)     node-sprintf-js [1.0.3-2 (now, stable, testing)]                               
22)     nodejs [4.8.2~dfsg-1 (now, stable, testing)]                                   

      Upgrade the following packages:                                                  
23)     libuv1 [1.9.1-3 (now, stable, testing) -> 1.18.0-3~bpo9+1 (stable-backports)]  

      Leave the following dependencies unresolved:                                     
24)     libjs-jquery-flot recommends libjs-excanvas                                    
25)     nvidia-legacy-304xx-driver-libs recommends nvidia-legacy-304xx-driver-libs-i386



Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

history.log of command after which  system got broken:

Start-Date: 2018-07-14  20:56:34
Commandline: apt -uV full-upgrade
Install: libgl1:amd64 (1.0.0+git20180308-2~bpo9+1, automatic), libgl1:i386 (1.0.0+git20180308-2~bpo9+1, automatic), libglx-nvidia0:amd64 (384.130-1, automatic), libglx-nvidia0:i386 (384.130-1, automatic), libglx0:amd64 (1.0.0+git20180308-2~bpo9+1, automatic), libglx0:i386 (1.0.0+git20180308-2~bpo9+1, automatic), mesa-va-drivers:i386 (13.0.6-1+b2, automatic), libglvnd0:amd64 (1.0.0+git20180308-2~bpo9+1, automatic), libglvnd0:i386 (1.0.0+git20180308-2~bpo9+1, automatic)
Upgrade: libgles-nvidia1:amd64 (375.82-1~deb9u1, 384.130-1), libgles-nvidia2:amd64 (375.82-1~deb9u1, 384.130-1), libnvidia-ml1:amd64 (375.82-1~deb9u1, 384.130-1), nvidia-vdpau-driver:amd64 (375.82-1~deb9u1, 384.130-1), libgles1-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), nvidia-kernel-dkms:amd64 (375.82-1~deb9u1, 384.130-1), libegl-nvidia0:amd64 (375.82-1~deb9u1, 384.130-1), libgles1-glvnd-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), libgl1-nvidia-glx:amd64 (375.82-1~deb9u1, 384.130-1), libgl1-nvidia-glx:i386 (375.82-1~deb9u1, 384.130-1), libnvidia-cfg1:amd64 (375.82-1~deb9u1, 384.130-1), nvidia-kernel-support:amd64 (375.82-1~deb9u1, 384.130-1), nvidia-driver-bin:amd64 (375.82-1~deb9u1, 384.130-1), libegl1-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), libgles2-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), xserver-xorg-video-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), libopengl0-glvnd-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), libnvidia-glcore:amd64 (375.82-1~deb9u1, 384.130-1), libnvidia-glcore:i386 (375.82-1~deb9u1, 384.130-1), libgles2-glvnd-nvidia:amd64 (375.82-1~deb9u1, 384.130-1), libnvidia-eglcore:amd64 (375.82-1~deb9u1, 384.130-1), nvidia-alternative:amd64 (375.82-1~deb9u1, 384.130-1)
Remove: vlc-plugin-video-output:amd64 (3.0.2-0+deb9u1), libgles2-mesa:amd64 (13.0.6-1+b2), ffmpeg:amd64 (7:3.2.10-1~deb9u1), libav-tools:amd64 (7:3.2.10-1~deb9u1), vdpau-va-driver:i386 (0.7.4-6), primus-libs:amd64 (0~20150328-4), primus-libs:i386 (0~20150328-4), nvidia-driver:amd64 (375.82-1~deb9u1), libopenscenegraph100v5:amd64 (3.2.3+dfsg1-2+b4), primus:amd64 (0~20150328-4), mplayer2:amd64 (3:0.23.0-2+deb9u2), flightgear:amd64 (1:2016.4.4+dfsg-3+deb9u1), mpv:amd64 (0.23.0-2+deb9u2), primus-libs-ia32:i386 (0~20150328-4), vlc:amd64 (3.0.2-0+deb9u1), libavdevice57:amd64 (7:3.2.10-1~deb9u1), nvidia-driver-libs:amd64 (375.82-1~deb9u1), libgl1-mesa-glx:amd64 (13.0.6-1+b2), libgl1-mesa-glx:i386 (13.0.6-1+b2), libgldispatch0-nvidia:amd64 (375.82-1~deb9u1)
End-Date: 2018-07-14  20:58:56

Offline

#7 2018-07-17 13:02:10

Panopticon
Member
Registered: 2018-01-27
Posts: 147  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Do you have an nvidia graphics card?

I find the program inxi can help a lot with getting much needed info on my system.

If you have backports enabled in /etc/apt/sources.list you should be able to download a current version of inxi.(if you want to).

sudo apt-get -t ascii install inxi

then in terminal after the inxi program has installed, as user (not root).

inxi -GSMr

That command gives quite a comprehensive overview,, you should man inxi before you post results to know what is being displayed.

Last edited by Panopticon (2018-07-17 13:30:41)

Offline

#8 2018-07-17 13:06:45

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Panopticon wrote:

Do you have an nvidia graphics card?

Yes, (plus  integrated intel)

Offline

#9 2018-07-17 13:33:45

Panopticon
Member
Registered: 2018-01-27
Posts: 147  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

If you have nvidia graphics are you ok in using the nouveau drivers?

If so try below if not already installed. But before you do see my edited post above yours.

sudo apt-get install xserver-xorg-video-nouveau

Last edited by Panopticon (2018-07-17 13:34:25)

Offline

#10 2018-07-17 13:56:40

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Panopticon wrote:

If you have nvidia graphics are you ok in using the nouveau drivers?

If so try below if not already installed. But before you do see my edited post above yours.

sudo apt-get install xserver-xorg-video-nouveau

AFAIK I can't use nouveau (because of Optimus)

$ inxi -GSMr
System:    Host: hostname Kernel: 4.9.0-7-amd64 x86_64 (64 bit) Desktop: Openbox 3.6.1
           Distro: Devuan GNU/Linux ascii
Machine:   Device: laptop System: Micro-Star product: GE70  REV:1.0
           Mobo: Micro-Star model: MS-1756 v: REV:1.0 BIOS: American Megatrends v: E1756IMS.514 date: 03/12/2013
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GK107M [GeForce GTX 660M]
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.02hz
           GLX Renderer: N/A GLX Version: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://pkgmaster.devuan.org/merged/ ascii main contrib non-free
           deb http://pkgmaster.devuan.org/merged/ ascii-updates main contrib non-free
           deb http://pkgmaster.devuan.org/merged/ ascii-security main contrib non-free
           deb http://pkgmaster.devuan.org/merged/ ascii-backports main contrib non-free
           deb http://packages.devuan.org/merged/ ascii main
           deb-src http://packages.devuan.org/merged/ ascii main

Would it be safe to uninstall nvidia driver and related sw and then install again ? If yes, what package manager is most safe in term of preventing / solving dependencies problems ?

Offline

#11 2018-07-17 19:21:36

UnclePa
Member
Registered: 2018-07-06
Posts: 24  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Ah, I was wondering what all the Nvidia stuff was about when lshw only listed Intel.  I forgot about Optimus.  I'll have to bow out.  That's out of my league.

Offline

#12 2018-07-17 20:40:37

fsmithred
Administrator
Registered: 2016-11-25
Posts: 928  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

If you just got the kernel upgrade to 4.9.0-7, try booting the previous kernel (4.9.0-6). Maybe the nvidia packages need to catch up. If you installed from the nvidia binaries instead of from packages in the repo, reinstall/rebuild the driver.

Offline

#13 2018-07-18 07:00:35

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

fsmithred wrote:

If you just got the kernel upgrade to 4.9.0-7, try booting the previous kernel (4.9.0-6). Maybe the nvidia packages need to catch up. If you installed from the nvidia binaries instead of from packages in the repo, reinstall/rebuild the driver.

Booting the previous kernel (4.9.0-6) didn't help. I installed nvidia from packages in the repo.

Offline

#14 2018-07-18 07:04:20

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

UnclePa wrote:

Ah, I was wondering what all the Nvidia stuff was about when lshw only listed Intel.  I forgot about Optimus.  I'll have to bow out.  That's out of my league.

I would call it "100 % optimus problem" if all package dependencies would be ok. I think I need repair package dependencies at first.

Offline

#15 2018-07-18 12:17:49

Panopticon
Member
Registered: 2018-01-27
Posts: 147  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

In my opinion, for that laptop you may be better off using a rolling release linux with latest kernels. Not to say that Devuan would not be able to run it, i have no experience in newer types of laptops. You might try artix linux if you dont want systemd as init. They are breaking new ground and are pretty close to staying on par with arch linux.
https://artixlinux.org/

Offline

#16 2018-07-19 09:43:37

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

Panopticon wrote:

In my opinion, for that laptop you may be better off using a rolling release linux with latest kernels. Not to say that Devuan would not be able to run it, i have no experience in newer types of laptops. You might try artix linux if you dont want systemd as init. They are breaking new ground and are pretty close to staying on par with arch linux.
https://artixlinux.org/


Thank you, I prefer Devuan now. I had same problem on Debian which I've solved. FPS in one 3D game even jumped from 40 to 100 smile

It has little improved in Devuan, but some dependency problems still persists:

# apt install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

# apt-get install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



# aptitude install 
The following NEW packages will be installed:
  nvidia-legacy-304xx-driver{b} nvidia-legacy-304xx-kernel-dkms{b} 
The following packages will be REMOVED:
  libwebrtc-audio-processing-0{u} libxcb-glx0:i386{u} libxcb-present0{u} 
  libxdamage1:i386{u} rtkit{u} 
The following packages are RECOMMENDED but will NOT be installed:
  nvidia-persistenced nvidia-persistenced:i386 nvidia-settings-legacy-304xx 
0 packages upgraded, 2 newly installed, 5 to remove and 0 not upgraded.
Need to get 4026 kB of archives. After unpacking 16.3 MB will be used.
The following packages have unmet dependencies:
 nvidia-legacy-304xx-driver : Depends: nvidia-legacy-304xx-driver-libs (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-legacy-304xx-driver-bin (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: xserver-xorg-video-nvidia-legacy-304xx (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-legacy-304xx-vdpau-driver (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-legacy-304xx-alternative (= 304.137-5~deb9u1) but it is not going to be installed
                              Depends: nvidia-support but it is not going to be installed
 libgl1-mesa-glx : Depends: libxcb-present0 but it is not going to be installed
 libgl1-mesa-glx:i386 : Depends: libxcb-glx0:i386 (>= 1.8) but it is not going to be installed
                        Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed
 nvidia-legacy-304xx-kernel-dkms : Depends: dkms (>= 2.1.0.0) but it is not going to be installed
                                   Depends: nvidia-legacy-304xx-kernel-support--v1 which is a virtual package, provided by:
                                            - nvidia-legacy-304xx-kernel-support:i386 (304.137-5~bpo9+1), but it is not going to be installed
                                            - nvidia-legacy-304xx-kernel-support (304.137-5~bpo9+1), but it is not going to be installed
                                            - nvidia-legacy-304xx-kernel-support:i386 (304.137-5~deb9u1), but it is not going to be installed
                                            - nvidia-legacy-304xx-kernel-support (304.137-5~deb9u1), but it is not going to be installed

The following actions will resolve these dependencies:

      Install the following packages:                                                  
1)      dkms [2.3-2 (now, stable, testing)]                                            
2)      fakeroot:i386 [1.21-3.1 (stable, testing)]                                     
3)      libfakeroot:i386 [1.21-3.1 (stable, testing)]                                  
4)      libgl1-nvidia-legacy-304xx-glx [304.137-5~deb9u1 (stable)]                     
5)      libnvidia-legacy-304xx-cfg1 [304.137-5~deb9u1 (stable)]                        
6)      libnvidia-legacy-304xx-glcore [304.137-5~deb9u1 (stable)]                      
7)      libnvidia-legacy-304xx-ml1 [304.137-5~deb9u1 (stable)]                         
8)      linux-headers-amd64 [4.9+80+deb9u5 (stable, testing)]                          
9)      nvidia-kernel-common:i386 [20151021+4 (stable)]                                
10)     nvidia-legacy-304xx-alternative:i386 [304.137-5~deb9u1 (stable)]               
11)     nvidia-legacy-304xx-driver-bin [304.137-5~deb9u1 (stable)]                     
12)     nvidia-legacy-304xx-driver-libs [304.137-5~deb9u1 (stable)]                    
13)     nvidia-legacy-304xx-kernel-support:i386 [304.137-5~deb9u1 (stable)]            
14)     nvidia-legacy-304xx-vdpau-driver [304.137-5~deb9u1 (stable)]                   
15)     nvidia-modprobe:i386 [384.111-2~deb9u1 (stable)]                               
16)     nvidia-settings-legacy-304xx [304.134-1 (stable)]                              
17)     nvidia-support:i386 [20151021+4 (stable)]                                      
18)     pkgconf:i386 [0.9.12-6 (stable, testing)]                                      
19)     xserver-xorg-video-nvidia-legacy-304xx [304.137-5~deb9u1 (stable)]             

      Keep the following packages at their current version:                            
20)     libxcb-glx0:i386 [1.12-1 (now, stable, testing)]                               
21)     libxcb-present0 [1.12-1 (now, stable, testing)]                                
22)     libxdamage1:i386 [1:1.1.4-2+b3 (now, stable, testing)]                         

      Leave the following dependencies unresolved:                                     
23)     nvidia-legacy-304xx-driver-libs recommends nvidia-legacy-304xx-driver-libs-i386



Accept this solution? [Y/n/q/?] 


# apt --installed list  | grep nvidia

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

glx-alternative-nvidia/stable,now 0.8.3~deb9u1 amd64 [installed]
libegl-nvidia0/stable-backports,now 390.67-2~bpo9+1 amd64 [installed,automatic]
libnvidia-eglcore/stable-backports,now 390.67-2~bpo9+1 amd64 [installed]
nvidia-alternative/stable-backports,now 390.67-2~bpo9+1 amd64 [installed,automatic]
nvidia-egl-common/stable-backports,now 390.67-2~bpo9+1 amd64 [installed,automatic]
nvidia-egl-icd/stable-backports,now 390.67-2~bpo9+1 amd64 [installed,automatic]
nvidia-installer-cleanup/stable,now 20151021+4 amd64 [installed,automatic]
nvidia-legacy-check/stable,now 384.130-1 amd64 [installed,automatic]

Offline

#17 2018-07-27 08:09:40

boycottsystemd
Member
Registered: 2017-09-25
Posts: 62  

Re: ASCII: Can't start Xorg after system upgrade [SOLVED]

It's solved, there is no error message from aptitude install, apt install, apt-get install. I've removed nvidia packages which removed Xorg. Then I installed Xorg, nvidia.

Commands history:

aptitude remove libegl1-mesa
aptitude purge nvidia*
aptitude  remove nvidia-alternative
apt remove glx-alternative-nvidia
aptitude  remove libegl-nvidia0
aptitude install xserver-xorg-video-intel
aptitude install xorg
aptitude install bumblebee-nvidia
aptitude install nvidia-driver
aptitude remove nvidia-legacy-304xx-driver
aptitude remove xserver-xorg-legacy
aptitude remove nvidia-legacy-304xx-kernel-support
apt remove nvidia-legacy-check
aptitude install nvidia-driver-libs-nonglvnd
aptitude install primus

Offline

Board footer