The officially official Devuan Forum!

You are not logged in.

#1 2018-05-13 03:49:58

rsevero
Member
Registered: 2018-05-13
Posts: 12  

[SOLVED] No extensions available in iptables after upgrading do ascii

Hi,


Just upgraded to ascii. Iptables has no extensions: multiport, mark, MASQUERADE. Iptables can't find any.

I have already removed and reinstalled iptables but the issue remains unchanged.

Ideas on how to further debug this issue?

Last edited by rsevero (2018-05-13 13:43:04)

Offline

#2 2018-05-13 09:07:02

KatolaZ
Member
Registered: 2017-03-11
Posts: 36  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

Hi,

which is the issue, exactly? Which error message are you seeing? Which kernel version are you using?  On which platform? (no need to say that I am using some or all of those iptables modules in many ASCII installations, without problems, and I am sure I am not alone here otherwise we would have had thousands of users complaining here and on DNG).

Offline

#3 2018-05-13 10:14:52

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

The issue is that I can't load my iptables rules on Devuan ascii.

The answers to your other questions: https://cdn.pbrd.co/images/HkYd1CW.jpg

I believe iptables is working on Devuan ascii. That's what makes my issue even more strange. I had a regular devuan jessie installed from scratch. The only "difference" I can see in my system was that ia wasn't completely updated (jessie wise) when I upgraded do ascii.

Ideas?

Offline

#4 2018-05-13 10:18:54

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

Apparently the other image is wrongly cropped. Complete one: https://pasteboard.co/HkYhKGn.jpg

Last edited by rsevero (2018-05-13 10:52:16)

Offline

#5 2018-05-13 11:24:30

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 221  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

Seems odd; something must have gone wrong with your upgrade.

a) what's your sources.list (and sources.list.d/*) ?

b) what's your pin preferences

c) what does "apt-get -s dist-upgrade" say (the "-s" means "simulate", i.e., "just analyze what would be done, but don't do it")

Offline

#6 2018-05-13 11:38:41

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

Answers: https://pasteboard.co/HkYMNbT.jpg

I don't know what pin preferences are. Can you tell me where I can find them?

When I upgraded to ascii I was using pkgmaster.devuan.org in my sources.list. Changing to deb.devuan.org didn't produce any new results.

Offline

#7 2018-05-13 12:28:43

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 221  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

If you don't know, then you probably haven't set any pin preferences.

You do know that the last image was 116 Mb, I suppose. Please use the text copied into the posts, rather. You can pipe output to file, or use script to get a typescript file.

Anyhow, I'm guesing your iptables (v1.6.1) is from ascii-backports; where's your kernel from?
Do you have the /lib/modules/$(uname -r) sub tree with kernel modules?
Specifically do you have /lib/modules/$(uname -r)/kernel/net/ipv4/netfilter/ipt_MASQUERADE.ko, which is the module concerned?

Offline

#8 2018-05-13 12:52:01

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

ralph.ronnquist wrote:

You do know that the last image was 116 Mb, I suppose.

I bet it was 11.6 Mb but I understand the inconvenience.

ralph.ronnquist wrote:

Please use the text copied into the posts, rather. You can pipe output to file, or use script to get a typescript file.

I'm having some dificulties doing so as the affected machine is my server/router which has no X so my desktop machines have no internet connection if I connect them in my internal network. All info I'm passing is going through my cel phone so it's hard to capture the text. That's why I'm sending photos...

ralph.ronnquist wrote:

Anyhow, I'm guesing your iptables (v1.6.1) is from ascii-backports; where's your kernel from?

I'm not sure. How can I found out?

ralph.ronnquist wrote:

Do you have the /lib/modules/$(uname -r) sub tree with kernel modules?

Yes, I do.

ralph.ronnquist wrote:

Specifically do you have /lib/modules/$(uname -r)/kernel/net/ipv4/netfilter/ipt_MASQUERADE.ko, which is the module concerned?

Also yes.

Offline

#9 2018-05-13 13:17:58

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 221  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

ok. Why did you install iptables from backports?

Offline

#10 2018-05-13 13:22:01

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

ralph.ronnquist wrote:

ok. Why did you install iptables from backports?

Did I? How would I do it differently? As far as I can tell I just installed iptables when first installing Devuan jessie and them upgraded to ascii.

Offline

#11 2018-05-13 13:25:14

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

I've just purged iptables and it's dependencies from my server, commented out the backports line in my sources.list, them:

* apt-get update
* apt-get install iptables

The problems remains unchanged.

Offline

#12 2018-05-13 13:39:30

rsevero
Member
Registered: 2018-05-13
Posts: 12  

Re: [SOLVED] No extensions available in iptables after upgrading do ascii

I have just found out the problem: I had manually compiled/installed an updated iptables version (1.6.1) on jessie.

After removing it, purging and reinstalling regular iptables, everything seems to be working again.

Thanks for your help and sorry for the troubles.

Offline

Board footer