The officially official Devuan Forum!

You are not logged in.

#1 2018-04-23 11:32:05

sacarde
Member
Registered: 2018-04-23
Posts: 8  

wireless problem on qemu

hi,
   I use same usb-wireless (Atheros AR9271) in 2 virtualized system:

1) debian/sid
2) devuan

I use same configuration:

allow-hotplug wlan0
iface wlan0 inet dhcp
wireless-essid NETGEAR

in debian system, wlan0 get IP address OK
in devuan system I receive error:

ifup wlan0
Internet Systems Consortium DHCP Client 4.3.1
Copyright 2004-2014 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/e0:46:9a:0d:72:0c
Sending on   LPF/wlan0/e0:46:9a:0d:72:0c
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


in both system eth0 in dhcp works OK



what can I check?




thank you

Offline

#2 2018-04-23 13:34:37

wdq
Member
Registered: 2018-03-15
Posts: 37  

Re: wireless problem on qemu

have you installed wpasupplicant , if yes just add it in your etc/network/interfaces


 auto wlan0
  iface wlan0 inet dhcp
  wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf 

restart networking

Offline

#3 2018-04-23 14:51:06

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

in both systems I dont have wpasupplicant

Offline

#4 2018-04-23 15:16:48

wdq
Member
Registered: 2018-03-15
Posts: 37  

Re: wireless problem on qemu

Well let`s try this
apt-get install wpasupplicant

 apt-get install wpasupplicant 

now you need to create a configuration file so

nano /etc/wpa_supplicant/wpa_supplicant.conf

Add the next content in your config file where you have to change network_id and password with your own

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
  ssid="network_id"
  psk="password"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=TKIP
  group=TKIP

Now let`s modify the network/interfaces

nano /etc/network/interfaces

and add modify like this

auto wlan0
  iface wlan0 inet dhcp
  wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

and give a reboot

Hope this helps !

Offline

#5 2018-04-23 15:19:17

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

my network has only essid NETGEAR

no any other key/password

what I have to set this:

  ssid="network_id"
  psk="password"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=TKIP
  group=TKIP


?

Last edited by sacarde (2018-04-23 15:19:44)

Offline

#6 2018-04-23 15:24:09

wdq
Member
Registered: 2018-03-15
Posts: 37  

Re: wireless problem on qemu

Well then just modify like this the content of wpa_supplicant.conf

 key_mgmt=NONE

and do not add the

  psk="password"

line .

Offline

#7 2018-04-23 15:38:35

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

this is my /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
  ssid="NETGEAR"
  proto=WPA
  key_mgmt=NONE
  pairwise=TKIP
  group=TKIP
  }

but after reboot, same problem:

eth0 have an IP
wlan0 no

Offline

#8 2018-04-23 16:25:12

wdq
Member
Registered: 2018-03-15
Posts: 37  

Re: wireless problem on qemu

ok try to change the proto= WPA line to proto=RSN

and ifdown eth0 to see if there is a conflict between eth0 and wlan0

but you shoud try wicd more secure and has a gui .

Offline

#9 2018-04-23 18:46:53

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

same problem



p.s.
adding other info

iwlist scan
ens3      Interface doesn't support scanning.
wlan0    Interface doesn't support scanning : Device or resource busy
lo           Interface doesn't support scanning.

Last edited by sacarde (2018-04-27 09:46:51)

Offline

#10 2018-04-29 07:40:07

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

other info from dmesg:

[  106.224185] usb 1-1: new full-speed USB device number 2 using uhci_hcd
[  106.645996] usb 1-1: config 1 interface 0 altsetting 0 endpoint 0x1 has invalid maxpacket 512, setting to 64
[  106.646006] usb 1-1: config 1 interface 0 altsetting 0 endpoint 0x82 has invalid maxpacket 512, setting to 64
[  106.646009] usb 1-1: config 1 interface 0 altsetting 0 endpoint 0x5 has invalid maxpacket 512, setting to 64
[  106.646012] usb 1-1: config 1 interface 0 altsetting 0 endpoint 0x6 has invalid maxpacket 512, setting to 64
[  106.659511] usb 1-1: New USB device found, idVendor=0846, idProduct=9030
[  106.659524] usb 1-1: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[  106.659530] usb 1-1: Product: WNA1100
[  106.659534] usb 1-1: Manufacturer: NETGEAR WNA
[  106.659538] usb 1-1: SerialNumber: 12345
[  106.715384] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
[  106.716669] usb 1-1: firmware: direct-loading firmware htc_9271.fw
[  106.717127] usbcore: registered new interface driver ath9k_htc
[  107.060489] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 50980
[  107.323928] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits

Offline

#11 2018-04-30 01:53:18

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 253  

Re: wireless problem on qemu

Have you tried with rfkill (tool for enabling and disabling wireless devices)? As in a "googled" example:

# modprobe -rf ath9k ath9k_htc
# rfkill unblock all
# modprobe ath9k ath9k_htc

I'm not sure what's the difference from Debian though. It would depend on versions, since the code for bringing up interfaces has had some development recently (last few years). Not long ago, it had a bug where the script could query the interface state too early after power-on. The patch against that problem was to add a sleep into the script between starting the interface and checking its state.

You could also try to use the "auto" method rather than "allow-hotplug", to let the networking init script raise the interface instead of (e)udev.

Offline

#12 2018-04-30 09:51:49

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

- rfkill are not blocked


- auto or allow-hotplug same problem


- is OK that I view nothing running:

dmesg|grep wlan

?

Last edited by sacarde (2018-04-30 09:53:33)

Offline

#13 2018-04-30 10:55:45

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 253  

Re: wireless problem on qemu

As the dongle behaves in your Debian and mis-behaves in your Devuan, there must be some difference in the code involved, obviously. The start point for tracking that down would be in the versions: of the kernels, of the ath modules and firmwares, of the hotplug handlers, etc. Perhaps you can make a table. Then it would be possible to experiment by aligning versions where possible, and by inspecting the differences more exactly otherwise.

btw, there is also the iw tool (from wireless-tools) for

# iw dev wlan0 scan

Rumours has it that sometimes that works where iwlist fails.

Offline

#14 2018-04-30 11:43:27

sacarde
Member
Registered: 2018-04-23
Posts: 8  

Re: wireless problem on qemu

ralph.ronnquist wrote:

...
btw, there is also the iw tool (from wireless-tools) for

# iw dev wlan0 scan

Rumours has it that sometimes that works where iwlist fails.

same error



- what can I view about:

wlan0    Interface doesn't support scanning : Device or resource busy


p.s.
I virtualized:

kubuntu16.04 works OK
kubuntu18.04 dont works
ubuntu14.04 works OK

Offline

Board footer