The officially official Devuan Forum!

You are not logged in.

#1 2018-01-30 10:07:24

devuan_dk_fan
Member
Registered: 2018-01-10
Posts: 90  

Recommended installation method for newer version of HPLIP - Jessie.

What is the recommended method of installing a newer version of HPLIP on Devuan Jessie? I need to be able to get my HP DeskJet 3632 printer to work with Devuan Jessie. I have tried backports and the driver is still AWOL. With the experimental repo, I ran into a problem with the necessary HPLIP dependencies going unmet as the required dependencies were older than what apt could pull in from the experimental repo. I have also tried downloading the latest HPLIP from the HP developers site, but the script/installer doesn't recognize Devuan and when I choose "Debian" as the distro, it prompts me for the following:

11    8.0 ("Jessie", Released 04/05/2015)
12    8.1 ("Jessie", Released 04/05/2015)
13    8.2 ("Jessie", Released 04/05/2015)
14    8.3 ("Jessie", Released 04/05/2015)
15    8.4 ("Jessie", Released 04/05/2016)
16    8.5 ("Jessie", Released 27/08/2016)
17    8.6 ("Jessie", Released 22/10/2016)
18    8.7 ("Jessie", Released 22/10/2016)
19    8.8 ("Jessie", Released 31/05/2017)

and I am not sure what I should answer as I don't which release Devuan is most compatible with.

Help would be appreciated.


Military justice is to justice what military music is to music. - Groucho Marx

Offline

#2 2018-01-30 10:20:01

Geoff 42
Member
Registered: 2016-12-15
Posts: 180  

Re: Recommended installation method for newer version of HPLIP - Jessie.

I have an HP DeskJet 3630 and I am using printer-driver-hpcups 3.14.6-1+deb8u1 and it all seems to work nicely, including scanning.
This is running under Jessie.

Geoff

Last edited by Geoff 42 (2018-01-30 10:24:05)

Offline

#3 2018-01-30 11:26:26

devuan_dk_fan
Member
Registered: 2018-01-10
Posts: 90  

Re: Recommended installation method for newer version of HPLIP - Jessie.

Geoff 42 wrote:

I have an HP DeskJet 3630 and I am using printer-driver-hpcups 3.14.6-1+deb8u1 and it all seems to work nicely, including scanning.
This is running under Jessie.

Thanks for that Geoff. Hmmm. Unfortunately, apt seems to be hungover from trying to install hplip from experimental:

$ sudo apt-get install hplip
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 hplip : Depends: libhpmud0 (= 3.14.6-1+deb8u1) but 3.16.11+repack0-1~bpo8+1 is to be installed
         Depends: libsane-hpaio (= 3.14.6-1+deb8u1) but 3.16.11+repack0-1~bpo8+1 is to be installed
         Depends: printer-driver-hpcups (= 3.14.6-1+deb8u1) but 3.16.11+repack0-1~bpo8+1 is to be installed
         Recommends: printer-driver-postscript-hp but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Except that I don't:

$ dpkg -l | grep "^hi"

returns nothing. I have also tried:

sudo apt-get update
sudo apt-get install -f
sudo apt-get dist-upgrade
sudo apt-get update

but apt still gives me the above unmet dependencies message.

Last edited by devuan_dk_fan (2018-01-30 11:27:09)


Military justice is to justice what military music is to music. - Groucho Marx

Offline

#4 2018-01-30 11:43:22

devuan_dk_fan
Member
Registered: 2018-01-10
Posts: 90  

Re: Recommended installation method for newer version of HPLIP - Jessie.

OK, I found the problem. I went into Synaptic and used the "mark all upgrades" command. I was told that a couple of packages needed to be downgraded. Everything works now, and I installed printer-driver-hpcups.


Military justice is to justice what military music is to music. - Groucho Marx

Offline

#5 2018-01-30 11:53:50

devuan_dk_fan
Member
Registered: 2018-01-10
Posts: 90  

Re: Recommended installation method for newer version of HPLIP - Jessie.

What model did you use when you setup your 3630? I don't see any model number that even approximates. I tried Deskjet/deskjet, but nothing prints...
----
Interesting. I went into the CUPS web interface <http://localhost:631/admin/> and was able to set up the printer without any problem, after I installed the backports version of hplip. I am using the Trinity desktop environment, and for some reason, the newer printer drivers aren't listed in the GUI setup.

Last edited by devuan_dk_fan (2018-01-30 16:08:59)


Military justice is to justice what military music is to music. - Groucho Marx

Offline

#6 2018-01-30 16:45:45

Geoff 42
Member
Registered: 2016-12-15
Posts: 180  

Re: Recommended installation method for newer version of HPLIP - Jessie.

I don't recall doing anything clever. However, as I look around my own src directory for clues, I have spotted an HP subdirectory which contains hplip-3.16.8.

I have now spotted the HP web pages at :-
https://developers.hp.com/hp-linux-imaging-and-printing
which show which versions are needed to support recent models. You can then download the latest version, if necessary.

Geoff

Offline

Board footer