The officially official Devuan Forum!

You are not logged in.

#1 2018-01-23 21:39:39

Mr.Bean
Member
Registered: 2018-01-23
Posts: 2

Good Life Linux issue with OpenBox

Hi,


     I use Good Life Linux but each time I wanted to shut down from OpenBox exit menu, nothing happens. I have to log off or switch user and then quit/shutdown.


Second issue is: I installed docky but when I closed the lid of the laptop, docky "disappears" or closed...

Offline

#2 2018-01-24 01:23:41

MiyoLinux
Member
Registered: 2016-12-05
Posts: 446

Re: Good Life Linux issue with OpenBox

Mr. Bean, smile  (one of my favorite characters!)

I don't know if I can help much.

The issue that you described with Docky is a well-known bug, so it's not specific to Devuan. I remember seeing some work-arounds found online for Ubuntu that involved making some scripts, but when I tried them on Devuan about a year ago, they didn't work. In the end, I found it easiest to just open gmrun and enter...

docky

...to quickly get the dock back again. I know that's not your preferred method, but that's what suited me. Someone else may have a better answer.

As to the problem with Shutdown...

After reading your post, I downloaded the 64 bit version of Good Life Linux Openbox. I ran all updates...I used...

apt-get dist-upgrade

...because I knew there would be a newer kernel. That .iso is pretty old. I rebooted, and the Shutdown option is working perfectly for me...so I'm not sure what could be the problem. Here's my suggestion...open your terminal and enter...

obsession-logout

When the GUI opens, click on Shutdown...does the terminal give any information?


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#3 2018-01-30 20:58:02

Mr.Bean
Member
Registered: 2018-01-23
Posts: 2

Re: Good Life Linux issue with OpenBox

Hi, thanks for the reply...


     Good Life Linux doesen't inclueded gmrun by default, so what I did to start Docky again is by running it in terminal. And here what I get:

[Info  15:47:02.050] Docky version: 2.2.0 Release
[Info  15:47:02.099] Kernel version: 3.16.0.5
[Info  15:47:02.102] CLR version: 4.0.30319.17020
[Error 15:47:02.771] [SystemService] Could not initialize power manager dbus: 'org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.UPower" doesn't exist
'
[Info  15:47:02.774] [SystemService]   at Docky.Services.SystemService+IUPowerProxy.Get (System.String interface, System.String propname) [0x00000] in <filename unknown>:0
  at Docky.Services.SystemService.HandleUPowerChanged () [0x00000] in <filename unknown>:0
  at Docky.Services.SystemService.InitializeBattery () [0x00000] in <filename unknown>:0
[Error 15:47:02.776] [SystemService] Network Manager is not available.
[Info  15:47:02.791] [ThemeService] Setting theme: HUD
[Warn  15:47:02.892] [DesktopItemService] Could not find remap file '/home/Mr.Bean/.local/share/docky/remaps.ini'!
[Info  15:47:03.208] [DockServices] Dock services initialized.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/Mr.Bean/.config/fontconfig/fonts.conf manually
[Info  15:47:04.149] [PluginManager] Loaded "Trash".
[Info  15:47:04.209] [PluginManager] Loaded "Clippy".
[Info  15:47:04.209] [PluginManager] Loaded "CPU Monitor".
[Info  15:47:04.267] [PluginManager] Loaded "Network Manager".
[Info  15:47:04.342] [PluginManager] Loaded "Docky.Widgets,1.0".
[Info  15:47:04.342] [PluginManager] Loaded "Weather".
[Info  15:47:04.343] [PluginManager] Loaded "Mounter".
[Info  15:47:04.444] [PluginManager] Loaded "Battery Monitor".
[Info  15:47:04.445] [PluginManager] Loaded "Network Monitor".
[Error 15:47:04.465] [ConnectionManager] Object reference not set to an instance of an object
[Error 15:47:04.465] [ConnectionManager] Object reference not set to an instance of an object

(Docky:842): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(Docky:842): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(Docky:842): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(Docky:842): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(Docky:842): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE
[Info  15:47:05.098] [AbstractWeatherSource] Weather Channel: Reloading weather data
Cairo.Surface is leaking, programmer is missing a call to Dispose
Set MONO_CAIRO_DEBUG_DISPOSE to track allocation traces

I hope it help but the problem is, when I closed the terminal, it also closed the app Docky...


As fot the shutdown issue, here is the message:

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/Mr.Bean/.config/fontconfig/fonts.conf manually

And by clicking on the shutdown button dosen't change anything... no shutdown or anything else...

BTW, I have the 32 bit version and is regularly updated...

Last edited by Mr.Bean (2018-01-30 21:11:56)

Offline

#4 2018-01-31 22:06:54

MiyoLinux
Member
Registered: 2016-12-05
Posts: 446

Re: Good Life Linux issue with OpenBox

Hi Mr. Bean.

Just to be sure, I downloaded the 32 bit version and installed it. I ran all updates, rebooted, and all of the shutdown options are working...so I'm not sure what could be the problem.

You might try reinstalling obsession-logout to see if that helps...not sure if it will. I'll give an alternative at the end of this post.

I don't think that font warning should have anything to do with it; however, it appears that the .font.conf file is causing a problem. I tried running obsession-logout from the terminal, and I got the same message as you (even though all of my shutdown options are working). I then looked in the ~/.config/fontconfig/ folder, and that file already exists there...so I just deleted the .fonts.conf file from the Home folder. After doing that, I tried it all again, and the error message was gone.

If you're unsure how to do that, just open your file manager. Right click on an empty space, and choose "Show hidden files". Then look for the file called .fonts.conf and click on it one time to highlight it. After highlighting it, click on Edit in the tool bar and then click Remove.

As to Docky...I mentioned earlier that what you're experiencing is a well-known and long-standing bug with Docky. I don't know a fix for it...sorry. Perhaps someone else here may know of one? If so, please feel free to post it! smile

The application gmrun is in the 32 bit version and 64 bit versions that I downloaded...it's one of the items at the top of the right-click menu, but it's named as "Run command".  Try clicking on that, and a small window will open in the center of your screen. Type in the word docky, and hit Enter on your keyboard, and Docky should start again. Sorry that I couldn't be more help with that problem.

Now...if fixing that font error and reinstalling obsession-logout doesn't help, here's a possible fix for you...it may not be what you prefer, but it will at least hopefully get you back to being able to Shutdown, reboot, etc. This is actually the method that I included with Miyo-i3, and I'm considering using it in future versions of MiyoLinux...haven't decided yet though. Anyway...

ALTERNATIVE SHUTDOWN OPTIONS

Edited to add: before anything else...let's try something first. The following command should reboot your computer, so only do this when you're ready to try a reboot. If this works, then proceed with the rest of the instructions...

Open your terminal, and copy and paste the following command to see if it will reboot your computer...

dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Restart

...then hit Enter on your keyboard.

If that rebooted your computer, proceed with the following instructions.

Open the right-click menu, and go to...

Advanced > Obmenu-Generator > Menu Schema

When that opens, scroll to the bottom of the file, and you should see these lines...

## This uses the 'oblogout' menu
    {item => ['obsession-logout', 'Exit', 'exit']},
]

Now...put your cursor at the end of the line...

{item => ['obsession-logout', 'Exit', 'exit']},

...and hit Enter on your keyboard. That should put a space between that line and the ] symbol below it. So it should now look like this...

## This uses the 'oblogout' menu
    {item => ['obsession-logout', 'Exit', 'exit']},

]

Now...in that empty space that you just created, copy and paste the following into it...

{begin_cat => ['Exit', 'exit']},
    {item => ['openbox --exit',  'Logout',  'gnome-logout']},
    {item => ['dbus-send --system --print-reply --dest="org.freedesktop.UPower" /org/freedesktop/UPower org.freedesktop.UPower.Hibernate',  'Hibernate',  'gnome-session-hibernate']},
    {item => ['dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Restart', 'Reboot', 'gtk-refresh']},
    {item => ['dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Stop', 'Shutdown', 'gnome-shutdown']},
{end_cat => undef},

MAKE SURE THE...
]
...SYMBOL IS BELOW THOSE LINES! smile

So, the bottom of the Menu Schema file should now look like this...

    ## This uses the 'oblogout' menu
    {item => ['obsession-logout', 'Exit', 'exit']},
    {begin_cat => ['Exit', 'exit']},
    {item => ['openbox --exit',  'Logout',  'gnome-logout']},
    {item => ['dbus-send --system --print-reply --dest="org.freedesktop.UPower" /org/freedesktop/UPower org.freedesktop.UPower.Hibernate',  'Hibernate',  'gnome-session-hibernate']},
    {item => ['dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Restart', 'Restart', 'gtk-refresh']},
    {item => ['dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Stop', 'Shutdown', 'gnome-shutdown']},
    {end_cat => undef},
]

Save and close the file.

At this time, you will have two exit options in your right-click menu. The ones that we just added requires you to hover your mouse cursor over the word Exit, and it will give you the following options...

Logout
Hibernate (I didn't check, but you might have to install the package called hibernate if you use this)
Reboot
Shutdown

Clicking on any of those options will immediately go into effect...If they work, and you're happy with that, then you can open that same file again, and comment out the other original Exit option...just put a # symbol in front of the following line...

{item => ['obsession-logout', 'Exit', 'exit']},

...so that it looks like this...

#{item => ['obsession-logout', 'Exit', 'exit']},

Then save and close the file again, and you'll only have the new Exit options in your menu.

This may not be your preferred answer, but hopefully it will help as a last resort.

Last edited by MiyoLinux (2018-01-31 23:15:52)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

Board footer