The officially official Devuan Forum!

You are not logged in.

#1 2017-12-26 18:28:53

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

New Refracta Isos

I've uploaded new refracta-9 no-X isos:
https://sourceforge.net/projects/refrac … s/testing/

Based on Devuan-2.0 ASCII (pre-beta by probably a few days)

No-X does not mean minimal. It's crammed with a lot of extra utilities, as usual.

login:password    user:user    root:root

No refracta9 desktop isos yet. I might upload ones made from systems upgraded from jessie, but they are bigger than CD size. I haven't decided yet how to get them down to CD size. I'll take suggestions on what packages to leave out.

Update (2017-12-30): Newer installer fixes some bugs. Also includes partial German translation.
https://sourceforge.net/projects/refrac … b/download

* select_grub_dev if grub-pc is copied to /target and installed. (Fixes no bootloader installed on bios system)
* Fixed disable autologin when sudo is default.
* Include preliminary (partial) German translation file. refractainstaller-base (9.3.2)

Offline

#2 2017-12-27 16:53:30

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

When I downloaded it said 0 downloads, so I am the happy 1st.
The iso was fine, I tried it into machines, one with bios, the other uefi.
My openbox and lx-tools installed quick on the live session, then I used the console refractainstaller instead of the gui for once.  Worked well..
I chrooted to finish up fstab touches and remove the 4,9-03 kernel.
I then tried to add a repository that needed a gpg key and gpg was nowhere to be found on ascii.  The alternative just didn't work.  So I skipped into ceres and got the gnupg and gpg as well as a few associated files that weren't installable in ascii.
Weird, this didn't happen before.
End result refracta-devuan-2.0 kicks behinds!

It is unbelievable that with all the crap I loaded into the live (nearing its maximum space of 2GB??)  it transfered everything so damn fast.  It even carried a couple of debs that had no space to install live so I did them on metal.

Good work but what's up with gpg?

Offline

#3 2017-12-27 16:56:03

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

I even got obmenu-generator and conky-manager running on live and when I booted everything was nice and clean.

Ascii is nowhere close to being stable, it is missing lots of stuff I think, but as long as I can grab them from ceres I won't complaint.

Offline

#4 2017-12-27 19:35:16

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

Re: New Refracta Isos

gnupg is installed. I don't think I could have installed any packages from the main repo without it.

user@refracta:~$ whereis gpg
gpg: /usr/bin/gpg /usr/share/man/man1/gpg.1.gz

user@refracta:~$ gpg --list-keys
gpg: directory '/home/user/.gnupg' created
gpg: keybox '/home/user/.gnupg/pubring.kbx' created
gpg: /home/user/.gnupg/trustdb.gpg: trustdb created


user@refracta:~$ dpkg -l gnupg
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                     Version           Architecture      Description
+++-========================-=================-=================-=====================================================
ii  gnupg                    2.1.18-8          amd64             GNU privacy guard - a free PGP replacement

What was missing that you had to pull from ceres? I've been using ascii, and it seems fine. There are a few more devuanized packages that need to get into the repo, but it's based on stretch, so just about everything should be working correctly.

Offline

#5 2017-12-27 19:57:58

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

This wouldn't work

gpg --keyserver keys.gnupg.net --recv A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89
gpg --export A3C4F0F979CAA22CDBA8F512EE8CBC9E886DDD89 | sudo apt-key add -

Offline

#6 2017-12-27 23:42:11

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

Somehow I ended up with 2.2.3-1 from ceres as ascii wasn't making them available.
Maybe a bad mirror coincidence?

Offline

#7 2017-12-28 00:00:05

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

Does this look right to you?

apt install openrc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dbus : Depends: adduser but it is not going to be installed
        Depends: init-system-helpers (>= 1.3~) but it is not going to be installed
        Depends: libapparmor1 (>= 2.8.95) but it is not going to be installed
        Depends: libexpat1 (>= 2.0.1) but it is not going to be installed
 dconf-gsettings-backend : Depends: dconf-service (>= 0.26.0-2) but it is not going to be installed
                           Depends: dconf-service (< 0.26.0-2.1~) but it is not going to be installed
                           Depends: libdconf1 (= 0.26.0-2+b1) but it is not going to be installed
 gconf-service : Depends: libldap-2.4-2 (>= 2.4.7) but it is not going to be installed
                 Depends: gconf2-common (= 3.2.6-4) but it is not going to be installed
 gnome-icon-theme : Depends: gtk-update-icon-cache but it is not going to be installed
                    Depends: librsvg2-common but it is not going to be installed
 gnome-keyring : Depends: gcr (>= 3.4) but it is not going to be installed
                 Depends: p11-kit (>= 0.16) but it is not going to be installed
                 Depends: pinentry-gnome3 but it is not going to be installed
 libacl1 : Depends: libattr1 (>= 1:2.4.46-8) but it is not going to be installed
 libbonoboui2-0 : Depends: libgnomecanvas2-0 (>= 2.11.1) but it is not going to be installed
 libc6 : Conflicts: openrc (< 0.27-2~) but 0.23-1+b1 is to be installed
 libcairo2 : Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
             Depends: libxcb-render0 but it is not going to be installed
 libcanberra0 : Depends: libasound2 (>= 1.0.16) but it is not going to be installed
                Depends: libltdl7 (>= 2.4.6) but it is not going to be installed
                Depends: libtdb1 (>= 1.2.7+git20101214) but it is not going to be installed
                Depends: libvorbisfile3 (>= 1.1.2) but it is not going to be installed
 libcap2-bin : Depends: libcap2 (>= 1:2.10) but it is not going to be installed
               Recommends: libpam-cap but it is not going to be installed
 libegl1-mesa : Depends: libexpat1 (>= 2.0.1) but it is not going to be installed
                Depends: libwayland-server0 (>= 1.2.0) but it is not going to be installed
                Depends: libx11-xcb1 but it is not going to be installed
                Depends: libxcb-dri2-0 (>= 1.8) but it is not going to be installed
                Depends: libxcb-dri3-0 but it is not going to be installed
                Depends: libxcb-present0 but it is not going to be installed
                Depends: libxcb-sync1 but it is not going to be installed
                Depends: libxcb-xfixes0 but it is not going to be installed
 libfontconfig1 : Depends: libexpat1 (>= 2.0.1) but it is not going to be installed
                  Depends: fontconfig-config (>= 2.11.0-6.7) but it is not going to be installed
 libfreetype6 : Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
 libgail-common : Depends: libgail18 (= 2.24.31-2) but it is not going to be installed
                  Depends: libxdamage1 (>= 1:1.1) but it is not going to be installed
                  Depends: libxfixes3 but it is not going to be installed
 libgbm1 : Depends: libexpat1 (>= 2.0.1) but it is not going to be installed
           Depends: libwayland-server0 (>= 1.2.0) but it is not going to be installed
 libgconf-2-4 : Depends: gconf2-common (= 3.2.6-4) but it is not going to be installed
 libgcrypt20 : Depends: libgpg-error0 (>= 1.25) but it is not going to be installed
 libgdk-pixbuf2.0-0 : Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
                      Depends: libtiff5 (>= 4.0.3) but it is not going to be installed
 libgl1-mesa-glx : Depends: libexpat1 (>= 2.0.1) but it is not going to be installed
                   Depends: libx11-xcb1 but it is not going to be installed
                   Depends: libxcb-dri2-0 (>= 1.8) but it is not going to be installed
                   Depends: libxcb-dri3-0 but it is not going to be installed
                   Depends: libxcb-glx0 (>= 1.8) but it is not going to be installed
                   Depends: libxcb-present0 but it is not going to be installed
                   Depends: libxcb-sync1 but it is not going to be installed
                   Depends: libxdamage1 (>= 1:1.1) but it is not going to be installed
                   Depends: libxfixes3 but it is not going to be installed
                   Recommends: libgl1-mesa-dri but it is not going to be installed
 libglib2.0-0 : Depends: libffi6 (>= 3.0.4) but it is not going to be installed
                Depends: libmount1 (>= 2.20.1) but it is not going to be installed
                Depends: libpcre3 but it is not going to be installed
                Recommends: xdg-user-dirs but it is not going to be installed
 libgnome-2-0 : Depends: libgnomevfs2-0 (>= 1:2.17.90) but it is not going to be installed
                Depends: libgnome2-common (= 2.32.1-5) but it is not going to be installed
 libgnomevfs2-extra : Depends: libgnomevfs2-0 (>= 1:2.17.90) but it is not going to be installed
                      Depends: libgnomevfs2-common (= 1:2.24.4-6.1) but it is not going to be installed
 libgnutls30 : Depends: libgmp10 (>= 2:6) but it is not going to be installed
               Depends: libhogweed4 but it is not going to be installed
               Depends: libidn11 (>= 1.13) but it is not going to be installed
               Depends: libnettle6 but it is not going to be installed
 libgssapi-krb5-2 : Depends: libcomerr2 (>= 1.34) but it is not going to be installed
                    Depends: libk5crypto3 (>= 1.8+dfsg) but it is not going to be installed
                    Depends: libkeyutils1 (>= 1.4) but it is not going to be installed
                    Depends: libkrb5-3 (= 1.15-1+deb9u1) but it is not going to be installed
                    Depends: libkrb5support0 (>= 1.15~beta1) but it is not going to be installed
 libgtk-3-0 : Depends: libgtk-3-common (>= 3.22.11-1) but it is not going to be installed
              Depends: libatk-bridge2.0-0 (>= 2.5.3) but it is not going to be installed
              Depends: libcairo-gobject2 (>= 1.10.0) but it is not going to be installed
              Depends: libcolord2 (>= 0.1.29) but it is not going to be installed
              Depends: libcups2 (>= 1.6.0) but it is not going to be installed
              Depends: librest-0.7-0 (>= 0.7) but it is not going to be installed
              Depends: libsoup2.4-1 (>= 2.4.0) but it is not going to be installed
              Depends: libwayland-cursor0 (>= 1.9.91) but it is not going to be installed
              Depends: libwayland-egl1-mesa (>= 10.0.2) but it is not going to be installed or
                       libwayland-egl1
              Depends: libxcursor1 (> 1.1.2) but it is not going to be installed
              Depends: libxdamage1 (>= 1:1.1) but it is not going to be installed
              Depends: libxfixes3 but it is not going to be installed
              Depends: adwaita-icon-theme but it is not going to be installed
              Recommends: libgtk-3-bin but it is not going to be installed
 libgtk2.0-0 : Depends: libcups2 (>= 1.6.0) but it is not going to be installed
               Depends: libxcursor1 (> 1.1.2) but it is not going to be installed
               Depends: libxdamage1 (>= 1:1.1) but it is not going to be installed
               Depends: libxfixes3 but it is not going to be installed
               Recommends: libgtk2.0-bin but it is not going to be installed
 libgudev-1.0-0 : Depends: libudev1 (>= 183)
 libp11-kit0 : Depends: libffi6 (>= 3.0.4) but it is not going to be installed
 libpam-runtime : Depends: debconf (>= 0.5) but it is not going to be installed or
                           debconf-2.0
                  Depends: debconf (>= 1.5.19) but it is not going to be installed or
                           cdebconf but it is not going to be installed
                  Depends: libpam-modules (>= 1.0.1-6) but it is not going to be installed
 libpam0g : Depends: debconf (>= 0.5) but it is not going to be installed or
                     debconf-2.0
 libpango-1.0-0 : Depends: fontconfig (>= 2.1.91) but it is not going to be installed
                  Depends: libthai0 (>= 0.1.22-3~) but it is not going to be installed
 libpangoft2-1.0-0 : Depends: libharfbuzz0b (>= 0.9.42) but it is not going to be installed
 libselinux1 : Depends: libpcre3 but it is not going to be installed
 libsm6 : Depends: libuuid1 (>= 2.16) but it is not going to be installed
 libsystemd0 : PreDepends: liblz4-1 (>= 0.0~r113) but it is not going to be installed
               PreDepends: liblzma5 (>= 5.1.1alpha+20120614) but it is not going to be installed
 libusb-1.0-0 : Depends: libudev1 (>= 183)
 libwayland-client0 : Depends: libffi6 (>= 3.0.4) but it is not going to be installed
 libwww-perl : Depends: perl but it is not going to be installed
               Depends: ca-certificates but it is not going to be installed
               Depends: libencode-locale-perl but it is not going to be installed
               Depends: libfile-listing-perl but it is not going to be installed
               Depends: libhtml-parser-perl but it is not going to be installed
               Depends: libhtml-tagset-perl but it is not going to be installed
               Depends: libhtml-tree-perl but it is not going to be installed
               Depends: libhttp-cookies-perl but it is not going to be installed
               Depends: libhttp-date-perl but it is not going to be installed
               Depends: libhttp-message-perl but it is not going to be installed
               Depends: libhttp-negotiate-perl but it is not going to be installed
               Depends: liblwp-mediatypes-perl but it is not going to be installed
               Depends: liblwp-protocol-https-perl but it is not going to be installed
               Depends: libnet-http-perl (>= 6.07) but it is not going to be installed
               Depends: liburi-perl but it is not going to be installed
               Depends: libwww-robotrules-perl but it is not going to be installed
               Recommends: libhtml-form-perl but it is not going to be installed
               Recommends: libhtml-format-perl but it is not going to be installed
               Recommends: libhttp-daemon-perl but it is not going to be installed
               Recommends: libmailtools-perl but it is not going to be installed
 libxfont2 : Depends: libfontenc1 but it is not going to be installed
 libxml2 : Depends: libicu57 (>= 57.1-1~) but it is not going to be installed
           Depends: liblzma5 (>= 5.1.1alpha+20120614) but it is not going to be installed
           Recommends: xml-core but it is not going to be installed
 openrc : PreDepends: init-system-helpers (>= 1.29) but it is not going to be installed
          Depends: insserv but it is not going to be installed
          Depends: libeinfo1 but it is not going to be installed
          Depends: librc1 but it is not going to be installed
 policykit-1 : Depends: libpolkit-agent-1-0 (>= 0.105) but it is not going to be installed
               Depends: libpolkit-backend-1-0 (>= 0.99) but it is not going to be installed
               Depends: consolekit but it is not going to be installed
 udev : Depends: eudev but it is not going to be installed
 xserver-common : Depends: x11-xkb-utils but it is not going to be installed
                  Recommends: xfonts-base but it is not going to be installed
                  Recommends: xauth but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Offline

#8 2017-12-28 02:41:41

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

Re: New Refracta Isos

No, that does not look right. Some of the versions mention on needed packages could be satisfied by jessie versions, some by ascii versions. I don't know what's going on with your system, but I will point out that as time goes on, ascii/stretch and ceres/sid will grow farther apart. You're really mixing stable with unstable, not testing and stable.

Offline

#9 2017-12-29 17:31:42

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

I can supply the error list for trying to install openrc
Unless there is something drastically different between tor repos and pkgmaster (we are told they have been the same from even before the pkgmaster announcement) openrc is not installable in ascii (as per the pre-beta installation).
I followed the instructions that are on your repository /openrc and all checked out OK till the openrc installation.  Too many missing dependencies.
So, I backed it up as it was, fearing a mess, and then switched/added ceres just for the openrc dependencies.
It went fine and told me to use an immidiate reboot/termination command if I was to remove sysv-rc and replace it with openrc.  So, I did!
I even went back and redid a slightly different way to see the difference.  No problems.
For a split second I see the Green/violet signs, then one more violet/green further down, and voila!  I got ascii with OpenRC "from refracta-scratch".

Then I installed it in a stick to make a portable installation and then I made a mistake, I installed vdev to see what's up with that.  I got sleepy so I started clean today.
The system collapsed, it would only give me an intiramfs prompth, or kernel panic.  I almost forgot what I did last so it took me a while to notice the vdev error.  Chrooted into it, removed vdev and it returned to normality.

I guess I shouldn't be messing with things I do not know (vdev).

I understand this problem between stretch-sid/ascii-ceres with no buster in between, but I have gotten comfortable in breaking and unbreaking debians over the years.



The puzzle of the uninstallable openrc remains.

Offline

#10 2017-12-29 18:09:27

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

Oh, I also got linux-4.14 while I was at it.
Works like a Dodge Dart!

Offline

#11 2017-12-30 02:32:35

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

Re: New Refracta Isos

I tried to reproduce your errors, but I didn't run into any problems.

Installed refracta9_nox_amd64 in virtualbox.
Added xorg, openbox and a few other things.
Installed openrc and rebooted with the special command.
Got the ascii versions: 0.23-1+b1  (not a surprise - I only have ascii repos enabled.)

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libcurses-perl libcurses-ui-perl libterm-readkey-perl
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libeinfo1 librc1
Suggested packages:
  policycoreutils
The following packages will be REMOVED:
  sysv-rc sysv-rc-conf
The following NEW packages will be installed:
  libeinfo1 librc1 openrc
0 upgraded, 3 newly installed, 2 to remove and 0 not upgraded.
Need to get 174 kB of archives.
After this operation, 1,394 kB of additional disk space will be used.
Do you want to continue? [Y/n] 

<snip>

 [ ok ]
**********************************************************************
*** WARNING: if you are replacing sysv-rc by OpenRC, then you must ***
*** reboot immediately using the following command:                ***
for file in /etc/rc0.d/K*; do s=`basename $(readlink "$file")` ; /etc/init.d/$s stop; done
**********************************************************************

And it reboots.

Offline

#12 2017-12-30 07:03:31

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

Then the only explanation is that the ****.onion address repos are not what they seem to be, not equivalent to pkgmaster.

Offline

#13 2017-12-30 19:19:54

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

Re: New Refracta Isos

Something else must be going on for you. I used the onion address posted on devuan.org main page and just changed jessie to ascii. It worked fine here.

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libcurses-perl libcurses-ui-perl libterm-readkey-perl
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libeinfo1 librc1
Suggested packages:
  policycoreutils
The following packages will be REMOVED:
  sysv-rc sysv-rc-conf
The following NEW packages will be installed:
  libeinfo1 librc1 openrc
0 upgraded, 3 newly installed, 2 to remove and 0 not upgraded.
Need to get 174 kB of archives.
After this operation, 1394 kB of additional disk space will be used.
Do you want to continue? [Y/n] Get:1 tor+http://devuanfwojg73k6r.onion/merged ascii/main amd64 libeinfo1 amd64 0.23-1+b1 [15.7 kB]
Get:2 tor+http://devuanfwojg73k6r.onion/merged ascii/main amd64 librc1 amd64 0.23-1+b1 [33.2 kB]
Get:3 tor+http://devuanfwojg73k6r.onion/merged ascii/main amd64 openrc amd64 0.23-1+b1 [126 kB]
ii  openrc                   0.23-1+b1         amd64

Offline

#14 2017-12-30 21:08:34

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

I am open to suggestions.
Although everything seems to be running fine as is, but what is causing this I don't know.
During the time of the upgrade/switch repos were running extremely slow, not due to bad connection as everything else was fast.  Could it be a temporary outage of part of the repository?  ceres seemed to work faster, is it is on a separate server?
If 2-3 pkgs were temporarily not available it could cause a chain effect of a status where things were not installable.  ?? 

experimental was left open but I don't think this could cause such a condition.
How about updates proposed and proposed updates?

Also, I am looking through with synaptic at the local list, for things installed from ceres that should not appear as having current equivalents, as locally installed, and can't find any today.
There should be a bunch that came from ceres that either don't exist or have an earlier version #.
I can't find one!

In a day or two I will go to a different machine and pretty much repeat the process and see what it does there.

Offline

#15 2017-12-30 21:36:46

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

Re: New Refracta Isos

I don't know the answers to most of your questions. I do know that there are some packages in ceres that are behind versions in ascii and even jessie.

Experimental should not interfere - you must use '-t experimental' to get anything from there. I'm not sure what ascii-proposed will do, but I think it works like experimental, and  I know it contains some new versions of packages that need to be tested before they move into the main repo.

With ceres, it's possible to try to install something at the wrong time, and deps are not available. That is usually cured by waiting a little while and doing another update. The package manager generally does a good job of warning you before letting you do something bad, and the warnings get noticeably longer in proportion to the damage you could do. (to the point of making you type a couple lines of text just to say "yes".)

Oh yeah, almost forgot this. Get the newer installer. More info on the first post of this thread.
https://sourceforge.net/projects/refrac … .3_all.deb

Offline

#16 2017-12-30 23:18:52

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 490
Website

Re: New Refracta Isos

Thanks for the refractainstaller and all the good work you do.

Offline

#17 2018-03-09 04:43:41

stanz
Member
From: Northern Earth ~~ Brrrr
Registered: 2018-01-14
Posts: 52

Re: New Refracta Isos

I to...would like to Thank You... smile


His Laptop - Acer Aspire E5-521, amd64 Multi-boot: Miyo-XTRA Ascii - Vuu-do latest - StanzSec testing.
Her Laptop - Toshiba - Miyo-XTRA Ascii
All the other pc's - muuhahahaha... tongue

Offline

#18 2018-03-16 15:41:56

fsmithred
Administrator
Registered: 2016-11-25
Posts: 665

Re: New Refracta Isos

I'm glad you bumped up this thread. This must be the one that fungus referred to, reminding me that I said I didn't know what was going on. (I say that a lot, anyway.) So here's my post-mortem on the situation:

I recently noticed that the Refracta isos that were used in this story contained some packages from ceres, and those isos were made from a system that was installed back in June. I wish I'd realized that at the time this thread was started. I would have fixed the isos and told fungus to start over. The fact that more packages from ceres were added makes the forensics more difficult.

So, bottom line - I don't know if there was something screwed up with the repo back in June or if I screwed up. I doubt that anyone will remember what was going on back then. That was right after jessie went stable and everyone in Europe went on vacation. To anyone dissatisfied with the results of installing my ascii isos, I say that I'm sorry about any inconvenience, but please keep in mind that it's called "Testing" for a reason.

Offline

Board footer