The officially official Devuan Forum!

You are not logged in.

#1 2017-11-16 11:57:31

migf
Member
Registered: 2017-11-11
Posts: 2

[solved] CUPS failing to print

I am running CUPS in a Devuan Jessie but although it recognizes my Brother DCP-1610W laser printer it does nothing when I try to print a test page.

For using this printer I tried to get the drivers and other info from the Brother site but I found they are no longer there. So I copied them from my previous system (Debian) where they worked ok with CUPS version 1.6.

So my questions are:
1. were there any changes from version 1.6 in Debian to 1.7.5 in Devuan that make obsolete the drivers/info I am using?
1.a. if yes, is there any way of converting them so that they work with 1.7.5?
2. where can I find drivers/info for this printer compatible with 1.7.5?
3. would it be possible to have CUPS version 1.6 adapted to Devuan?

Thanks in advance for any help on this.

Details of installed CUPS:
Version: 1.7.5-12+devuan1.01
Installed-Size: 835
Maintainer: Daniel Reurich <daniel@centurion.net.nz>
Architecture: amd64

Last edited by migf (2017-12-02 12:15:03)

Offline

#2 2017-11-16 15:24:12

fsmithred
Administrator
Registered: 2016-11-25
Posts: 471

Re: [solved] CUPS failing to print

I'm sure there were changes upstream from 1.6 to 1.75 in debian. I think the only changes that devuan made to 1.75 was to remove the dependency on libsystemd0, but it may have been more involved than that. The only way to know for sure what changes were made would be to compare the source code of both packages.

One possible simple solution is to try one of the generic drivers. I think you'll find them at the end of the list of drivers when you're adding a printer in the cups admin. (http://localhost:631)

Right now, all the devs are focused on ascii, so getting changes/fixes in jessie or doing anything with wheezy packages is unlikely to happen. There may be a way to get your printer working by editing some cups config files, but I don't know my way around that enough to even give you a hint.

Offline

#3 2017-11-17 16:29:30

migf
Member
Registered: 2017-11-11
Posts: 2

Re: [solved] CUPS failing to print

Solved

Thanks for your answer: your suggestion of using a generic driver solved the problem.

I thought all the listed drivers were for other models and would not work, but the following one did the job:

Brother DCP-1200 Foomatic/hl1250 (recommended)

Thanks again!

Offline

Board footer