The officially official Devuan Forum!

You are not logged in.

#1 2017-08-15 04:21:15

D310S
Member
Registered: 2017-08-14
Posts: 3

Connecting to a BBB using SSH SOLVED

Objective: SSH into a beaglebone black that is connected via USB
Problem: SSH command hangs indefinitely
ssh root@192.168.7.2

Neither ifconfig or lsusb show the BBB at all, although it is identified in the syslog when connected. I know this works on the same machine using debian, but not devuan. This is probably a simple fix but I cannot find the answer.
Here is the relevant part of my syslog:

Aug 14 23:15:53 X200 kernel: [692860.116092] usb 6-2: new high-speed USB device number 50 using ehci-pci
Aug 14 23:15:54 X200 kernel: [692860.254116] usb 6-2: New USB device found, idVendor=1d6b, idProduct=0104
Aug 14 23:15:54 X200 kernel: [692860.254128] usb 6-2: New USB device strings: Mfr=2, Product=3, SerialNumber=4
Aug 14 23:15:54 X200 kernel: [692860.254136] usb 6-2: Product: BeagleBoneBlack
Aug 14 23:15:54 X200 kernel: [692860.254142] usb 6-2: Manufacturer: Circuitco
Aug 14 23:15:54 X200 kernel: [692860.254147] usb 6-2: SerialNumber: C0-5114BBBK13F0
Aug 14 23:15:54 X200 kernel: [692860.257433] rndis_host 6-2:1.0 eth0: register 'rndis_host' at usb-0000:00:1d.7-2, RNDIS device, 6c:ec:eb:5c:32:9c
Aug 14 23:15:54 X200 kernel: [692860.258012] cdc_acm 6-2:1.2: This device cannot do calls on its own. It is not a modem.
Aug 14 23:15:54 X200 kernel: [692860.258082] cdc_acm 6-2:1.2: ttyACM0: USB ACM device
Aug 14 23:15:54 X200 kernel: [692860.258916] usb-storage 6-2:1.4: USB Mass Storage device detected
Aug 14 23:15:54 X200 kernel: [692860.259129] scsi26 : usb-storage 6-2:1.4
Aug 14 23:15:54 X200 mtp-probe: checking bus 6, device 50: "/sys/devices/pci0000:00/0000:00:1d.7/usb6/6-2"
Aug 14 23:15:54 X200 mtp-probe: bus: 6, device: 50 was not an MTP device
Aug 14 23:15:55 X200 kernel: [692861.256918] scsi 26:0:0:0: Direct-Access     Linux    File-CD Gadget   0308 PQ: 0 ANSI: 2
Aug 14 23:15:55 X200 kernel: [692861.257836] sd 26:0:0:0: Attached scsi generic sg1 type 0
Aug 14 23:15:55 X200 kernel: [692861.261507] sd 26:0:0:0: [sdb] 196608 512-byte logical blocks: (100 MB/96.0 MiB)
Aug 14 23:15:55 X200 kernel: [692861.262824] sd 26:0:0:0: [sdb] Write Protect is off
Aug 14 23:15:55 X200 kernel: [692861.262830] sd 26:0:0:0: [sdb] Mode Sense: 0f 00 00 00
Aug 14 23:15:55 X200 kernel: [692861.263906] sd 26:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 14 23:15:55 X200 kernel: [692861.268997]  sdb:
Aug 14 23:15:55 X200 kernel: [692861.272240] sd 26:0:0:0: [sdb] Attached SCSI removable disk

I'm not sure what other information is relevant, but ask and you shall receive. Any help is appreciated.

Last edited by D310S (2017-08-31 19:35:16)

Offline

#2 2017-08-15 09:44:10

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 115

Re: Connecting to a BBB using SSH SOLVED

According to the hopefully relevant web page, here, you need to add a udev rule, which they provide a script for. That script however seems to concern a different idVendor:idProduct device from yours, and it would therefore not be immediately applicable.

However, since the script merely creates a new file to the udev configurations, /etc/udev/rules.d/73-beaglebone.rules, it is safe to try it, but first edit the script: replace the two occurrences of 0403 with your idVendor code, 1d6b, and the two occurrences of a6d0 with your idProduct code, 0104, before running the script (as root).

If it's helpful, it's all good, and if not, you can just remove the file.

Offline

#3 2017-08-16 18:55:29

D310S
Member
Registered: 2017-08-14
Posts: 3

Re: Connecting to a BBB using SSH SOLVED

ralph.ronnquist,
I did try both the original unaltered script and the one you described, but neither has changed the situation at all, as far as I can tell. Thank you for the suggestion.

Offline

#4 2017-08-31 19:35:03

D310S
Member
Registered: 2017-08-14
Posts: 3

Re: Connecting to a BBB using SSH SOLVED

I haven't done any looking into the actual cause or solution to this issue, but installing gnome-session and its dependencies resolves it. I am marking the thread solved.

Offline

Board footer