The officially official Devuan Forum!

You are not logged in.

#1 2023-12-08 19:38:01

mclien
Member
Registered: 2020-02-29
Posts: 92  

testing daedalus on cubox (I4P-300-D)

So I just found my old cubox and decided to give it a try.
I got images from

https://pkgmaster.devuan.org/devuan/dists/<release>/main/installer-armhf/current/images/netboot/SD-card-images/

And put it together and on an sd-card:

zcat firmware.MX6_Cubox-i.img.gz partition.img.gz > complete_daedalus_cubox.img
cat complete_daedalus_cubox.img > /dev/<sd-card-device>

Then I connected to the micro USB port of the cubox (which delivers output as serial device) and connected to that with screen:

screen /dev/ttyUSB0 115200

With sd-card in the cubox and also connected:
-HDMI
-USB (keyboard, mouse
-Ethernet (RJ45)

Did the complete install on the serial console (incl. full disc encryption)

The reboot to finish installation doesn't work (because arm doesn't seem to have an power of mode.

1st boot (whichis just power up the device) didn't went well, I got stuck at:

"hit any key to abort autostart: 0
=>

on the HDMI screen.

So I did a 2nd boot with the serial console attached like in the install setup, which gave me the passphrase question on the serial console.

It is running at the moment with 2 drawbacks:
No output at HDMI

Updating fails (logged in via ssh):

root@cubox:~# apt-get update
Ign:1 http://deb.devuan.org/merged daedalus InRelease
Hit:2 http://deb.devuan.org/merged daedalus-security InRelease
Get:3 http://deb.devuan.org/merged daedalus-updates InRelease [32.5 kB]
Hit:1 http://deb.devuan.org/merged daedalus InRelease
Reading package lists... Done
E: Release file for http://deb.devuan.org/merged/dists/daedalus-security/InRelease is not valid yet (invalid for another 19698d 11h 36min 13s). Updates for this repository will not be applied.
E: Release file for http://deb.devuan.org/merged/dists/daedalus-updates/InRelease is not valid yet (invalid for another 19699d 14h 36min 36s). Updates for this repository will not be applied.
E: Release file for http://deb.devuan.org/merged/dists/daedalus/InRelease is not valid yet (invalid for another 19694d 3h 11min 36s). Updates for this repository will not be applied.

So nice to have the base install done, but how do I proceed from here?

EDIT: I guess I need to user other repos?

Last edited by mclien (2023-12-08 19:49:29)

Offline

#2 2023-12-08 20:22:01

golinux
Administrator
Registered: 2016-11-25
Posts: 3,191  

Re: testing daedalus on cubox (I4P-300-D)

Maybe have a look at: https://www.devuan.org/os/packages

Offline

#3 2023-12-08 20:38:26

mclien
Member
Registered: 2020-02-29
Posts: 92  

Re: testing daedalus on cubox (I4P-300-D)

Sorry, I don't get the point. I didn't change anything after the install. Shouldn't the sources.list work after installation?
Those must be the ones used during install after all.
EDIT: Or do I simply ignore that the release file is not valid? (Yeah me stupid, it is working. I was just confused about the errors).

Starting installs now.

EDIT2: ok, works fine so far. rsync install for testing.
I'm now cloning the sd-card so I can always start over with the minimal install.

Last edited by mclien (2023-12-08 21:02:52)

Offline

#4 2023-12-09 10:59:01

mclien
Member
Registered: 2020-02-29
Posts: 92  

Re: testing daedalus on cubox (I4P-300-D)

My cubox is now running with fluxbox. Fluxbox with 1 bash window is using 170MB RAM of 2GB. That is quite nice, here are some things I haven't managed to fix so far.
- boot messages are still on the serial console only (so I have unlock the encrypted disc there)
-- how do I get the boot messages on the HDMI and serial?
- the windowmanager has a bit of a lag with mouse movements (IIRC I had an installation of armbian a few years back  which was running more smoothly)
-- some packages I need to install for the graphic? (drivers/xorg package?)
- keyboard layout is still at US (the installer seems not to give the choice here or it is somehow eaten by the bit strange resolution of the serial connect via screen).
-- is that something to be fixed with dpkg-reconfigure somehow?

So the overall test for that arm build works quite nice

Offline

Board footer