The officially official Devuan Forum!

You are not logged in.

#1 2020-05-08 21:58:26

VL44K6F0
Member
Registered: 2020-03-29
Posts: 5  

xdotool is the work of satan

trying to be as minimal as possible...

debootstrap install (per instructions somewhere here)

openbox
x11-apps
x11-xserver-utils
xdotool
xinit
xserver-common
xserver-xorg-core
xserver-xorg-input-evdev
xserver-xorg-input-kbd
xserver-xorg-input-mouse
xserver-xorg-input-void
xserver-xorg-video-radeon
xterm

and here i am witnessing the evil works of satan and pure evil:
bitmap from x11-apps won't let edit anything. it is not perfect, but usually does its job. not this time with xdotool.

xdotool, when installed on the host affects even that same bitmap program in virtualbox (latest beowulf live for example. also debian live isos from v4 to date)

trying to find out the issue i installed something i remembered from the beowulf live iso - something xf... was if xfce4 or xfwm4, who knows, anyway got that xf-something interface like in live-iso and bitmap worked (with xdotool installed on host and xf..thing and everything on host). unfortunately this xf.. thing is broken (or something else) - purging removed apt and keys and everything - broken system in other words. dont want to do it anymore. anyway there seems to be something that xf.. brings in that fixes the issue...

without xdotool on the host, in virtualbox everything, especially bitmap works flawlessly, no matter if xdotool is installed on guest or not.

does it make any sense?

Offline

Board footer