The officially official Devuan Forum!

You are not logged in.

#1 2017-03-06 11:20:23

Vi
d1g
Registered: 2017-03-06
Posts: 0

Sound volume turns, and stays mute

Hello! It is my first time here, so please be patient.

I tested Devuan beta 2, both 32 and 64 bit systems. I installed the suggested option GUI.


----
There is a bug in sound volume. When I turn down the volume all the way to mute, I can not turn it back on. It stays muted. I have to fiddle around sound settings to get the sound back on.
----


Devuan is very, very fun and robust to work.  Even I have succeeded in getting everyting to work!

A big thank you to all you developers!!!!

yours -Vi-

________________________________________

Project: devuan/devuan-project
Issue: #98
By: Vi

Offline

#2 2017-03-17 18:48:22

golinux
Administrator
Registered: 2016-11-25
Posts: 552

Re: Sound volume turns, and stays mute

More information needed.  pulseaudio, alsa, jack etc.?  How are you muting etc. ?  Sometimes after suspend sound disappears on audacity and avidemux (which are open most of the time) and I have to open a track with VLC to wake it up.

Online

#3 2017-05-09 22:48:34

treebeard
Member
Registered: 2017-05-09
Posts: 5

Re: Sound volume turns, and stays mute

I had the same problem with a HDA Intel sound card with ALSA Mixer. I am using Devuan RC2 and have not made any system alterations relating to sound. All attempts to un-mute using the audio mixer had no effect even through the audio mixer showed everything updating correctly.

I 'accidentally' muted, probably by clicking the mute button next to my keyboard (Acer laptop).

It may be a longstanding Debian or XFCE bug as there are lots of comments on-line about un-muting problems in both.

My sound started working again after I followed some advice on a Debian forum and ran:
$ amixer set Master unmute

Hope that helps.

Last edited by treebeard (2017-05-09 22:58:27)

Offline

#4 2017-05-09 23:48:08

golinux
Administrator
Registered: 2016-11-25
Posts: 552

Re: Sound volume turns, and stays mute

Welcome to the forum treebeard!  And thanks for your input.  Many of these git issues (important ones at least) have been moved to our new bug tracking system at https://bugs.devuan.org.  I searched and see it here.  It would be helpful if you could post your response there too.  I have never done that but there are clear instructions how to do so on the site.

Online

#5 2017-05-10 00:11:30

treebeard
Member
Registered: 2017-05-09
Posts: 5

Re: Sound volume turns, and stays mute

OK will do.

Just installed Devuan a few days ago after following the progress for three years. Really enjoying Devuan. Well done to everyone who worked so hard to get to this point. The quality is excellent and it is MUCH more responsive than Debian on the same hardware. Looking forward to helping out with other issues where I can.

Offline

#6 2017-05-10 00:39:08

golinux
Administrator
Registered: 2016-11-25
Posts: 552

Re: Sound volume turns, and stays mute

WOW!  That was fast!!  Thanks.

Online

#7 2017-05-24 20:44:00

MiyoLinux
Member
Registered: 2016-12-05
Posts: 207

Re: Sound volume turns, and stays mute

Thanks for all of the suggestions. I've tried several things, but I was still having problems with it muting the sound between speakers and headphones...

So, I took the easy way out (for me) and installed volumeicon-alsa. Added it to Application autostart. Problem solved for my taste. It can lower the volume completely down until it mutes, and it raises the volume back up.

The trade-off was that it added a little RAM usage, but not enough to matter (for me).


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#8 2017-05-24 21:55:02

greenjeans
Member
Registered: 2017-04-07
Posts: 282
Website

Re: Sound volume turns, and stays mute

MiyoLinux wrote:

Thanks for all of the suggestions. I've tried several things, but I was still having problems with it muting the sound between speakers and headphones...

So, I took the easy way out (for me) and installed volumeicon-alsa. Added it to Application autostart. Problem solved for my taste. It can lower the volume completely down until it mutes, and it raises the volume back up.

The trade-off was that it added a little RAM usage, but not enough to matter (for me).

Funny how the basic stuff you find in openbox continues to always work, and be available as well for a solution when more complex systems break down. wink

I'm using Obsession in mate, custom keyboard shortcuts for shutdown etc (including suspend and hibernation which mate otherwise does not seem to support in it's own shutdown menu or power-manager). Works stunningly well.


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Refracta and Miyolinux had too many tequila shots one night...    ....9 months later a vuu-do chile was born.....;-)

Offline

#9 2017-05-25 01:27:28

MiyoLinux
Member
Registered: 2016-12-05
Posts: 207

Re: Sound volume turns, and stays mute

greenjeans wrote:

Funny how the basic stuff you find in openbox continues to always work, and be available as well for a solution when more complex systems break down. wink

I'm using Obsession in mate, custom keyboard shortcuts for shutdown etc (including suspend and hibernation which mate otherwise does not seem to support in it's own shutdown menu or power-manager). Works stunningly well.

Indeed! It's just hard for me to move away from Openbox! big_smile

I do need to clarify a couple of things regarding the use of volumeicon-alsa in Xfce...

1. It places the volume icon in the system tray; therefore, the icon is a little smaller than the normal volume icon. I went into panel preferences and adjusted the size of the tray icons so that it would be a little larger.

2. If you accidentally double-click the icon, it will mute the volume. Then you have to open the mixer to unmute it. So don't double-click the icon! LOL! wink

Here's a screenshot of the entire panel...kind of hard to see, but hopefully it's enough to show the volume icon size (after I adjusted the system tray icon's size) in comparison to the others in the panel...

volumeicon

Last edited by MiyoLinux (2017-05-25 01:41:17)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#10 2017-05-25 11:59:10

smoki
Member
Registered: 2017-05-15
Posts: 56

Re: Sound volume turns, and stays mute

MiyoLinux wrote:

2. If you accidentally double-click the icon, it will mute the volume. Then you have to open the mixer to unmute it. So don't double-click the icon! LOL! wink

One liner fix i think, should prevent doubleclick mute.

Index: volumeicon-0.4.6/src/volumeicon.c
===================================================================
--- volumeicon-0.4.6.orig/src/volumeicon.c
+++ volumeicon-0.4.6/src/volumeicon.c
@@ -570,7 +570,7 @@ static void status_icon_on_button_releas
 		gtk_window_present_with_time(GTK_WINDOW(m_scale_window), event->time);
 		g_timeout_add(TIMER_INTERVAL, scale_timeout, NULL);
 	}
-	else if(event->button == 1 ||
+	else if((event->button == 1 && !config_get_left_mouse_slider()) ||
 		(event->button == 2 && config_get_middle_mouse_mute()))
 	{
 		m_mute = !m_mute;

Offline

#11 2017-05-25 13:44:24

Oldmoss
Member
Registered: 2016-12-08
Posts: 6

Re: Sound volume turns, and stays mute

treebeard wrote:

My sound started working again after I followed some advice on a Debian forum and ran:
$ amixer set Master unmute

Hope that helps.

And I have sound again!
Thanks!

Offline

#12 2017-05-25 14:57:32

smoki
Member
Registered: 2017-05-15
Posts: 56

Re: Sound volume turns, and stays mute

MiyoLinux wrote:

So, I took the easy way out (for me) and installed volumeicon-alsa. Added it to Application autostart. Problem solved for my taste. It can lower the volume completely down until it mutes, and it raises the volume back up.

The trade-off was that it added a little RAM usage, but not enough to matter (for me).

Mute/Unmute toggle

amixer -q set Master toggle

Volume Up

amixer -q set Master 1+ unmute 

Volume Down

amixer -q set Master 1- unmute 

Make a keybinds of choice to run these in openbox rc.xml and that is it - no dependencies.

Last edited by smoki (2017-05-25 14:59:00)

Offline

#13 2017-05-25 15:53:24

MiyoLinux
Member
Registered: 2016-12-05
Posts: 207

Re: Sound volume turns, and stays mute

smoki wrote:
MiyoLinux wrote:

So, I took the easy way out (for me) and installed volumeicon-alsa. Added it to Application autostart. Problem solved for my taste. It can lower the volume completely down until it mutes, and it raises the volume back up.

The trade-off was that it added a little RAM usage, but not enough to matter (for me).

Mute/Unmute toggle

amixer -q set Master toggle

Volume Up

amixer -q set Master 1+ unmute 

Volume Down

amixer -q set Master 1- unmute 

Make a keybinds of choice to run these in openbox rc.xml and that is it - no dependencies.

Thanks for all of your help and input smoki; it's much appreciated! smile


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

Board footer