The officially official Devuan Forum!

You are not logged in.

#1 2017-03-27 21:07:12

OmegaPhil
d1g
Registered: 2017-03-06
Posts: 0

dbus on ascii is out of date, blocking dbus-user-session upgrade

Currently, doing a full-upgrade on ascii fails due to the following:

```
dbus-user-session depends upon dbus (>= 1.10.16-1)
```

dbus is currently on 1.10.8-1+devuan1, it looks like there is a Devuan update due with [this pull request](https://git.devuan.org/devuan-packages/dbus/merge_requests/1), although even then that is done dbus will still be 2 point releases out.

Please can dbus be upgraded etc? Since Ben is handling it, doesn't look like it needs me poking around (and potentially breaking stuff).

________________________________________

Project: devuan-packages/dbus
Issue: #31
By: OmegaPhil

Offline

#2 2017-05-16 12:46:36

sgage
Member
Registered: 2016-12-01
Posts: 17

Re: dbus on ascii is out of date, blocking dbus-user-session upgrade

This issue also prevents the updating of gconf2, which prevents the installation of several other packages.

OmegaPhil wrote:

Currently, doing a full-upgrade on ascii fails due to the following:

```
dbus-user-session depends upon dbus (>= 1.10.16-1)
```

dbus is currently on 1.10.8-1+devuan1, it looks like there is a Devuan update due with [this pull request](https://git.devuan.org/devuan-packages/ … requests/1), although even then that is done dbus will still be 2 point releases out.

Please can dbus be upgraded etc? Since Ben is handling it, doesn't look like it needs me poking around (and potentially breaking stuff).

________________________________________

Project: devuan-packages/dbus
Issue: #31
By: OmegaPhil

Offline

#3 2017-05-17 01:11:15

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: dbus on ascii is out of date, blocking dbus-user-session upgrade

I got this message on an attempted upgrade from jessie to ascii:

 dbus-user-session : Depends: dbus (>= 1.10.18-1) but 1.10.8-1+devuan1 is to be installed.
                     Depends: systemd which is a virtual package.
                     Breaks: policykit-1 (< 0.105-12~) but 0.105-9+devuan1 is installed.

I got around it by making a dummy dbus-user-session package with equivs. I'm pretty sure this problem is already on the todo list for ascii.

Offline

Board footer