The officially official Devuan Forum!

You are not logged in.

#1 2017-07-10 14:41:10

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

OpenRC installation in Devuan Ascii

title: OpenRC installation in Devuan Ascii
---
I'm preparing to try and install OpenRC.
Some references I found by searching Dev1Galaxy:
Open RC (issue, still open)
https://dev1galaxy.org/viewtopic.php?id=178

https://git.devuan.org/devuan-packages/openrc
---
There's some more info, maybe more up to date in recent threads on Devuan DNG ML:
I have a question about libsystemd0 in devuan ascii, ( bad subject, see below)
https://lists.dyne.org/lurker/message/2 … 65.en.html

[Bad subject] that one is of course, but you change the subject, the thread is lost for your new email in Lurker sad , so you better leave the title alone, often...

But that email of mine, if you look up the whole thread:
https://lists.dyne.org/lurker/thread/20 … 4.d61f1165

you see that the link above is a reply to this close to a month old email of our developer Svante Signell:
( same bad title )
https://lists.dyne.org/lurker/message/2 … 27.en.html

However, I think most is almost or actually ready for close to a comfortable install of OpenRC, in Ascii....

In the next post.

Last edited by miroR (2017-07-10 14:54:15)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#2 2017-07-10 14:53:36

Dev1
Member
Registered: 2016-12-25
Posts: 16

Re: OpenRC installation in Devuan Ascii

Stop dreamin !

Offline

#3 2017-07-10 14:56:09

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

Dev1 wrote:

Stop dreamin !

What do you mean?

The below is gotten with:
# apt-get source util-linux

Reading package lists...
GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.dsc
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Mon, 10 Jul 2017 14:30:11 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc

GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2.orig.tar.xz HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Mon, 10 Jul 2017 14:30:11 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz

Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Mon, 10 Jul 2017 14:30:11 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz

GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc
HTTP/1.1 302 Found
Date: Mon, 10 Jul 2017 14:30:12 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc
Content-Length: 340
Content-Type: text/html; charset=iso-8859-1

GET /debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
HTTP/1.1 302 Found
Date: Mon, 10 Jul 2017 14:30:12 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
Content-Length: 346
Content-Type: text/html; charset=iso-8859-1

Answer for: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
HTTP/1.1 302 Found
Date: Mon, 10 Jul 2017 14:30:12 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
Content-Length: 350
Content-Type: text/html; charset=iso-8859-1

GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Wed, 22 Mar 2017 13:55:17 GMT
ETag: "f4e-54b521c435bcb"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Via: 1.1 varnish
Fastly-Debug-Digest: e888ade858fe9d2cc258b97c590dc19af4d2a774b28a378c9845a6a77de0b42e
Content-Length: 3918
Accept-Ranges: bytes
Date: Mon, 10 Jul 2017 14:30:13 GMT
Via: 1.1 varnish
Age: 1990976
Connection: keep-alive
X-Served-By: cache-ams4141-AMS, cache-hhn1528-HHN
X-Cache: HIT, HIT
X-Cache-Hits: 1, 1
X-Timer: S1499697013.422834,VS0,VE1

NOTICE: 'util-linux' packaging is maintained in the 'Git' version control system at:
git://anonscm.debian.org/collab-maint/pkg-util-linux.git
Please use:
git clone git://anonscm.debian.org/collab-maint/pkg-util-linux.git
to retrieve the latest (possibly unreleased) updates to the package.
Need to get 4,355 kB of source archives.
Get:1 http://packages.devuan.org/merged ascii/main util-linux 2.29.2-1 (dsc) [3,918 B]
GET /debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Wed, 22 Mar 2017 13:55:17 GMT
ETag: "4145a4-54b521c437b0a"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-xz
Via: 1.1 varnish
Fastly-Debug-Digest: e14601eb736a45d9acf595223fd411d071cb1de118a59a2c74b260d60794be71
Content-Length: 4277668
Accept-Ranges: bytes
Date: Mon, 10 Jul 2017 14:30:13 GMT
Via: 1.1 varnish
Age: 321335
Connection: keep-alive
X-Served-By: cache-ams4120-AMS, cache-hhn1528-HHN
X-Cache: HIT, MISS
X-Cache-Hits: 1, 0
X-Timer: S1499697013.447702,VS0,VE26

Get:2 http://packages.devuan.org/merged ascii/main util-linux 2.29.2-1 (tar) [4,278 kB]
Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Wed, 22 Mar 2017 13:55:17 GMT
ETag: "11fc0-54b521c437b0a"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-xz
Via: 1.1 varnish
Fastly-Debug-Digest: 6235b140b7c37d9baa9dc0171d63655b9aa39571405fb12cee03140f0857abbd
Content-Length: 73664
Accept-Ranges: bytes
Date: Mon, 10 Jul 2017 14:30:14 GMT
Via: 1.1 varnish
Age: 457962
Connection: keep-alive
X-Served-By: cache-ams4126-AMS, cache-hhn1528-HHN
X-Cache: HIT, HIT
X-Cache-Hits: 2, 1
X-Timer: S1499697014.174335,VS0,VE2

Get:3 http://packages.devuan.org/merged ascii/main util-linux 2.29.2-1 (diff) [73.7 kB]
dpkg-source: info: extracting util-linux in util-linux-2.29.2
dpkg-source: info: unpacking util-linux_2.29.2.orig.tar.xz
dpkg-source: info: unpacking util-linux_2.29.2-1.debian.tar.xz
dpkg-source: info: applying Multiarch-support-in-util-linux-build.patch
dpkg-source: info: applying man-page-tweaks-cleanup-my_dev_t.h-ancient-stuff.patch
dpkg-source: info: applying Disable-the-fallback-clause-in-hwclock-when-dev-rtc-.patch
dpkg-source: info: applying verbose-tests.patch
Fetched 4,355 kB in 3s (1,127 kB/s)
W: Download is performed unsandboxed as root as file 'util-linux_2.29.2-1.dsc' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

#
I only don't understand the last message (in bottom of the above paste):

W: Download is performed unsandboxed as root as file 'util-linux_2.29.2-1.dsc' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

...because I got:
$ ls -ltr util-linux_2.29.2-1.dsc

-rw-r--r-- 1 root root 3918 2017-03-22 13:55 util-linux_2.29.2-1.dsc

$
$ cat util-linux_2.29.2-1.dsc

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 3.0 (quilt)
Source: util-linux
Binary: util-linux, util-linux-locales, mount, bsdutils, fdisk-udeb, libblkid1, libblkid1-udeb, libblkid-dev, libfdisk1, libfdisk1-udeb, libfdisk-dev, libmount1, libmount1-udeb, libmount-dev, libsmartcols1, libsmartcols1-udeb, libsmartcols-dev, libuuid1, uuid-runtime, libuuid1-udeb, uuid-dev, util-linux-udeb, setpriv
Architecture: any all
Version: 2.29.2-1
Maintainer: Debian util-linux Maintainers <ah-util-linux@debian.org>
Uploaders: LaMont Jones <lamont@debian.org>, Andreas Henriksson <andreas@fatal.se>, Adam Conrad <adconrad@0c3.net>
Standards-Version: 3.9.8
Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/pkg-util-linux.git/
Vcs-Git: git://anonscm.debian.org/collab-maint/pkg-util-linux.git
Testsuite: autopkgtest
Testsuite-Triggers: bash, bc, bsdmainutils, dpkg, grep
Build-Depends: debhelper (>= 10), dh-exec (>= 0.13), dpkg-dev (>= 1.17.14), gettext, libcap-ng-dev [linux-any] <!stage1>, libncurses5-dev, libncursesw5-dev, libpam0g-dev <!stage1>, libselinux1-dev (>= 2.6-3~) [linux-any], libsystemd-dev [linux-any] <!stage1>, libtool, libudev-dev [linux-any] <!stage1>, pkg-config, po-debconf, systemd [linux-any] <!stage1>, zlib1g-dev
Package-List:
 bsdutils deb utils required arch=any profile=!stage1 essential=yes
 fdisk-udeb udeb debian-installer extra arch=hurd-any,linux-any profile=!stage1
 libblkid-dev deb libdevel optional arch=any
 libblkid1 deb libs required arch=any
 libblkid1-udeb udeb debian-installer optional arch=any
 libfdisk-dev deb libdevel optional arch=any
 libfdisk1 deb libs required arch=any
 libfdisk1-udeb udeb debian-installer optional arch=any
 libmount-dev deb libdevel optional arch=linux-any
 libmount1 deb libs required arch=any
 libmount1-udeb udeb debian-installer optional arch=linux-any
 libsmartcols-dev deb libdevel optional arch=any
 libsmartcols1 deb libs required arch=any
 libsmartcols1-udeb udeb debian-installer optional arch=any
 libuuid1 deb libs required arch=any
 libuuid1-udeb udeb debian-installer optional arch=any
 mount deb admin required arch=linux-any profile=!stage1 essential=yes
 setpriv deb admin optional arch=linux-any profile=!stage1
 util-linux deb utils required arch=any profile=!stage1 essential=yes
 util-linux-locales deb localization optional arch=all profile=!stage1
 util-linux-udeb udeb debian-installer optional arch=any profile=!stage1
 uuid-dev deb libdevel optional arch=any
 uuid-runtime deb utils optional arch=any profile=!stage1
Checksums-Sha1:
 b488f185e74187a63b55baef9d3f48d5b1780118 4277668 util-linux_2.29.2.orig.tar.xz
 4c8fd1efa813563e72020c4a2388ca7188186a67 73664 util-linux_2.29.2-1.debian.tar.xz
Checksums-Sha256:
 accea4d678209f97f634f40a93b7e9fcad5915d1f4749f6c47bee6bf110fe8e3 4277668 util-linux_2.29.2.orig.tar.xz
 820511a8c7c03c7b62218c03f57e4a33e5e928a2cb7d9cda58b9c07aade7744b 73664 util-linux_2.29.2-1.debian.tar.xz
Files:
 63c40c2068fcbb7e1d5c1d281115d973 4277668 util-linux_2.29.2.orig.tar.xz
 7c6d588a0279988af41e999a9e0ab220 73664 util-linux_2.29.2-1.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEE+uHltkZSvnmOJ4zCC8R9xk0TUwYFAljSfgMACgkQC8R9xk0T
UwZ5VBAAk4M6IqOk1+hEdYG1WLlg4u9dWq/CflKmBo8zYxXQOVbTuC4J1r/htcVi
3RfKoYMUt8JxEvOrRMgxl+8KbSWTTSWZz6uSTj8/5Rhjy53eeFIgIfoA5/EoASNW
MhMbDpZoHROpMr5pK2B7HCQioALeljJbC8eHMbs0Zu01CvApa6mkWCtB1Btr1iuh
UiMG7TJBOgz3gzzzJ82XQPRaf8whpX3GkfNDlipsWG9gm7OzoPuYD/Hrt+vnWKLg
fJ/wIaJ/iqza+n+ahojt8lAG4Q91k4Bd/IYLVuZ8/uPedsbyQMD+V85ECFC27XAB
+lHTi9Dolt/hP3ngw/zAnWl9JPOpeOFiMURrhtxWyzhdE8Dzxa3IAwYhWFbf9g1N
v17tmKeWOFFwHR5mw8gt5TGwMIBJ+0F6ZuX1vv5VaDXBqF7ooQaRjMvPdU0u6aEl
M4uQ83hbzv+1KG/MmRTP6nb6Ab2I9HxtHTCMHdxHQHi8BSRENtQ4cU9hP6idBA2Z
NnXhKkZNf6yS4B3lDcZnCFnaVB+6+Gzwreuz61iClQXorwBC1J5ZAhCqswd4Dhzl
RqYPHGJ3uvUreJXT5Q6NWJK56yYsW5cTimOlzQCq/m8kZkpj3se+W09fHbe4Qzzm
MXMX4uU1QzDQJzWuFzsBR1Z29/LmTON015BhtdLelLNs/kwry9w=
=cdJq
-----END PGP SIGNATURE-----

$
I mean it all downloaded...

Last edited by miroR (2017-07-10 15:13:20)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#4 2017-07-10 15:20:24

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

By the next step in Svante's mail (see above):
# apt-get build-dep util-linux

Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) builddeps:util-linux:amd64 < none -> 1 @un puN Ib >
Broken builddeps:util-linux:amd64 Depends on dh-exec:amd64 < none | 0.23+b1 @un uH > (>= 0.13)
  Considering dh-exec:amd64 0 as a solution to builddeps:util-linux:amd64 9998
  Re-Instated dh-exec:amd64
Broken builddeps:util-linux:amd64 Depends on libcap-ng-dev:amd64 < none | 0.7.7-3+b1 @un uH >
  Considering libcap-ng-dev:amd64 1 as a solution to builddeps:util-linux:amd64 9998
  Re-Instated libcap-ng-dev:amd64
Broken builddeps:util-linux:amd64 Depends on libncursesw5-dev:amd64 < none | 6.0+20161126-1 @un uH >
  Considering libncursesw5-dev:amd64 1 as a solution to builddeps:util-linux:amd64 9998
  Re-Instated libncursesw5-dev:amd64
Broken builddeps:util-linux:amd64 Depends on libpam0g-dev:amd64 < none | 1.1.8-3.6 @un uH >
  Considering libpam0g-dev:amd64 1 as a solution to builddeps:util-linux:amd64 9998
  Re-Instated libpam0g-dev:amd64
Broken builddeps:util-linux:amd64 Depends on libselinux1-dev:amd64 < none | 2.6-3+b1 @un uH > (>= 2.6-3~)
  Considering libselinux1-dev:amd64 0 as a solution to builddeps:util-linux:amd64 9998
  Re-Instated libsepol1-dev:amd64
  Re-Instated libselinux1-dev:amd64
Broken builddeps:util-linux:amd64 Depends on libsystemd-dev:amd64 < none | 232-25 @un uH >
  Considering libsystemd-dev:amd64 1 as a solution to builddeps:util-linux:amd64 9998
  Re-Instated libsystemd-dev:amd64
Broken builddeps:util-linux:amd64 Depends on systemd:amd64 < none @un H >
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:util-linux : Depends: systemd but it is not installable
E: Unable to correct problems, you have held broken packages.

#
Hmmmhhh...


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#5 2017-07-10 19:40:17

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

Well... There's another claim, and by a developer, that OpenRC is pretty much ready for installing, after the util-linux is compiled and installed, in Ascii:
I have a question about libsystemd0 in devuan ascii, (same bad title still)
https://lists.dyne.org/lurker/message/2 … c2.en.html

Adam Borowski wrote:

openrc in jessie isn't in the best shape; the one in stretch/ascii should be
fully functional though. There's an insserv warning and that scary notice
during upgrades isn't that good, but I'm not aware of any other problems.

Should be installable as soon as util-linux is rebuilt.
--
⢀⣴⠾⠻⢶⣦⠀
⣾⠁⢠⠒⠀⣿⡁ A dumb species has no way to open a tuna can.
⢿⡄⠘⠷⠚⠋⠀ A smart species invents a can opener.
⠈⠳⣄⠀⠀⠀⠀ A master species delegates.

EDIT 2017-07-12 11:40 UT START: This linuxmafia.com page links to this post, like this:

Rick Moen wrote:

But the apt-get source below is what I did following old instructions by Svante... And there is some more confusion in other posts below... So for the readers who use this topic to install OpenRC, the topic is actionable, but the util-linux package, not source, to use is, likely, because as Svante (and other devs who package it and its dependencies) say, the devuanized util-linux package.
So, gentle reader, you should first go to the:
download page first, be aware that news will likely be in the Devuan DNG ML thread linked from there, and than if necessary, read the rest of this topic.
Also, the source that I got below, and in the previous post by apt-get source is what I should file a bug about, as Svante suggested in this email of the same bad-subject thread. Should, if I manage to do it hmm .
EDIT 2017-07-12 11:49 UT END.

Now, apt-get source just downloads. And I got:
$ ls -ld util-linux*

drwxr-xr-x 25 root root    4096 2017-07-10 14:29 util-linux-2.29.2
-rw-r--r--  1 root root   73664 2017-03-22 13:55 util-linux_2.29.2-1.debian.tar.xz
-rw-r--r--  1 root root    3918 2017-03-22 13:55 util-linux_2.29.2-1.dsc
-rw-r--r--  1 root root 4277668 2017-03-22 13:55 util-linux_2.29.2.orig.tar.xz

$
that apt-get downloaded for me. Where:
$ ls -l util-linux-2.29.2/

total 2360
-rw-r--r-- 1 root root   93787 2017-02-22 12:07 ABOUT-NLS
-rw-r--r-- 1 root root   61830 2017-02-22 12:07 aclocal.m4
-rw-r--r-- 1 root root   25310 2017-02-22 11:46 AUTHORS
-rwxr-xr-x 1 root root    3153 2016-11-02 12:57 autogen.sh
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 bash-completion
-rw-r--r-- 1 root root     102 2017-02-22 12:12 ChangeLog
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 config
-rw-r--r-- 1 root root   20250 2017-02-22 12:07 config.h.in
-rwxr-xr-x 1 root root  903764 2017-02-22 12:07 configure
-rw-r--r-- 1 root root   66260 2017-07-10 14:29 configure.ac
-rw-r--r-- 1 root root   18092 2016-07-20 08:56 COPYING
drwxr-xr-x 5 root root    4096 2017-03-22 09:43 debian
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 disk-utils
drwxr-xr-x 5 root root    4096 2017-02-22 10:16 Documentation
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 include
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 lib
drwxr-xr-x 5 root root    4096 2017-07-10 14:29 libblkid
drwxr-xr-x 4 root root    4096 2017-02-22 12:12 libfdisk
drwxr-xr-x 5 root root    4096 2017-07-10 14:29 libmount
drwxr-xr-x 5 root root    4096 2017-02-22 12:12 libsmartcols
drwxr-xr-x 4 root root    4096 2017-07-10 14:29 libuuid
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 login-utils
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 m4
-rw-r--r-- 1 root root    6731 2017-07-10 14:29 Makefile.am
-rw-r--r-- 1 root root 1023790 2017-02-22 12:07 Makefile.in
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 misc-utils
-rw-r--r-- 1 root root   72054 2017-02-22 12:06 NEWS
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 po
-rw-r--r-- 1 root root    1582 2017-02-22 10:16 README
-rw-r--r-- 1 root root     555 2016-07-20 08:56 README.licensing
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 schedutils
drwxr-xr-x 2 root root    4096 2017-07-10 14:29 sys-utils
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 term-utils
drwxr-xr-x 5 root root    4096 2017-07-10 14:29 tests
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 text-utils
drwxr-xr-x 2 root root    4096 2017-02-22 12:12 tools

$
And all of it is a little wrong, because it's all owned root:root, while it should be owned mr:mr (me, the normal user).

What do I do. Can I download sources as regular user. Let me try.

$ mkdir src
$ cd src
~/src$ apt-get source util-linux

And that does look much better!

Reading package lists...
GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.dsc
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Mon, 10 Jul 2017 19:11:02 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc

GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2.orig.tar.xz HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Mon, 10 Jul 2017 19:11:02 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz

Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Mon, 10 Jul 2017 19:11:02 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz

GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc
HTTP/1.1 302 Found
Date: Mon, 10 Jul 2017 19:11:03 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc
Content-Length: 340
Content-Type: text/html; charset=iso-8859-1

GET /debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
HTTP/1.1 302 Found
Date: Mon, 10 Jul 2017 19:11:03 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
Content-Length: 346
Content-Type: text/html; charset=iso-8859-1

Answer for: http://httpredir.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
HTTP/1.1 302 Found
Date: Mon, 10 Jul 2017 19:11:03 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
Content-Length: 350
Content-Type: text/html; charset=iso-8859-1

GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.dsc
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Wed, 22 Mar 2017 13:55:17 GMT
ETag: "f4e-54b521c435bcb"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Via: 1.1 varnish
Fastly-Debug-Digest: e888ade858fe9d2cc258b97c590dc19af4d2a774b28a378c9845a6a77de0b42e
Content-Length: 3918
Accept-Ranges: bytes
Date: Mon, 10 Jul 2017 19:11:04 GMT
Via: 1.1 varnish
Age: 2007827
Connection: keep-alive
X-Served-By: cache-ams4141-AMS, cache-hhn1549-HHN
X-Cache: HIT, HIT
X-Cache-Hits: 1, 1
X-Timer: S1499713865.528879,VS0,VE0

NOTICE: 'util-linux' packaging is maintained in the 'Git' version control system at:
git://anonscm.debian.org/collab-maint/pkg-util-linux.git
Please use:
git clone git://anonscm.debian.org/collab-maint/pkg-util-linux.git
to retrieve the latest (possibly unreleased) updates to the package.
Need to get 4,355 kB of source archives.
Get:1 http://packages.devuan.org/merged ascii/main util-linux 2.29.2-1 (dsc) [3,918 B]
GET /debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2.orig.tar.xz
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Wed, 22 Mar 2017 13:55:17 GMT
ETag: "4145a4-54b521c437b0a"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-xz
Via: 1.1 varnish
Fastly-Debug-Digest: e14601eb736a45d9acf595223fd411d071cb1de118a59a2c74b260d60794be71
Content-Length: 4277668
Accept-Ranges: bytes
Date: Mon, 10 Jul 2017 19:11:04 GMT
Via: 1.1 varnish
Age: 338186
Connection: keep-alive
X-Served-By: cache-ams4120-AMS, cache-hhn1549-HHN
X-Cache: HIT, HIT
X-Cache-Hits: 1, 1
X-Timer: S1499713865.554128,VS0,VE16

Get:2 http://packages.devuan.org/merged ascii/main util-linux 2.29.2-1 (tar) [4,278 kB]
Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/u/util-linux/util-linux_2.29.2-1.debian.tar.xz
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Wed, 22 Mar 2017 13:55:17 GMT
ETag: "11fc0-54b521c437b0a"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-xz
Via: 1.1 varnish
Fastly-Debug-Digest: 6235b140b7c37d9baa9dc0171d63655b9aa39571405fb12cee03140f0857abbd
Content-Length: 73664
Accept-Ranges: bytes
Date: Mon, 10 Jul 2017 19:11:05 GMT
Via: 1.1 varnish
Age: 474813
Connection: keep-alive
X-Served-By: cache-ams4126-AMS, cache-hhn1549-HHN
X-Cache: HIT, HIT
X-Cache-Hits: 2, 1
X-Timer: S1499713865.346705,VS0,VE1

Get:3 http://packages.devuan.org/merged ascii/main util-linux 2.29.2-1 (diff) [73.7 kB]
dpkg-source: info: extracting util-linux in util-linux-2.29.2
dpkg-source: info: unpacking util-linux_2.29.2.orig.tar.xz
dpkg-source: info: unpacking util-linux_2.29.2-1.debian.tar.xz
dpkg-source: info: applying Multiarch-support-in-util-linux-build.patch
dpkg-source: info: applying man-page-tweaks-cleanup-my_dev_t.h-ancient-stuff.patch
dpkg-source: info: applying Disable-the-fallback-clause-in-hwclock-when-dev-rtc-.patch
dpkg-source: info: applying verbose-tests.patch
Fetched 4,355 kB in 3s (1,144 kB/s)

And the listing is like the above when I ran it as root where you can read "Fetched 4,355 kB in 3s (1,127 kB/s)". But this time there's no warning!

Trying to get build dependencies with:
# apt-get build-dep util-linux

... same as already posted ...

[same as] at: http://dev1galaxy.org/viewtopic.php?id=1128#p3236 .

And how could it be otherwise:

# apt-cache policy util-linux
util-linux:
  Installed: 2.28-1+devuan3
  Candidate: 2.28-1+devuan3
  Version table:
 *** 2.28-1+devuan3 500
        500 http://packages.devuan.org/merged ascii/main amd64 Packages
        500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages
        100 http://packages.devuan.org/devuan ascii-proposed/main amd64 Packages
        500 http://packages.devuan.org/devuan ascii/main amd64 Packages
        100 /var/lib/dpkg/status

So I got a chicken and egg problem. As long as 2.28-1+devuan3 version of util-linux is installed, it will be asking for systemd-dev and other packages.

Can I then try and build util-linux previous to # apt-get build-dep util-linux ?

Let me see:

~/src/util-linux-2.29.2$ dpkg-buildpackage -b |& tee ~/LOG_/dpkg-buildpackage-b_$(date +%y%m%d_%H%M)_$(hostname)
dpkg-buildpackage: info: source package util-linux
dpkg-buildpackage: info: source version 2.29.2-1
dpkg-buildpackage: info: source distribution unstable
dpkg-buildpackage: info: source changed by Andreas Henriksson <andreas@fatal.se>
 dpkg-source --before-build util-linux-2.29.2
dpkg-buildpackage: info: host architecture amd64
dpkg-checkbuilddeps: error: Unmet build dependencies: dh-exec (>= 0.13) libcap-ng-dev libncursesw5-dev libpam0g-dev libselinux1-dev (>= 2.6-3~) libsystemd-dev systemd
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
~/src/util-linux-2.29.2$

What do I do here?

Last edited by miroR (2017-07-12 11:51:47)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#6 2017-07-11 02:17:06

zapper
Member
Registered: 2017-05-29
Posts: 54

Re: OpenRC installation in Devuan Ascii

If I could give you an attachment, I would...
but since I cannot on the forum or mail-list
I will make it simple, you need three certain packages from a later version...

libfdisk1_2.29.2-1+devuan1_amd64.deb
util-linux_2.29.2-1+devuan1_amd64.deb
sysvinit-utils_2.88dsf-59.9_amd64.deb


then you install initscripts from proposed upgrades for devuan ascii.

then type:  sudo apt install -s openrc

just to see if I am correct.

if I am, you install it. simple yes?

I think so anyways.. wink

to install the first three packages, use dpkg instead of gdebi or it will utterly fail each time.

ps, if you give me your email, I can send them to you.  It can be an alias if you prefer... I will pm you if you want.
also, I would install initscripts with aptitude and finally, let us know if you fail. By us, I mean the community. wink

if you need those three packages, I have them. smile

Last edited by zapper (2017-07-11 02:31:56)

Offline

#7 2017-07-11 02:21:11

zapper
Member
Registered: 2017-05-29
Posts: 54

Re: OpenRC installation in Devuan Ascii

Dev1 wrote:

Stop dreamin !

This isn't a dream, I just gave him instructions. Although he should be aware that it just because it works for me doesn't mean it will work as well for him. Or at least that's what I am inclined to think, I could be wrong...

Offline

#8 2017-07-11 02:27:21

golinux
Administrator
Registered: 2016-11-25
Posts: 654

Re: OpenRC installation in Devuan Ascii

@zapper . . . you can email members of this forum (if they allow it) from their user info on any post or from their user profie.

Online

#9 2017-07-11 02:32:18

zapper
Member
Registered: 2017-05-29
Posts: 54

Re: OpenRC installation in Devuan Ascii

golinux wrote:

@zapper . . . you can email members of this forum (if they allow it) from their user info on any post or from their user profie.

Ah okay, Thanks. I will try then.

Offline

#10 2017-07-11 10:27:26

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

First I apologies for being late.
The temperature reaches even 37 degrees C here even in the shadow today, and also it's July 11th, the 22nd anniversary of Srebrenica genocide, and I watch Bosnian TV channels on this day (on another Devuan machine, with --old-- TV-cards in it)...

zapper wrote:

If I could give you an attachment, I would...
but since I cannot on the forum or mail-list
I will make it simple, you need three certain packages from a later version...

libfdisk1_2.29.2-1+devuan1_amd64.deb
util-linux_2.29.2-1+devuan1_amd64.deb
sysvinit-utils_2.88dsf-59.9_amd64.deb
...
to install the first three packages, use dpkg instead of gdebi or it will utterly fail each time.

(for other readers) I have, in the meantime, received the three packages from zap.

I don't even know what is gdebi. dkpg and apt are my best friends these days...

The first try with installing of those went like this:
# dpkg -i libfdisk1_2.29.2-1+devuan1_amd64.deb util-linux_2.29.2-1+devuan1_amd64.deb sysvinit-utils_2.88dsf-59.9_amd64.deb

(Reading database ... 184288 files and directories currently installed.)
Preparing to unpack libfdisk1_2.29.2-1+devuan1_amd64.deb ...
Unpacking libfdisk1:amd64 (2.29.2-1+devuan1) over (2.28-1+devuan3) ...
dpkg: regarding util-linux_2.29.2-1+devuan1_amd64.deb containing util-linux, pre-dependency problem:
 util-linux pre-depends on libfdisk1 (>= 2.29~rc2)
  libfdisk1:amd64 latest configured version is 2.28-1+devuan3.

dpkg: error processing archive util-linux_2.29.2-1+devuan1_amd64.deb (--install):
 pre-dependency problem - not installing util-linux
Preparing to unpack sysvinit-utils_2.88dsf-59.9_amd64.deb ...
Unpacking sysvinit-utils (2.88dsf-59.9) over (2.88dsf-59.3+devuan2) ...
Replacing files in old package initscripts (2.88dsf-59.3+devuan2) ...
Setting up libfdisk1:amd64 (2.29.2-1+devuan1) ...
dpkg: dependency problems prevent configuration of sysvinit-utils:
 sysvinit-utils depends on util-linux (>> 2.28-2~); however:
  Version of util-linux on system is 2.28-1+devuan3.

dpkg: error processing package sysvinit-utils (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 util-linux_2.29.2-1+devuan1_amd64.deb
 sysvinit-utils

#


ps, if you give me your email, I can send them to you.  It can be an alias if you prefer... I will pm you if you want.
also, I would install initscripts with aptitude and finally, let us know if you fail.
...

It's only the hot day, and the Srebrenica anniversary the reasons that I'm late...

I think I have to play a little with preferences to allow for these packages to be accepted by apt...

Last edited by miroR (2017-07-11 10:28:09)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#11 2017-07-11 10:42:44

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

I stuck these in preferences:

# cat > /etc/apt/preferences.d/ascii-pin
Package: *
Pin: release n=ascii
Pin-Priority: 1001 
#

That's just from:

https://lists.dyne.org/lurker/message/2 … ad.en.html
AMPROLLA GLITCH: ISSUE SOLVED -- PLEASE READ CAREFULLY

(
but readers, if you're not advanced, see the corrections to it in its thread, as well as what I explained about it in:

Broken packages in Ascii, how to fix? (Beware of Debian Stretch)
https://dev1galaxy.org/viewtopic.php?id=1115
)

And let me see if I can install those packages now...

Yes, that did it:

# dpkg -i libfdisk1_2.29.2-1+devuan1_amd64.deb util-linux_2.29.2-1+devuan1_amd64.deb sysvinit-utils_2.88dsf-59.9_amd64.deb |& tee LOG_/dpkg-i_libfdisk1_2.29.2-1+devuan1_amd64.deb_util-linux_2.29.2-1+devuan1_amd64.deb_sysvinit-utils_2.88dsf-59.9_amd64.deb_$(date +%y%m%d_%H%M)_gdOv 
(Reading database ... 184288 files and directories currently installed.)
Preparing to unpack libfdisk1_2.29.2-1+devuan1_amd64.deb ...
Unpacking libfdisk1:amd64 (2.29.2-1+devuan1) over (2.29.2-1+devuan1) ...
Preparing to unpack util-linux_2.29.2-1+devuan1_amd64.deb ...
Unpacking util-linux (2.29.2-1+devuan1) over (2.28-1+devuan3) ...
Preparing to unpack sysvinit-utils_2.88dsf-59.9_amd64.deb ...
Unpacking sysvinit-utils (2.88dsf-59.9) over (2.88dsf-59.9) ...
Setting up libfdisk1:amd64 (2.29.2-1+devuan1) ...
Setting up util-linux (2.29.2-1+devuan1) ...
Setting up sysvinit-utils (2.88dsf-59.9) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for man-db (2.7.6.1-2) ...
#

Let me post this.

And a promise. If I install OpenRC (but I haven't installed anything if I haven't installed it in my Air-Gapped master as well, see:
Air-Gapped Devuan Install, Tentative
https://dev1galaxy.org/viewtopic.php?id=746
... so patience is needed... It's getting less hot in my appartment (it looks at East, and is hot in mornings more than afternoons in the summer), so I'll be able to work...

And if I install OpenRC successfully (also in my Air-Gapped, which is likely now that I will...), I'll post those three necessary packages for anyone who wishes to install OpenRC somewher on https://www.CroatiaFidelis.hr ... Just, more patience...

But, before I continue, and for other readers who might be using that KatolaZ recipe, one that acii-pin is used, it must be removed once it is not needed. So...

# rm -v /etc/apt/preferences.d/ascii-pin 
removed '/etc/apt/preferences.d/ascii-pin'
#

Last edited by miroR (2017-07-11 10:44:47)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#12 2017-07-11 11:15:17

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

Svante gave me instructions at:
( the bad subject of that email thread, explained earlier: )
I have a question about libsystemd0 in devuan ascii,
https://lists.dyne.org/lurker/message/2 … 49.en.html

svante wrote:

> Install which packages?

apt-get install sysvinit-core
apt-get install sysvinit-utils #Depends on util-linux see below

And he gave in that email what, I hope, I will eventually have in my system:

Here you should see:

apt-cache policy initscripts
initscripts:
  Installed: 2.88dsf-59.9+devuan2
  Candidate: 2.88dsf-59.9+devuan2
  Version table:
 *** 2.88dsf-59.9+devuan2 100
        100 http://packages.devuan.org/devuan ascii-proposed/main amd64
Packages
        100 /var/lib/dpkg/status
     2.88dsf-59.3+devuan2 500
        500 http://auto.mirror.devuan.org/merged ascii/main amd64
Packages

and similar for sysvinit-core

But I don't have that in my system yet. I have:

# apt-cache policy sysvinit-core

sysvinit-core:
  Installed: 2.88dsf-59.3+devuan2
  Candidate: 2.88dsf-59.3+devuan2
  Version table:
     2.88dsf-59.9+devuan2 100
        100 http://packages.devuan.org/devuan ascii-proposed/main amd64 Packages
 *** 2.88dsf-59.3+devuan2 500
        500 http://packages.devuan.org/merged ascii/main amd64 Packages
        500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages
        500 http://packages.devuan.org/devuan ascii/main amd64 Packages
        100 /var/lib/dpkg/status

#
# apt-cache policy sysvinit-utils

sysvinit-utils:
  Installed: 2.88dsf-59.9
  Candidate: 2.88dsf-59.9+devuan2
  Version table:
     2.88dsf-59.9+devuan2 100
        100 http://packages.devuan.org/devuan ascii-proposed/main amd64 Packages
 *** 2.88dsf-59.9 100
        100 /var/lib/dpkg/status
     2.88dsf-59.3+devuan2 500
        500 http://packages.devuan.org/merged ascii/main amd64 Packages
        500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages
        500 http://packages.devuan.org/devuan ascii/main amd64 Packages

#
# apt-cache policy initscripts

initscripts:
  Installed: 2.88dsf-59.3+devuan2
  Candidate: 2.88dsf-59.3+devuan2
  Version table:
     2.88dsf-59.9+devuan2 100
        100 http://packages.devuan.org/devuan ascii-proposed/main amd64 Packages
 *** 2.88dsf-59.3+devuan2 500
        500 http://packages.devuan.org/merged ascii/main amd64 Packages
        500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages
        500 http://packages.devuan.org/devuan ascii/main amd64 Packages
        100 /var/lib/dpkg/status

#

But I think that should change with:

# apt-get -s install sysvinit-core -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...similar for sysvinit-core
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
Suggested packages:
  bootlogd
The following packages will be upgraded:
  sysvinit-core
1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Inst sysvinit-core [2.88dsf-59.3+devuan2] (2.88dsf-59.9+devuan2 None:2.0.0/ascii-proposed [amd64])
Conf sysvinit-core (2.88dsf-59.9+devuan2 None:2.0.0/ascii-proposed [amd64])

#

# apt-get -s install sysvinit-utils -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  sysvinit-utils
1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Inst sysvinit-utils [2.88dsf-59.9] (2.88dsf-59.9+devuan2 None:2.0.0/ascii-proposed [amd64])
Conf sysvinit-utils (2.88dsf-59.9+devuan2 None:2.0.0/ascii-proposed [amd64])

#

# apt-get -s install initscripts -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  initscripts
1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Inst initscripts [2.88dsf-59.3+devuan2] (2.88dsf-59.9+devuan2 None:2.0.0/ascii-proposed [amd64])
Conf initscripts (2.88dsf-59.9+devuan2 None:2.0.0/ascii-proposed [amd64])

#

That was dry run (as also zap suggested). So next is installing these three above for real, and then installing OpenRC and rebooting...

Last edited by miroR (2017-07-11 11:16:01)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#13 2017-07-11 11:47:19

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

I have just installed OpenRC. No, haven't rebooted yet, so I don't yet know if the installation has been successful.

But here's the report.

Actually, first, I know it's a lot, but it might tell lots of necessary details in case the install was a failure... I have this in place:
# cat /etc/apt/apt.conf

Debug::pkgProblemResolver "on";
#Debug::pkgDPkgPM "on";
Debug::Acquire::ftp "on";
Debug::Acquire::http "on";
Debug::Acquire::gpgv "on";
Debug::BuildDeps "on";
Debug::Hashes "on";
InstallProgress::Fancy "off";
Binary::apt::DPkg::Progress-Fancy "off";
AllowInsecureRepositories "off";

#
That's where all the verbosity derives from smile below.
# apt-get install sysvinit-core -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
Suggested packages:
  bootlogd
The following packages will be upgraded:
  sysvinit-core
GET /devuan/pool/main/s/sysvinit/sysvinit-core_2.88dsf-59.9%2bdevuan2_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/devuan/pool/main/s/sysvinit/sysvinit-core_2.88dsf-59.9+devuan2_amd64.deb
HTTP/1.1 200 OK
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:16:07 GMT
Content-Type: application/octet-stream
Content-Length: 132970
Last-Modified: Thu, 15 Jun 2017 12:08:11 GMT
Connection: keep-alive
ETag: "594278ab-2076a"
Accept-Ranges: bytes

1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 133 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Get:1 http://packages.devuan.org/devuan ascii-proposed/main amd64 sysvinit-core amd64 2.88dsf-59.9+devuan2 [133 kB]
apt-listchanges: Reading changelogs...
Preconfiguring packages ...
Fetched 133 kB in 1s (110 kB/s)
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../sysvinit-core_2.88dsf-59.9+devuan2_amd64.deb ...
Unpacking sysvinit-core (2.88dsf-59.9+devuan2) over (2.88dsf-59.3+devuan2) ...
Setting up sysvinit-core (2.88dsf-59.9+devuan2) ...
sysvinit: restarting... done.
Processing triggers for man-db (2.7.6.1-2) ...
2017/07/11 11:15:50 Reading config from: /etc/paxrat/paxrat.conf

#

# apt-get install sysvinit-utils -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  sysvinit-utils
GET /devuan/pool/main/s/sysvinit/sysvinit-utils_2.88dsf-59.9%2bdevuan2_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/devuan/pool/main/s/sysvinit/sysvinit-utils_2.88dsf-59.9+devuan2_amd64.deb
HTTP/1.1 200 OK
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:16:33 GMT
Content-Type: application/octet-stream
Content-Length: 67750
Last-Modified: Thu, 15 Jun 2017 12:08:11 GMT
Connection: keep-alive
ETag: "594278ab-108a6"
Accept-Ranges: bytes

1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
Need to get 67.8 kB of archives.
After this operation, 27.6 kB of additional disk space will be used.
Get:1 http://packages.devuan.org/devuan ascii-proposed/main amd64 sysvinit-utils amd64 2.88dsf-59.9+devuan2 [67.8 kB]
apt-listchanges: Reading changelogs...
Fetched 67.8 kB in 0s (79.1 kB/s)
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../sysvinit-utils_2.88dsf-59.9+devuan2_amd64.deb ...
Unpacking sysvinit-utils (2.88dsf-59.9+devuan2) over (2.88dsf-59.9) ...
Setting up sysvinit-utils (2.88dsf-59.9+devuan2) ...
Processing triggers for man-db (2.7.6.1-2) ...
2017/07/11 11:16:14 Reading config from: /etc/paxrat/paxrat.conf

#

# apt-get install initscripts -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  initscripts
GET /devuan/pool/main/s/sysvinit/initscripts_2.88dsf-59.9%2bdevuan2_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/devuan/pool/main/s/sysvinit/initscripts_2.88dsf-59.9+devuan2_amd64.deb
HTTP/1.1 200 OK
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:16:58 GMT
Content-Type: application/octet-stream
Content-Length: 85502
Last-Modified: Thu, 15 Jun 2017 12:08:11 GMT
Connection: keep-alive
ETag: "594278ab-14dfe"
Accept-Ranges: bytes

1 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 85.5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://packages.devuan.org/devuan ascii-proposed/main amd64 initscripts amd64 2.88dsf-59.9+devuan2 [85.5 kB]
apt-listchanges: Reading changelogs...
Fetched 85.5 kB in 0s (169 kB/s)
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../initscripts_2.88dsf-59.9+devuan2_amd64.deb ...
Unpacking initscripts (2.88dsf-59.9+devuan2) over (2.88dsf-59.3+devuan2) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up initscripts (2.88dsf-59.9+devuan2) ...
Installing new version of config file /etc/init.d/umountfs ...
Installing new version of config file /etc/init.d/umountroot ...
Installing new version of config file /etc/default/tmpfs ...
2017/07/11 11:16:45 Reading config from: /etc/paxrat/paxrat.conf

And next, I, finally, installed OpenRC (won't bother you with the dry run, kind reader, but I did run it with "-s" first, of course).


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#14 2017-07-11 11:58:36

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

I have just installed OpenRC. No, haven't rebooted yet, so I don't yet know if the installation has been successful.

But here's the report.

Actually, first, I know it's a lot, but it might tell lots of necessary details in case the install was a failure... I have this in place:
# cat /etc/apt/apt.conf

Debug::pkgProblemResolver "on";
#Debug::pkgDPkgPM "on";
Debug::Acquire::ftp "on";
Debug::Acquire::http "on";
Debug::Acquire::gpgv "on";
Debug::BuildDeps "on";
Debug::Hashes "on";
InstallProgress::Fancy "off";
Binary::apt::DPkg::Progress-Fancy "off";
AllowInsecureRepositories "off";

#
That's where all the verbosity derives from smile below.
# apt-get install sysvinit-core -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
Suggested packages:
  bootlogd
The following packages will be upgraded:
  sysvinit-core
GET /devuan/pool/main/s/sysvinit/sysvinit-core_2.88dsf-59.9%2bdevuan2_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/devuan/pool/main/s/sysvinit/sysvinit-core_2.88dsf-59.9+devuan2_amd64.deb
HTTP/1.1 200 OK
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:16:07 GMT
Content-Type: application/octet-stream
Content-Length: 132970
Last-Modified: Thu, 15 Jun 2017 12:08:11 GMT
Connection: keep-alive
ETag: "594278ab-2076a"
Accept-Ranges: bytes

1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 133 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Get:1 http://packages.devuan.org/devuan ascii-proposed/main amd64 sysvinit-core amd64 2.88dsf-59.9+devuan2 [133 kB]
apt-listchanges: Reading changelogs...
Preconfiguring packages ...
Fetched 133 kB in 1s (110 kB/s)
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../sysvinit-core_2.88dsf-59.9+devuan2_amd64.deb ...
Unpacking sysvinit-core (2.88dsf-59.9+devuan2) over (2.88dsf-59.3+devuan2) ...
Setting up sysvinit-core (2.88dsf-59.9+devuan2) ...
sysvinit: restarting... done.
Processing triggers for man-db (2.7.6.1-2) ...
2017/07/11 11:15:50 Reading config from: /etc/paxrat/paxrat.conf

#

# apt-get install sysvinit-utils -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  sysvinit-utils
GET /devuan/pool/main/s/sysvinit/sysvinit-utils_2.88dsf-59.9%2bdevuan2_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/devuan/pool/main/s/sysvinit/sysvinit-utils_2.88dsf-59.9+devuan2_amd64.deb
HTTP/1.1 200 OK
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:16:33 GMT
Content-Type: application/octet-stream
Content-Length: 67750
Last-Modified: Thu, 15 Jun 2017 12:08:11 GMT
Connection: keep-alive
ETag: "594278ab-108a6"
Accept-Ranges: bytes

1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
Need to get 67.8 kB of archives.
After this operation, 27.6 kB of additional disk space will be used.
Get:1 http://packages.devuan.org/devuan ascii-proposed/main amd64 sysvinit-utils amd64 2.88dsf-59.9+devuan2 [67.8 kB]
apt-listchanges: Reading changelogs...
Fetched 67.8 kB in 0s (79.1 kB/s)
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../sysvinit-utils_2.88dsf-59.9+devuan2_amd64.deb ...
Unpacking sysvinit-utils (2.88dsf-59.9+devuan2) over (2.88dsf-59.9) ...
Setting up sysvinit-utils (2.88dsf-59.9+devuan2) ...
Processing triggers for man-db (2.7.6.1-2) ...
2017/07/11 11:16:14 Reading config from: /etc/paxrat/paxrat.conf

#

# apt-get install initscripts -t ascii-proposed

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  initscripts
GET /devuan/pool/main/s/sysvinit/initscripts_2.88dsf-59.9%2bdevuan2_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/devuan/pool/main/s/sysvinit/initscripts_2.88dsf-59.9+devuan2_amd64.deb
HTTP/1.1 200 OK
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:16:58 GMT
Content-Type: application/octet-stream
Content-Length: 85502
Last-Modified: Thu, 15 Jun 2017 12:08:11 GMT
Connection: keep-alive
ETag: "594278ab-14dfe"
Accept-Ranges: bytes

1 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 85.5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://packages.devuan.org/devuan ascii-proposed/main amd64 initscripts amd64 2.88dsf-59.9+devuan2 [85.5 kB]
apt-listchanges: Reading changelogs...
Fetched 85.5 kB in 0s (169 kB/s)
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../initscripts_2.88dsf-59.9+devuan2_amd64.deb ...
Unpacking initscripts (2.88dsf-59.9+devuan2) over (2.88dsf-59.3+devuan2) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up initscripts (2.88dsf-59.9+devuan2) ...
Installing new version of config file /etc/init.d/umountfs ...
Installing new version of config file /etc/init.d/umountroot ...
Installing new version of config file /etc/default/tmpfs ...
2017/07/11 11:16:45 Reading config from: /etc/paxrat/paxrat.conf

And next, I, finally, installed OpenRC (won't bother you with the dry run, kind reader, but I did run it with "-s" first, of course).


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#15 2017-07-11 12:03:57

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

I have indeed installed OpenRC, and...

And, now I can see what ugly message Rick Moen spoke about (in yesterday's message of his on Devuan DNG ML in our thread linked to above, the one with the bad subject/title)...

But my Palemoon started crashing again... And I don't know if I'll post this successfully with it, or will have to use Lynx, or even post it with (significant) delay...

I need to make smaller posts, Lynx has issues posting my huge posts... Already posted what was originally less than a third maybe of the entire post that I prepared... Now splitting more...

OpenRC full install log, first part.

# apt-get install openrc

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following package was automatically installed and is no longer required:
  linux-doc-4.9
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  libeinfo1 librc1
Suggested packages:
  policycoreutils
The following packages will be REMOVED:
  sysv-rc
The following NEW packages will be installed:
  libeinfo1 librc1 openrc
0 upgraded, 3 newly installed, 1 to remove and 2 not upgraded.
Need to get 174 kB of archives.
After this operation, 1,424 kB of additional disk space will be used.
Do you want to continue? [Y/n] GET /merged/pool/DEBIAN/main/o/openrc/libeinfo1_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/o/openrc/libeinfo1_0.23-1+b1_amd64.deb
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:19:08 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/o/openrc/libeinfo1_0.23-1+b1_amd64.deb

GET /merged/pool/DEBIAN/main/o/openrc/librc1_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /merged/pool/DEBIAN/main/o/openrc/openrc_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: packages.devuan.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/o/openrc/librc1_0.23-1+b1_amd64.deb
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:19:08 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/o/openrc/librc1_0.23-1+b1_amd64.deb

Answer for: http://packages.devuan.org/merged/pool/DEBIAN/main/o/openrc/openrc_0.23-1+b1_amd64.deb
HTTP/1.1 302 Moved Temporarily
Server: nginx/1.9.9
Date: Tue, 11 Jul 2017 11:19:08 GMT
Content-Type: text/html
Content-Length: 160
Connection: keep-alive
Location: http://httpredir.debian.org/debian/pool/main/o/openrc/openrc_0.23-1+b1_amd64.deb

GET /debian/pool/main/o/openrc/libeinfo1_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://httpredir.debian.org/debian/pool/main/o/openrc/libeinfo1_0.23-1+b1_amd64.deb
HTTP/1.1 302 Found
Date: Tue, 11 Jul 2017 11:19:09 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/o/openrc/libeinfo1_0.23-1+b1_amd64.deb
Content-Length: 342
Content-Type: text/html; charset=iso-8859-1

GET /debian/pool/main/o/openrc/librc1_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /debian/pool/main/o/openrc/openrc_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: httpredir.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://httpredir.debian.org/debian/pool/main/o/openrc/librc1_0.23-1+b1_amd64.deb
HTTP/1.1 302 Found
Date: Tue, 11 Jul 2017 11:19:10 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/o/openrc/librc1_0.23-1+b1_amd64.deb
Content-Length: 339
Content-Type: text/html; charset=iso-8859-1

Answer for: http://httpredir.debian.org/debian/pool/main/o/openrc/openrc_0.23-1+b1_amd64.deb
HTTP/1.1 302 Found
Date: Tue, 11 Jul 2017 11:19:10 GMT
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Location: http://cdn-fastly.deb.debian.org/debian/pool/main/o/openrc/openrc_0.23-1+b1_amd64.deb
Content-Length: 339
Content-Type: text/html; charset=iso-8859-1

GET /debian/pool/main/o/openrc/libeinfo1_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/o/openrc/libeinfo1_0.23-1+b1_amd64.deb
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Sun, 05 Mar 2017 19:29:17 GMT
ETag: "3d32-54a00cb7a4a72"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-debian-package
Via: 1.1 varnish
Fastly-Debug-Digest: 3520261422c9f122f9923f75ccce2433cd50a4edc5546da059a8ab84cb2a2059
Content-Length: 15666
Accept-Ranges: bytes
Date: Tue, 11 Jul 2017 11:19:10 GMT
Via: 1.1 varnish
Age: 2144632
Connection: keep-alive
X-Served-By: cache-ams4140-AMS, cache-hhn1542-HHN
X-Cache: HIT, HIT
X-Cache-Hits: 1, 1
X-Timer: S1499771951.869008,VS0,VE1

Get:1 http://packages.devuan.org/merged ascii/main amd64 libeinfo1 amd64 0.23-1+b1 [15.7 kB]
GET /debian/pool/main/o/openrc/librc1_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


GET /debian/pool/main/o/openrc/openrc_0.23-1%2bb1_amd64.deb HTTP/1.1
Host: cdn-fastly.deb.debian.org
User-Agent: Debian APT-HTTP/1.3 (1.4.6)


Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/o/openrc/librc1_0.23-1+b1_amd64.deb
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Sun, 05 Mar 2017 19:29:17 GMT
ETag: "8196-54a00cb7a4a72"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-debian-package
Via: 1.1 varnish
Fastly-Debug-Digest: 589d1cb7093f71ddb9538fe6cc55a07024d7b1b844b9d483d34605ca6c8c27e8
Content-Length: 33174
Accept-Ranges: bytes
Date: Tue, 11 Jul 2017 11:19:10 GMT
Via: 1.1 varnish
Age: 427916
Connection: keep-alive
X-Served-By: cache-ams4129-AMS, cache-hhn1542-HHN
X-Cache: HIT, MISS
X-Cache-Hits: 1, 0
X-Timer: S1499771951.917385,VS0,VE10

Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#16 2017-07-11 12:06:11

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

OpenRC full install log, second part.

Get:2 http://packages.devuan.org/merged ascii/main amd64 librc1 amd64 0.23-1+b1 [33.2 kB]
Answer for: http://cdn-fastly.deb.debian.org/debian/pool/main/o/openrc/openrc_0.23-1+b1_amd64.deb
HTTP/1.1 200 OK
Server: Apache
X-Content-Type-Options: nosniff
X-Frame-Options: sameorigin
Referrer-Policy: no-referrer
X-Xss-Protection: 1
Last-Modified: Sun, 05 Mar 2017 19:29:17 GMT
ETag: "1eab8-54a00cb7a4a72"
X-Clacks-Overhead: GNU Terry Pratchett
Cache-Control: public, max-age=2592000
Content-Type: application/x-debian-package
Via: 1.1 varnish
Fastly-Debug-Digest: 78986765a377eecbedff0636d17231028231778972b9ce3307a47024745af27f
Content-Length: 125624
Accept-Ranges: bytes
Date: Tue, 11 Jul 2017 11:19:10 GMT
Via: 1.1 varnish
Age: 96212
Connection: keep-alive
X-Served-By: cache-ams4132-AMS, cache-hhn1542-HHN
X-Cache: HIT, MISS
X-Cache-Hits: 1, 0
X-Timer: S1499771951.927994,VS0,VE10

Get:3 http://packages.devuan.org/merged ascii/main amd64 openrc amd64 0.23-1+b1 [126 kB]
Fetched 174 kB in 2s (74.4 kB/s)
Selecting previously unselected package libeinfo1.
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184291 files and directories currently installed.)
Preparing to unpack .../libeinfo1_0.23-1+b1_amd64.deb ...
Unpacking libeinfo1 (0.23-1+b1) ...
Selecting previously unselected package librc1.
Preparing to unpack .../librc1_0.23-1+b1_amd64.deb ...
Unpacking librc1 (0.23-1+b1) ...
dpkg: sysv-rc: dependency problems, but removing anyway as you requested:
 initscripts depends on sysv-rc | file-rc | openrc; however:
  Package sysv-rc is to be removed.
  Package file-rc is not installed.
  Package openrc is not installed.
 sysvinit-core depends on sysv-rc | file-rc | openrc; however:
  Package sysv-rc is to be removed.
  Package file-rc is not installed.
  Package openrc is not installed.

(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184299 files and directories currently installed.)
Removing sysv-rc (2.88dsf-59.3+devuan2) ...
Selecting previously unselected package openrc.
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 184281 files and directories currently installed.)
Preparing to unpack .../openrc_0.23-1+b1_amd64.deb ...
Unpacking openrc (0.23-1+b1) ...
Setting up libeinfo1 (0.23-1+b1) ...
Setting up librc1 (0.23-1+b1) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up openrc (0.23-1+b1) ...
Add existing services ...
* service killprocs added to runlevel recovery
* service motd added to runlevel recovery
* service bootlogs added to runlevel recovery
* service single added to runlevel recovery
* service console-setup.sh added to runlevel default
* service motd added to runlevel default
* service rsyslog added to runlevel default
* service saslauthd added to runlevel default
* service apache2 added to runlevel default
* service acpid added to runlevel default
* service anacron added to runlevel default
* service atd added to runlevel default
* service clamav-freshclam added to runlevel default
* service cron added to runlevel default
* service gpm added to runlevel default
* service mysql added to runlevel default
* service rsync added to runlevel default
* service smartmontools added to runlevel default
* service exim4 added to runlevel default
* service postfix added to runlevel default
* service bootlogs added to runlevel default
* service rc.local added to runlevel default
* service rmnologin added to runlevel default
* service hostname.sh added to runlevel sysinit
* service mountkernfs.sh added to runlevel sysinit
* service udev added to runlevel sysinit
* service keyboard-setup.sh added to runlevel sysinit
* service mountdevsubfs.sh added to runlevel sysinit
* service hwclock.sh added to runlevel sysinit
* service checkroot.sh added to runlevel sysinit
* service cryptdisks-early added to runlevel sysinit
* service checkroot-bootclean.sh added to runlevel sysinit
* service kmod added to runlevel sysinit
* service cryptdisks added to runlevel sysinit
* service checkfs.sh added to runlevel sysinit
* service mountall.sh added to runlevel sysinit
* service mountall-bootclean.sh added to runlevel sysinit
* service procps added to runlevel sysinit
* service urandom added to runlevel sysinit
* service networking added to runlevel sysinit
* service rpcbind added to runlevel sysinit
* service nfs-common added to runlevel sysinit
* service mountnfs.sh added to runlevel sysinit
* service mountnfs-bootclean.sh added to runlevel sysinit
* service alsa-utils added to runlevel sysinit
* service bootmisc.sh added to runlevel sysinit
* service x11-common added to runlevel sysinit
* service sendsigs added to runlevel off
* service umountnfs.sh added to runlevel off
* service umountfs added to runlevel off
* service umountroot added to runlevel off
* service savecache added to runlevel off
* Caching service dependencies ...
* Found a solvable dependency loop: cryptdisks a> umountfs u> hwclock.sh a> checkroot n> cryptdisks.
* Found a solvable dependency loop: cryptdisks a> umountfs u> hwclock.sh a> checkroot n> cryptdisks-early n> cryptdisks.
* Solving the loop by breaking umountfs u> hwclock.sh.
 [ ok ]
**********************************************************************
*** WARNING: if you are replacing sysv-rc by OpenRC, then you must ***
*** reboot immediately using the following command:                ***
for file in /etc/rc0.d/K*; do s=`basename $(readlink "$file")` ; /etc/init.d/$s stop; done
**********************************************************************
2017/07/11 11:18:57 Reading config from: /etc/paxrat/paxrat.conf

#


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#17 2017-07-11 12:09:28

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

Wow! Maybe it went well...

I now need to try and figure out what that ugly message means:

apt logs wrote:
**********************************************************************
*** WARNING: if you are replacing sysv-rc by OpenRC, then you must ***
*** reboot immediately using the following command:                ***
for file in /etc/rc0.d/K*; do s=`basename $(readlink "$file")` ; /etc/init.d/$s stop; done
**********************************************************************

Hmmh... But I surely do have to just, I guess, just do it...

Will, hopefully... Hopefully, I will be back soon!

Regards! (And Lynx is such steep learning curve to use...)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#18 2017-07-11 12:26:54

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

Isn't this such a beauty? :
# apt-cache policy openrc

openrc:
  Installed: 0.23-1+b1
  Candidate: 0.23-1+b1
  Version table:
 *** 0.23-1+b1 500
        500 [url]http://packages.devuan.org/merged[/url] ascii/main amd64 Packages
        500 [url]http://auto.mirror.devuan.org/merged[/url] ascii/main amd64 Packages
        100 /var/lib/dpkg/status

#
And I did actually see in green, I think OpenRC 0.23 during the boot sequence. It looked so charming!

Yes, I have successfully rebooted. No issues whatsoever, or no issues worth mentioning. Actually no issues related to OpenRC that I saw.

Now, let me first update my Air-Gapped. That's never really so very trivial, and then I'll try and post the packages to https://www.CroatiaFidelis.hr and post a link to the packages for download here in this topic.

Last edited by miroR (2017-07-11 12:27:58)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#19 2017-07-11 12:55:48

fsmithred
Administrator
Registered: 2016-11-25
Posts: 444

Re: OpenRC installation in Devuan Ascii

I haven't been following this discussion, so maybe I have no business posting on this thread, but there are a couple of things bugging me about it.

1. Way up in the early part of this thread I see:

GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1

That surely can't be right. Use devuan repos, not debian.

2. When I run '$ apt-get source util-linux' I see:

Get:1 http://auto.mirror.devuan.org/devuan/ jessie-proposed/main util-linux 2.26.2-6+devuan1

But that is not the version in ascii or even in ceres.

$ apt-cache policy util-linux
util-linux:
  Installed: 2.26.2-6+devuan1
  Candidate: 2.26.2-6+devuan1
  Version table:
     2.28-1+devuan3 0
        100 http://us.mirror.devuan.org/merged/ ascii/main amd64 Packages
     2.27.1-1+devuan0.1 0
        100 http://auto.mirror.devuan.org/merged/ ceres/main amd64 Packages
 *** 2.26.2-6+devuan1 0
        500 http://us.mirror.devuan.org/merged/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status

It appears that there is a newer version in ascii than in ceres (and also I have the wrong version. This is on ascii that was upgraded from jessie, and I still have the jessie version of util-linux.)


If I run '$ apt-get -t ascii source util-linux' I get the version that belongs in ascii:

Get:1 http://auto.mirror.devuan.org/merged ascii/main util-linux 2.28-1+devuan3 

Then I run into the build-dep problem:

builddeps:util-linux : Depends: libudev-dev but it is not going to be installed

because it requires systemd.  So I checked to see if we've devuanized libudev-dev, and it looks like we did it for the version of udev that's in jessie (220) but not for ascii (232).

# apt-cache policy libudev-dev
libudev-dev:
  Installed: (none)
  Candidate: 232-25
  Version table:
     220:3.2.2-devuan2.3 100
        100 http://auto.mirror.devuan.org/devuan experimental/main amd64 Packages
     232-25 500
        500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages

Why does ascii have a newer version of util-linux than ceres?

Shouldn't the source for the ascii version be used for ascii? Just running 'apt-get source util-linux' pulls in sources for a version newer than any in devuan.

Offline

#20 2017-07-11 14:51:24

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

fsmithred wrote:

I haven't been following this discussion

You really should have smile You're wrong this time... Pls. read at least the links to Svante's emails.

, so maybe I have no business posting on this thread, but there are a couple of things bugging me about it.

1. Way up in the early part of this thread I see:

GET /merged/pool/DEBIAN/main/u/util-linux/util-linux_2.29.2-1.dsc HTTP/1.1

That surely can't be right. Use devuan repos, not debian.

2. When I run '$ apt-get source util-linux' I see:

Get:1 http://auto.mirror.devuan.org/devuan/ jessie-proposed/main util-linux 2.26.2-6+devuan1

But that is not the version in ascii or even in ceres.

$ apt-cache policy util-linux
util-linux:
  Installed: 2.26.2-6+devuan1
  Candidate: 2.26.2-6+devuan1
  Version table:
     2.28-1+devuan3 0
        100 http://us.mirror.devuan.org/merged/ ascii/main amd64 Packages
     2.27.1-1+devuan0.1 0
        100 http://auto.mirror.devuan.org/merged/ ceres/main amd64 Packages
 *** 2.26.2-6+devuan1 0
        500 http://us.mirror.devuan.org/merged/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status

It appears that there is a newer version in ascii than in ceres (and also I have the wrong version. This is on ascii that was upgraded from jessie, and I still have the jessie version of util-linux.)


If I run '$ apt-get -t ascii source util-linux' I get the version that belongs in ascii:

Get:1 http://auto.mirror.devuan.org/merged ascii/main util-linux 2.28-1+devuan3 

Then I run into the build-dep problem:

builddeps:util-linux : Depends: libudev-dev but it is not going to be installed

because it requires systemd.  So I checked to see if we've devuanized libudev-dev, and it looks like we did it for the version of udev that's in jessie (220) but not for ascii (232).

# apt-cache policy libudev-dev
libudev-dev:
  Installed: (none)
  Candidate: 232-25
  Version table:
     220:3.2.2-devuan2.3 100
        100 http://auto.mirror.devuan.org/devuan experimental/main amd64 Packages
     232-25 500
        500 http://auto.mirror.devuan.org/merged ascii/main amd64 Packages

Why does ascii have a newer version of util-linux than ceres?

Shouldn't the source for the ascii version be used for ascii? Just running 'apt-get source util-linux' pulls in sources for a version newer than any in devuan.

If you wish I can try and explain what has already been explained (but it's better that you read at least the Svante's emails)...
My Palemoon segfaults unpredictably, I have to post this now... Because I have to keep my promise...

Last edited by miroR (2017-07-11 14:52:22)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#21 2017-07-11 14:54:28

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

UPDATE 2017-07-12 04:17 UT:
After some more discussion on from:
( same bad subject )
https://lists.dyne.org/lurker/message/2 … 02.en.html
I posted below only those packages that are as per
this email, cited the line below from it
not available:

Svante wrote:

These packages still FTBFS in ascii-proposed due to a bug in pbuilder.
I can send them privately to you: i386 or amd64?

and for amd64 and i386 arches.
---

Here are the deb packages:

https://www.croatiafidelis.hr/foss/Devuan-OpenRC/

I will update this with some (minimal) info, such as how to verify those packages...

UPDATE: And that is, they need to have the SHA256 hashes as in my email:
https://lists.dyne.org/lurker/message/2 … 95.en.html

The sums I can stow in this very post as well:

de3a62685fc93c50b975f7435377e0775984dfb2964a0aeea44e0d5d7b6a7a1b libfdisk1_2.29.2-1+devuan1_amd64.deb
5587f1e90a1d504262e740b4f66f93c547ca32aa49026871e8f3e231980ebb30 util-linux_2.29.2-1+devuan1_amd64.deb
dc89cbedc2ea04b0b3a6b304668ef1399ef195ad473d5ce1fdc69a7534226fc1  libfdisk1_2.29.2-1+devuan1_i386.deb
a309e340b75d767bba63a50af65a33cb11302cc45ab4b7e39d3dc4c857a871ac  util-linux_2.29.2-1+devuan1_i386.deb

But on the download dir, there is the SUMS with the same content as above, but also PGP-signed SUMS.sig.
I only claim that I have received to-the-bit those packages that I make available, amd64 packages earlier from zap, and i386 packages from Svante last night.

Old text below here, unchanged.
BTW, it went smoothly in my Air-Gapped master machine... And to see something like this:

OpenRC wrote:

OpenRC 0.23 is starting up Linux 4.9.33-unofficial+grsec170708-18 (x86_64)

and to see it boot so smoothly is a fuzzy warm purple, kind and mighty experience just like Devuan is such a fuzzy warm purple, kind and mighty beast!

Regards!

Last edited by miroR (2017-07-12 04:34:51)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#22 2017-08-13 23:29:52

fsmithred
Administrator
Registered: 2016-11-25
Posts: 444

Re: OpenRC installation in Devuan Ascii

I installed openrc in ascii today after I got the deb packages from Svante. I see you already uploaded them. I did, too - http://distro.ibiblio.org/refracta/files/openrc/
(I'll use your links below, but if those don't work for someone, they can replace them with the ibiblio address)


Here's what I did, in a nutshell:

Add to /etc/apt/sources.list

deb http://auto.mirror.devuan.org/devuan ascii-proposed  main

Download debs:

for amd64

wget https://www.croatiafidelis.hr/foss/Devuan-OpenRC/libfdisk1_2.29.2-1+devuan1_amd64.deb
wget https://www.croatiafidelis.hr/foss/Devuan-OpenRC/util-linux_2.29.2-1+devuan1_amd64.deb

for i386

wget https://www.croatiafidelis.hr/foss/Devuan-OpenRC/libfdisk1_2.29.2-1+devuan1_i386.deb
wget https://www.croatiafidelis.hr/foss/Devuan-OpenRC/util-linux_2.29.2-1+devuan1_i386.deb

Run these commands in the following order.

apt-get update
apt-get -t ascii-proposed install sysvinit-core
dpkg -i libfdisk1_2.29.2-1+devuan1_amd64.deb
apt-get -t ascii-proposed download sysvinit-utils
dpkg -i sysvinit-utils_2.88dsf-59.9+devuan2_amd64.deb util-linux_2.29.2-1+devuan1_amd64.deb
apt-get -t ascii-proposed install initscripts
apt-get install openrc

When openrc is finished installing, you will get the warning that's a couple of posts above this. You have to run a long command before rebooting. Do yourself a favor and use an x- terminal rather than plain console, so you can copy/paste.

Here's a live iso with openbox, eudev and openrc (amd64 only):
http://distro.ibiblio.org/refracta/file … 3_2222.iso
login/password  root/root and user/user

Offline

#23 2017-08-21 12:02:54

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 364
Website

Re: OpenRC installation in Devuan Ascii

bits and pieces from my X0rg.log

    80.388] (==) ModulePath set to "/usr/lib/xorg/modules"
[    80.388] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    80.388] (II) Loader magic: 0x557ea4a64e00
[    80.388] (II) Module ABI versions:
[    80.388] 	X.Org ANSI C Emulation: 0.4
[    80.388] 	X.Org Video Driver: 23.0
[    80.388] 	X.Org XInput driver : 24.1
[    80.388] 	X.Org Server Extension : 10.0
[    80.389] (++) using VT number 1

[    80.389] (EE) systemd-logind: failed to get session: The name org.freedesktop.login1 was not provided by any .service files
[    80.389] (II) xfree86: Adding drm device (/dev/dri/card0)
[    80.407] (II) LoadModule: "intel"
[    80.407] (WW) Warning, couldn't open module intel
[    80.407] (II) UnloadModule: "intel"
[    80.407] (II) Unloading intel
[    80.407] (EE) Failed to load module "intel" (module does not exist, 0)
[    80.407] (II) LoadModule: "modesetting"
[    80.407] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    80.407] (II) Module modesetting: vendor="X.Org Foundation"
[    80.525] (II) Loading sub module "fb"
[    80.525] (II) LoadModule: "fb"
[    80.525] (II) Loading /usr/lib/xorg/modules/libfb.so
[    80.525] (II) Module fb: vendor="X.Org Foundation"
[    80.525] 	compiled for 1.19.2, module version = 1.0.0
[    80.525] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    80.525] (II) UnloadModule: "fbdev"
[    80.525] (II) Unloading fbdev
[    80.525] (II) UnloadSubModule: "fbdevhw"
[    80.525] (II) Unloading fbdevhw
[    80.525] (II) UnloadModule: "vesa"
[    80.525] (II) Unloading vesa
[    80.525] (==) Depth 24 pixmap format is 32 bpp
[    80.525] (WW) glamor requires at least 128 instructions (64 reported)
[    80.525] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
[    80.525] (EE) 
Fatal server error:
[    80.525] (EE) AddScreen/ScreenInit failed for driver 0

I gave up

Offline

#24 2017-08-29 16:29:45

miroR
Member
From: Zagreb, Croatia
Registered: 2016-11-30
Posts: 136
Website

Re: OpenRC installation in Devuan Ascii

fsmithred wrote:

I installed openrc in ascii today after I got the deb packages from Svante. I see you already uploaded them. I did, too - http://distro.ibiblio.org/refracta/files/openrc/

Great that users now have more than one place to go for these packages!

Here's what I did, in a nutshell:

Add to /etc/apt/sources.list

deb http://auto.mirror.devuan.org/devuan ascii-proposed  main

Download debs:
...
[ they're in both locations ]
...

Run these commands in the following order.

apt-get update
apt-get -t ascii-proposed install sysvinit-core
dpkg -i libfdisk1_2.29.2-1+devuan1_amd64.deb
apt-get -t ascii-proposed download sysvinit-utils

But this one:

dpkg -i sysvinit-utils_2.88dsf-59.9+devuan2_amd64.deb \

That one is in the repos, no need to download it from either of our places, and anyway it is not in either CroatiaFidelis.hr nor ibiblio.org, that one above...

CORRECTION...Aaah... I see. You wrote above:

...
apt-get -t ascii-proposed download sysvinit-utils
...

and of course, your instructions are correct. Had to post quickly. Still busy, sorry again!

    util-linux_2.29.2-1+devuan1_amd64.deb
apt-get -t ascii-proposed install initscripts
apt-get install openrc

...

Here's a live iso with openbox, eudev and openrc (amd64 only):
http://distro.ibiblio.org/refracta/file … 3_2222.iso
login/password  root/root and user/user

I've just downloaded ascii_oblx_eudv_oprc-20170813_2222.iso:

gpg: Signature made Sun 13 Aug 2017 22:40:15 UTC
gpg:                using RSA key D95DDF2BF71AAAEB
gpg: Good signature from "fsmithred (aka fsr) <fsmithred@gmail.com>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: C369 694A 33F3 51CB 848D  93E7 D95D DF2B F71A AAEB

and will be using it on my next Air-Gap building and cloning, can't wait smile !
BTW, I might be in some difficulties, but it's hard to tell:

From SPDY to Hauppauge Card Firmware Issues
https://www.croatiafidelis.hr/foss/cap/ … -spdy-HVR/

(and I had other issues and worries...)

@fungus (quick cas gotto go): those don't look like OpenRC issues... I don't have any of those... But I have a really lean system, sans-dbus...

Last edited by miroR (2017-08-29 16:37:00)


Devs/testers/users of FOSS, what might be ahead for GNU/Linux after we lost PaX Team and spender? spender wrote:
https://forums.grsecurity.net/viewtopic … 699#p17127
Google made the choice to engage in underhanded competition against us with our own code...
grsecurity ripoff by Google, w/ Linus approval https://lists.dyne.org/lurker/message/2 … 4b.en.html

Offline

#25 2017-10-01 01:26:34

MiyoLinux
Member
Registered: 2016-12-05
Posts: 289

Re: OpenRC installation in Devuan Ascii

Finally gave this a try today...

32 bit Devuan Ascii Openbox using OpenRC.

Boots up at 65 MBs of RAM. big_smile

WOW! Incredible work guys! Thank you!


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

Board footer